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Chapter 1. Accessing the console

The console is the visible face of BigFix, used by the operator to monitor and
repair networked computers running the BigFix client. To begin using the console,
you must be authorized. There are two kinds of console user:

* Operators, who manage the day-to-day operation of the program, including
Fixlet management and action deployment, subject to the management rights
assigned by a site administrator or master operator.

* Master Operators, who are operators with the added authority to assign
management rights to other console operators. Master operators can also:

— Create new computer settings, which allow clients to be labeled for various
groupings.

— Create or edit retrieved properties, which are used to filter and sort
computers.

— Change the BigFix client heartbeat, to optimize the program's performance.

— Subscribe or unsubscribe from sites.

— Create custom actions (if that option was selected for this deployment).

When you have your credentials, you are ready to operate the console:
1. Start the console by double-clicking its desktop icon or select it from the
Programs menu: Start / Programs / IBM BigFix / IBM BigFix Console.

2. Log in to the console using one of the following notations for the username:

username
username@domain
domain\user

3. After you initialize the action site, the console opens and begins to import
Fixlet. After it finishes, it forwards the Fixlets to the installed clients, which
evaluate them and return the results. This process can take a few minutes.

Console authentication using Windows session credentials

You can log in to the BigFix console using your Windows Active Directory user
credentials if the following conditions are met:

* You integrated BigFix with the Active Directory domain as explained in
[Active Directory” on page 66

* The system where the BigFix console is installed belongs to the Active Directory
domain.

* Your user ID is defined as:
— BigFix operator with the necessary authorizations to use the console.
— Active Directory domain user on the system where the console is installed.

Note: If you want to enable SSL, specify the Generic LDAP option and, if your
environment contains child domains, the port number 3268 which points to the
Global catalog.

If these conditions are satisfied, when you access the console, the login window is
automatically populated with your domain credentials and you can click Login to
enter the console.

© Copyright IBM Corp. 2010, 2015 1



B Login to IBM BigFix

SEFVEr:
ComputerMame :]

Iser manne!

bigfix_admin

Password:

[ Use Windows session credentials

Login -~ | Gt

Note: This authentication method is valid only for BigFix servers running on
Windows operating systems.

Introducing the BigFix console user interface

The Main Console window for BigFix has a panel on the left containing buttons
and navigation trees called the Domain Panel. It is designed to group content into
collections pertaining to specific operator domains, such as software patching,
malware protection, power management, and so on. After a domain has been
chosen and topics are selected from the navigation tree, a list of related content is
shown on the right. From this list, specific items can be selected for a more
detailed view in the Work Area beneath the list. Here is a simplified breakdown of
some of the features you might encounter in a typical session:

Domain Panel
This vertical panel on the left provides a high-level view of the extensive
content, allowing you to quickly subdivide the information by major IT
functions. Within each domain, this panel presents navigation trees that
make it easy to zoom in on Fixlet, reports, analyses, and other content.
This panel might be subdivided into sections, depending on the style of
the domain. Some of these sections might include:

Content Filters
If it exists, this section is at the top and provides various content
filters and reports that are a part of the selected domain. Click the
disclosure icon to the left (either a triangle or a plus sign) to
produce a navigation tree to refine your choices.

General Content
This section lets you navigate all the content in the domain. The
content might include Fixlet, tasks, actions, analyses, and
computers, all collected from various sites. Click the disclosure
icon to the left (either a triangle or a plus sign) to open up the tree.

Domain Buttons
At the bottom of the Domain Panel, these buttons represent the set of
domains that are currently available to you. When you subscribe to a site,
it is automatically entered into the correct domain. If a new domain is

2 IBM BigFix: Console Operator’s Guide



required, a button for it is added to this group. At the bottom of the
buttons is a control that allows you to adjust the number of buttons to
display.

Console Toolbar
This toolbar allows you to navigate back and forth through the items you
have selected from the Domain navigation tree. These Back and Forward
buttons act like their counterparts in a browser, and are an important
method for navigating through your content. In addition there are buttons
that allow you to display items you might have hidden and items that are
not currently relevant to any of your clients (this allows you to view all the
available content for research or cloning purposes). There is also a refresh
button that reloads content from the database for the console display.

List Panel
This is a listing of the items specified by the content filters and the
navigation trees in the Domain Panel. You can sort this list by clicking the
column headers and you can rearrange the headers by dragging them left
or right. In addition, you can right-click the headers to see a pop-up menu
containing a list of all the possible fields. Check those you want to use as
headers.

Context Menu
This is the menu that opens when you right-click any item in a list.
Different lists have different context menus.

Work Area Toolbar
This bar contains context-sensitive buttons that can run various actions
based on the content of the current work area. It also contains two icons,
upper right, that let you maximize or detach a specific document.
Detaching allows you to examine more than one document at a time.

Work Area
Below the List Panel and the Work Area Toolbar is the Work Area. When
you click an item from the List Panel, the console opens a detailed
document in this window. The following list describes, for example, the
elements of a Fixlet:

Document tabs
Each type of document has a unique set of tabs to go along with it.
For a Fixlet, the tabs include items such as Description, Details,
Applicable Computers, and Action History.

Fixlet When a Fixlet is opened from the list, the default Description tab is
selected and the Fixlet document explains the issue in plain
English.

Action Button
A Fixlet document typically contains at least one Action,
represented by a link in the Work Area (also available from the
Take Action button in the Work Area Toolbar). Click it to deploy
the Action across your network.

Below is a screen shot from a typical session. A subset of Fixlets and Tasks have
been selected from the Domain navigation tree, and the user is viewing the
description of a Task opened from the list panel:

Domain Panel Console Toolbar List Panel Context Menu

Chapter 1. Accessing the console 3
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In general, your workflow proceeds first from the Domain Panel to the List Panel.
After selecting an item from that list, you follow the instructions in the Work Area
to complete the task.

How you proceed depends on the content type. Fixlet describe problems that have
been discovered on one or more clients. Analyses present you with information
collected from the clients on your network. The computer branch of the tree allows
you to examine specific clients under your control.

For example, if you select Fixlets from the Domain Panel, a list of the relevant
Fixlets is shown in the List Panel. Select one from the list and it is shown in the
Work Area below. The Fixlet document presents you with a short, clear explanation
of a problem that is currently affecting your clients. If you want, you can inspect
the underlying code used in the relevance expression and the proposed actions by
clicking the Details tab. When you have decided to deploy the action to the
affected computers, click the action (represented by a button in the Work Area
Toolbar or a hyperlink in the Work Area) and follow the prompts. After deploying
the action, the affected clients are remediated and no longer report the problem. At
that point, the Fixlet is removed from the relevant Fixlet list.

You can set preferences that govern how responsive and secure you want your
network to be. To adjust the default values, select Preferences from the File menu.
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A sample console operator's workflow

BigFix is a powerful and feature-packed program that might seem overwhelming
to a new user. However, when you understand the typical workflow, the operation
becomes straightforward and intuitive. Let's run through a sample session:

1.
2.

3.

Start up the BigFix Console.

From the Domain Panel on the left, click the button labeled All Content, which
lets us view all subscribed sites. Then click the Fixlets and Tasks item at the
top of the Domain panel. This then displays a list of the Fixlet and Tasks that
are currently applicable to your network in the List Panel to the right.

File Edit View Go Tools Help

wl Back = Forward = | %" Show Hidden Content ¥ Show Mon-Relevant Content | ;:-’T Refresh Console

All Contgy « Al [Search Al ol B
ié_ﬁii‘x\etsandTasksfl.Q ‘_ Name 2 Source Severity  Site Applicable Co...  Open Actic *
“ =E|3<g]| (;--927) || Ms09-026: Vulnerability in RPC Coul... Important Patches for Win.. 1/2 0
] I:f:‘;) F MS09-037: Vulnerabilities in Microso... Critical Patches for Win.. 1/2 0
T N/
- e MS09-041: Vulnerability in Worlstati... Moderate Patches for Win.. 1/2 0
s B A (:TJ M509-044: Vulnerabilities in Remote... Critical Patches for Win... 1/2 0
E U;ﬂspecwf\ed | MS503-048: Vulnerabilities in Windo...  Critical Patches for Win.. 1/2 ]
. B Low (57) 1 MS503-051: Vulnerabilities in Windo...  Critical Patches for Win.. 1/2 ]
o] -056: Vulnerabilities in Windo... mportant atches for Win... T
B Moderate (156] || MS09-056: Vulnerabi Wind Imp Patches for Wi 1/2 0
- [y Important (]_gﬁ:- — | M503-053: Vulnerability in Local Sec...  Important Patches for Win... 1/2 0 =
. B Critical (50) s Ls i 2 e S & ;
> B By Site
B By Category Fixlet: M509-037: Vulnerabilities in Microsoft Active Template Library (ATL) Could Allow Remote Code Exe.. o' O
> & By Source (/n’ Take Action - | # Edit | Copy |=5 Export | Hide Locally Hide Globally | 2 Remove
> B By Source Release —
Fixlets Only (1.884) Description | Details | Applicable Computers (1) | Action History ('0)|
Tasks Only (93) iy =
4 L mo— L Description 1=l
=) Al Content Microsoft has released a security update that resolves several privately
T reported vulnerabilities in Microsoft Active Template Library (ATL). The
@ BigFix Management - vulnerabilities could allow remote code execution if 3 user loaded a specially
™= crafted component or control hosted on a malicious website. Users whose
‘1. Patch Management W&s are configured to have fewer user rights on the system could be
less iMpacted than users who operate with administrative user rights.
o i : : : : :
ﬁ-' Systeme Hicode After downloading and installing this update, affected computers will no
= longer be susceptible to these vulnerabilities. L

From the List Panel, click a Fixlet of interest. The corresponding document
opens in the Work Area below the list. This is the text of the Fixlet, which gives
you the information you need to decide on deployment, along with the specific
actions to take.
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Description | Details | Apphcable Computers (1) | Action History (0)

»

Description

This update resolves a problem that can cause programs that use
the Qutdook View Control with Forms 2.0, such as Microsoft Office
Outiook with Business Contact Manager, to stop functioning as
expected after Security Update for Microsoft Gffice Outlock 2007
(KB972363) 15 installed.

Mote: Affected computers may report back as 'Pending Restart
once the update has run successfully, but will not report back
their final status until the computer has been restarted.

MNote: Some Office updates will force the affected computer to
restart without displaying a warning message if Office
apphcations are open when this update is run. To prevent this
from happening, shut down all Office applications prior to applying
this update,

e

File Size: 814.90 KB

Actions

® Click here fg initiate the deployment process

® Click here to it Microsoft Security Bulletin M309-060.

® Click here for informabgn on troubleshooting Office patches

4. At the bottom of the message you find one or more links that initiate actions to
fix the affected computers. Click the action that seems most appropriate. A
Take Action dialog box opens.

& Take Action =a EoR =<
[ET T IET 45354: Security Update for Microsoft Office 2003] Create in domain: lNI Cantent > |
Preset: |Dl.'fault "||. Show anky personal presets Save Precet. Delete Preset..

Torget |Execution | Users | Mecsages | Offer | Post-Action | Applicability | Success Criteria | Action Seript|

Target:
@ Specific computers selected in the list below
2 All computers with the property values selected in the tree below
* The computers specified in the list of names below (one per ling)

» |5 Applicable Computers (1) Computer Ma.. | 05 cPU Last Report Ti.. | Locked
FINAMCE WindP Medi... 3400 MHz Pen... 12/71/2010 104... Mo
m | *
ok | [ Cancel |

5. Use the Target tab to select any subset of affected computers you want to target
with the action. There are several techniques for deploying actions:

Specific computers selected in the list below
The first targeting button lets you select the computers you want from
the panel below right, which lists all those computers for which the
Fixlet is currently relevant. The right-click menu allows you to select all
the computers in the list. This technique limits the Fixlet action to the
specified list.
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All computers with the property values selected in the tree below
Choose the second button to take actions on computers with a set of
specified properties. Until the expiration of the action period, whenever
a computer satisfies the given properties it is targeted. As with all
actions, only the affected computers actually receive the action.

The computers specified in the list of names below
Choose the third button to specify a list of computers.

6. Use the rest of the tabs to prepare your action, including execution schedules,
client messages, extra scripting and more, then click the OK button. For more
information, see the article on the Take Action dialog.

7. When you supply your password, the Fixlet action is deployed throughout
your network, and is applied specifically to each computer that needs it, subject
to any filters you put in place.

This is the process that you use for typical computer maintenance and remediation.
As you explore the interface, you will discover that it can also help you remediate
security issues, inventory your computers, manage your users, and maintain a
detailed audit trail of every patch and upgrade. As varied as these tasks are, they
are all accomplished with a similar workflow. You should experiment to learn
more about the power of this interface.

Chapter 1. Accessing the console 7
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Chapter 2. Fixlets and Tasks

Introducing Fixlets and Tasks

Fixlets and Tasks are central to BigFix. Using Relevance statements, they target
specific computers, remediating only those BigFix Clients affected by an issue.
They are both packaged with an Action script that can resolve the issue with a
simple mouse-click.

Fixlets and Tasks differ mainly in how they get resolved.

* A Fixlet is triggered by a Relevance clause that detects a vulnerability. When an
Action is invoked to remediate the vulnerability, the Fixlet automatically loses
relevance and is thus no longer applicable on that specific BigFix Client. As a
Fixlet Action propagates through your network, you can track its progress with
the Console, Web Reports, and the Visualization Tool. When every BigFix Client
in your network has been remediated, the Fixlet is no longer relevant and it is
removed from the list. If the issue returns, the Fixlet is shown again in the list,
ready to address the issue again.

* A Task comes with one or more Action scripts that help you adjust settings or
run maintenance tasks. It generally stays relevant after its Action script has been
run. Tasks are designed for reapplication and as a consequence, they are often
persistent.

Both Fixlets and Tasks might have a Default Action, allowing you to simply click
from the list to deploy it. They can both be grouped into Baselines, allowing higher
levels of automation. If you create a Baseline of Fixlets or Tasks which all contain
default Actions, you can turn the tedious chores of maintaining a corporate policy
or common operating environment into a single-click operation. In typical
operation, Fixlet relevance contributes to the overall baseline relevance; Task
relevance does not. Similarly, Actions created from a Baseline can be composed of
both Fixlet and Task Actions, and typically only the relevance of the Fixlet Actions
contributes to the decision to run the group. These are defining features of Fixlets
and Tasks. The following table summarizes the differences:

Fixlet message Task

Relevance interpretation: Machine is in remediable Action is available to run in
state this context

To establish success of Relevance becomes false Action runs to completion

remediation:

Contributes to Baseline Yes No

Relevance?

Contributes to Group Action | Yes No

execution?

At any time, you can open a Fixlet or Task to inspect the underlying Relevance
expressions that are used to target the Clients, as well as the Action scripts that are
designed to address the issue. The language is human-readable to give you a high
degree of confidence in both the applicability of the trigger and efficacy of the
remedial Action. You can also see exactly which computers in your network are

© Copyright IBM Corp. 2010, 2015 9



affected by each Fixlet or Task. When propagated, you can then view the progress
and ultimate history of each Action taken on a Client-by-Client basis.

Differences between Fixlets and tasks

If you look at the details in the Fixlet and task definition on the BigFix console,
you see the same entries. What makes the difference between the two are the scope
and the default behavior.

For what concerns the scope:

* Fixlets are used for fixing lack of compliance to enforced rules, in a few words, a
Fixlet takes a known "broken" condition and fixes it.

* Tasks are configuration items to run, in other words, a task takes a

"not-necessarily broken condition" and changes it to something else that is
"not-necessarily fixed".

For example:
* A Fixlet would be Update AntiVirus definition.
* A task would be Run Antivirus scan.

For what concerns the default behaviour:

* When a Fixlet finishes it's action script, it checks the relevance to make sure it
has gone from true, the Fixlet is relevant, to false, whatever was broken is now
fixed, and reports back Fixed when it is done.

* When a task finishes its action script, it does not check the relevance again. If all
the lines in the action script completed then the client considers that action
successful and reports back Complete. For this reason, as a best practice, you are
suggested to set success criteria for the action run by the task to ensure that the
task run and that it was successful.

Viewing Fixlets and Tasks

10

To display a Fixlet or Task,

1. From the navigation tree in the Domain Panel, click the icon labeled Fixlets and
Tasks.

2. From the resulting List Panel on the right, click an item to open it.

The body of the Fixlet message is shown in the Work Area (click the Description
tab if not already selected).
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Frdet: Version of Dbmslpon.dil May Cause Handle Leak on BES Client/Server Components  off ]
&7 Take Action= | o~ Edit | Copy | Export | Hide Locally Hide Globally | 3 Femove

Description | Details | Applicable Computers (1) | Action History (0)

Description

The hsted computers have a version of dbmslpen.dil that
may cause the BES Client, FillDB, and/or GatherDB Services
to keak handles. To resolve this issue, use the acton below
to set a registry key value and disable the "Shared Memory
Met-Library' for SQL Server client,

Important Note: There have been reports of issues caused

by disabling the 'Shared Memaory Net-Library' setting. In

particular, the firewall service may no longer start on =
computers running ISA Server 2004. Please take extra

caution to qualify this setting change in a test environment

prior to use in & production environmeant.

Actions
® Click here to disable the 'Shared Memory Met-Librany

® Click here for more information from Microsoft on how to configure
S0L Server Client Met-Libraries manualhy

When selected, each Fixlet or Task has a window of its own.

Each Fixlet or Task comes with four tabs in the Work Area:

* Description: This is a page providing a descriptive explanation of the problem
and one or more Actions to fix it. The Actions are represented by links at the
bottom of the description page. Click an Action to open the Take Action dialog,
which allows you to further target or schedule the Action. If you accidentally
click an Action hyperlink, before the actual deployment, you always get a
chance to modify (or cancel) the Action.

* Details: This dialog contains the Fixlet/Task properties such as category, security
ID, download size, source, severity, and date. It also lists the code behind the
Relevance expressions and the Actions. At the bottom of this dialog there is a
text box for you to enter a comment that remains attached to this item.

* Applicable Computers: This is a filter/list of all the computers targeted by the
selected Fixlet or Task. You can filter the list by selecting items from the folders
on the left, and sort the list by clicking the column headers.

 Action History: This is a filter/list of any Actions that have been deployed from
this Fixlet or Task. If the item is new, there are no Actions in the list. Like the
other filter/lists in the Console, you can filter the Actions using the left panel,
and sort them by clicking the column headers above the right-hand list.

Monitoring Fixlets and Tasks

When a Fixlet or Task becomes relevant somewhere in your network, BigFix adds
it to the list available under the Fixlets and Tasks icon in the Domain Panel
navigation tree. You can filter this list by opening the icon and clicking the
subcategories underneath. Each icon represents data groupings that you can use to
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narrow down the items in the List Panel on the right. Then, in the listing area
itself, you can sort the items by clicking a column heading.

The list headers include the following information:

Name: The name assigned to the Fixlet message by the author.
ID: A numerical ID assigned to the Fixlet message by the author.

Source Severity: A measure of how serious a Fixlet message is, assigned by the
Fixlet author. Typical values are Critical, Important, Moderate, or Low.

Site: The name of the site that is generating the relevant Fixlet message.

Applicable Computer Count: The number of BigFix Clients in the network
currently affected by the Fixlet message.

Open Action Count: Number of distinct actions open for the given Fixlet
message.

Category: The type of Fixlet message, such as a security patch or update.

Unlocked Computer Count: The number of unlocked computers affected by the
Fixlet.

Download Size: The size of the remedial file or patch that the action downloads.
Source: The name of the source company that provided the Fixlet information.

Source ID: An identification number assigned to the Fixlet to relate it back to its
source.

Source Release Date: The date this Fixlet message was released.

For example, you might filter the Fixlet list by opening the Source Severity folder
and selecting Important to filter out less urgent Fixlet messages.

All Content « Al SeagetfAll p| [m]
4 [ Fixlets and Tasks (1977) * | Name = Source S&Venty  Applicable Co...  Open Action C... T *
. obe Flash Player Required - onscle mportant / u'
gg'gzn g Adobe Flash Player Required - BES C | Imp 1/7 0 S
= > :]E:c(; EVEIDY BES Clients using Main BES Serverinstead ...  Important 1/7 0 Su
/
<Unspecified> (14 BES Clients using Main BES Serverinstead ...  Important 1/7 0 Su
N/A (67) i |=| | Missing Office Web Components - BES Co...  Important 3/7 0 Su
u}.specified @ || | MSD8-047: Vulnerability in IPsec Policy Pro.. Important 1/2 0 Se
s MS508-049: Vulnerabilities in Event System ... Important 1/2 0 Se
Moderate (156 MB50E-052: Vulnerabilities in GDI+ Could All.. Important 1/2 0 Se
Important t]_gg] | | MS08-067: Vulnerability in Server Service .. Important 1/2 0 Se
P R R S PR - S
> By Catego
& By Eet Fixlet: Adobe Flash Player Required - BES Console o O

File Edit View Go Tools Help
m Back = B Forward « | @ Show Hidden Content " Show Mon-Relevant Content | ' Refresh Conso\gf

» B3 By Source
> El By Source Release Date é‘-’TakeActionv | 7 Edit | Copy |2 Export | Hide Locally Hide Globally | M Remove
Fixlets Only (1.884) o e
Tasks Only (93) Description | Details ! Applicable Computers (1) | Action History (1)!

......... Description | 3

%) All Content [
Adobe Flash Player 9 or greater needs to be installed for Internet
@ BigFix Management Explorer to use many dashboards and wizards in the BES Console.

‘l. Patch Management
- Note: Starting with Internet Explorer 10, Adobe Flash Player is a
%__ Systems Lifecycle built-in add-on.

Then you could sort the Fixlet messages by Applicable Computer Count (which
shows the number of affected computers) to find which Fixlet messages are
relevant to the greatest number of computers. If you do not see one of the columns
listed above, right-click in the Fixlet header and select it from the pop-up menu.
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Commenting on Fixlets and Tasks

You can attach a comment to a Fixlet or Task that other operators can read.
1. From the Domain Panel, select Fixlets and Tasks from the navigation tree.
2. Select a Fixlet or Task from the List Panel on the right by clicking it.

3. From the document panel below, select the Details tab and scroll to the bottom.

Endet: WMS0E-051: Yulnersbilities in Microsolt PowerPoint Could Allow Remc. & L

47 Take Action = | # Edit | Copy [YExport | Hide Locally Hide Globally

L

D-escrip‘t'mn. Detals Applicable Computers (1) | Action History (0}

| = Comments

Comment Console Operator Time Entered

Mo
comments.

i' Add Comment J [

4. Type your comment into the text box and click the Add Comment Button.

Your comment is name- and time-stamped for other operators to view it. In

addition to Fixlets and Tasks, you can attach comments to Actions, Computers, and
Analyses.

Creating or Customizing Fixlets and Tasks

To create your own custom Fixlet or Task message from scratch,
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Select Tools > Create New Fixlet or Task. This opens a creation dialog with
blank fields for you to fill in.

Y Creste ot o
Name: Createin site: | Master Action Site -
Create in domain: [.ﬂll éol;'ll:l‘ll : vl

| Description ;.iﬁt-iomlllﬂ.d-ewance [-I;rqgtrﬁ-ies.:

B I U |i=:i=|iEE | & # &'

i Description

| <enter a description of the problem and the comrective action here>

Actions

L] Ciickjﬂﬂﬁlm deploy this action.

i QK Cancel

Note: To remove incorrect characters from the dialog, right-click the window,
select Encoding and select the appropriate language. Close and reopen the
window.

Note: The maximum length for Fixlet or Task names is 255 characters.

You might also want to customize a Fixlet or Task. You can do this by cloning
and modifying an existing one. To do this, first select the desired Fixlet or Task
from the List Panel, then select Edit > Create Custom Copy (or right-click the
item and select Create Custom Copy from the context menu). The appropriate
creation dialog opens, but this time it is filled with the original content.

] Create Fidet =l 5 w3
(TSP 3 rinistrative Login Needed Createinsite: | Master Action Site -
Create in domain: :.ﬁll éﬂl;‘t.l:ﬂt : ']

| Description t;:tuons[ Relevance |-Prqpe|:;i.e:-:_

Description

The listed computers have a pending operation scheduled in the registry under the
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft Windows\CurrentWersion\RunOnce key This
pending operation is scheduled to be run the next time an administrative user logs into the operating
system.

Usually, the pending operations are required to complete argnslallation that requires a restart. A user
should log on to these computers as soon as passible in order to ensure that all patches and
applications install completely.

Note: Installations and patches that require a user to login usually require that the user have
administrative privileges to complete the installation. if a user does not have administrative prileges,
they may receive a wamning when they log in that they have insuficient prvleges to finish the
installation.

i OK | Concel |

Either way, the Create dialog provides the same options. Enter the name of
your customized message in the top left text box. This serves as the title when
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the Fixlet or Task is displayed. You can use the name for sorting and filtering,
so create a consistent naming convention to make your content more
manageable.

Choose the Site and Domain to host it from the drop-down menus, upper
right.

Next, click through each of the tabs to further define your Fixlet or Task.

Description: Enter your descriptive text in this box. You can use the text
manipulation toolbar at the top of the dialog to enhance the formatting.

Actions: Define your action in this dialog. Use the buttons at the right to add,
delete, or change the position of the action. Below that is an area to customize
the properties of the action. Choose the Script Type from the drop-down menu.
Below that is a text box where you can enter a new action script or modify the
original.

] Create Fidet
Mame: Custorn Fixlet Createinsite: | Master Action Site vl
- ' : - Create in domain: | All Content |
Description | Actions | Relevance | Properties E
Content ID Script Type Default Action Custom Settings Custom Succe Add
Agtionl BigFix Action Seript 3 Delete |
4 ne L3
Action Properties
Action Mame:  Actionl [+ This action is the default action
Seript Type: . BigFix Action Script ) | || Include action settings locks
. || Include custom success criteria
Action Script:

QK Cancel

There are three check boxes you can use to modify the action:
* This action is the default action. Click this box to create a default action.

* Include action settings locks. Click Edit to the right of this check box to
customize the action setting locks, including start time, end time, day
exclusions, and more. This panel also includes failure and reapplication
behaviors.

* Include custom success criteria, which allows you to specify the conditions
that define the success of the action.

Relevance: Leave the default of applying to All computers, or click a different
button and enter a condition or a relevance statement in the dialog below. This
is how you target your Fixlet or Task to relevant computers. For more
information about the relevance language, see the Inspector Libraries.
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MName: Custom Fixlet Createinsite: | Master Action Site

| Create Fidet = |5 [
v
3

— . - Create in domain: | All Content
Description | Actions | Relevance | Properties | .
This Fidlet will be relevant on the following computers:
@ All computers
Computers which match the condition below

Computers which match all of the relevance clauses below

OK Cancel

6. Properties: Set the properties of your Fixlet or Task, including the category,
download size, date, severity, and more. You can also include the SANS
(SysAdmin, Audit, Network, Security) or CVE (Common Vulnerabilities and
Exposures) ID numbers.

7 Create Fidet e
Marme: Custom Fixlet Create in site: i Master Action Site - i
Create in domain: iAIICon‘tzn! "|

Description | Actions ! Relevance | Properties

Category:

Download Size:

Source: Internal
Source ID:

Source Release Date: 12/2/3010
Source Severity:

CVEID:

SANS ID:

| QK | Cancel

7. When you are satisfied with your definitions, click OK. Because your Fixlet or
Task must be propagated, you are prompted for your private key password.
When you enter it and click OK, it is sent to all the Clients, which evaluate it
for relevance and report back their status. You can then follow the deployment
of your new content in real-time from the Console.

Hiding Fixlets and Tasks

You can hide a Fixlet or Task with the following procedure:
1. From any Fixlet or Task List Panel, select the messages you want to hide.

2. Right-click the desired item and select Globally or Locally Hide from the
pop-up menu (or select Edit > Hiding > Globally/Locally Hide).
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File Edit View Go Tools Help
&l Back ~ W Forward | % Show Hidden Content ¥ Show Mon-Relevant Content e Refresh Console

All Content « A [Search Al 28
- rems e =
& [ Feature Packs (3 ame icable Co... en Action C... ategol oWF
@ SN Applicable C Open A C... Category D
NS e
» By Hotfix (9) ? Block Automatic Delivery of IE 10 - Windo... 31/2 0 Setting <ng g
[ @ Maintenance Wind Blod + ; hdo. 1/2 Open r
% Microsoft Unsuppc_ Block Automatic Delivery of [E& - Window... 1/2 Copy Text r|
Ey Optional (1) T = e L
@ i . Block Automat!r_ Da\!very of [E9 - Window... 1/2 Copy Text with Headers c
- _ || Block Autematic Delivery of IE3 - Window... 1/2 Select All c
@ Eo\lu? B}\d . || Task Windows Update Service - Startup 0. 4/7 c
& ecunty Advisery [ Task: Windows Update Service - Stop thes... 4/7 Globally Hide r

b Bl Security Hotfi (116 )
@ Security Update (7) Globally Unhide
[ service Pack (3) < m Locally Hide
B, setting (7) Task: Block Automatic Delivery of T 10 - Windows 7 SP1/2008 R2 §| Locally Unhide
L & Setup (3)
[ Software Distributii 47 Take Action - | oo B | Copy

I

port | Hide Locally Hig Take Default Action...

i Standby Behavi = Add C t...
s % S::p[): (1;) avor Description | Details I Applicable Computers (1) I Action Histor : S
> ik Tools (2) [= Edit...
< [ | » Description Rernove
N At i Create Custom Copy...
To help our customers become more secure an Export
L distribute Windows Internet Explorer 10 as an
@’ BigFix Management Automatic Updates for Windows 7 SP1 and higH Tt
Windows Server 2008 R2 SP1 and higher for x6 T s
}‘ Patch Management This Blocker Toolkit is made available to those Add To Exsting Baseline... 4
automatic delivery of Internet Explorer 10 to ma3
@ Systems Lifecycle where Automatic Updates is enabled. The Block Create Nea Forlet -
- Note: Create New Task...
B Create New Baseline...
7 items in list, 1 selected. Connected to 'ncd26068.r TCOIT A USEr T anens

The selected Fixlet or Task is no longer displayed in the list. If you chose to hide
the item locally, it is still visible to other Console users. If you are a master
operator, you can hide a Fixlet or Task globally to hide it also from all non-master
users.

Fixlet or Tasks that are hidden are still available and you can restore or "unhide"
them at any time. Here is how:

1.

Click the Show Hidden Content button in the Console Toolbar. All content,
including hidden content, is listed if this button is selected.

N S
File Edit View Go Tools Help
e Back + o o - [ SR TRGBR COERE: show Non-Releant Conten | £ RefeshConso

A single Fixlet or Task can be unhidden by clicking it from a list. In the
resultant Work Area you see an Unhide button. Click it to return the item to its
normal state.
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File Edit View Go Tools Help

<l Back = @ Forward = ‘ ®) Show Hidden Content | 1" Show Non-Relevant Content é} Refresh Console

All Content &

R

E Feature Packs (3)

> [l Hotfix (9)
@ Maintenance Wind

% Microsoft Unsuppe
[ Optional (1) il
@ Product Enhancen
[F Rollup (3) =
@ Security Advisory ()
@ Security Hotfio (116
@ Security Update (7]

3

B

Al Search All =
Mame e Applicable Co..  Open Action C... Category Dowr

A

lock Automatic Delivery of IE10 - Windo., 2 1/2 0 Setting <no ¢
Block Automats -Windo... 1/2 0 Setting <no ¢
Block Automatic Delivery of IE& - Window... 1/2 0 Setting <N ¢
Block Automatic Delivery of IE9 - Window..., 1/2 0 Setting <no ¢
Block Automatic Delivery of IEQ - Window... 1/2 0 Setting <no
Task: Windows Update Service - Startup o..  4/7 0 Setting “no ¢
Task: Windows Update Service - Stop thes.. 4/7 0 Setting <no ¢
a 1 | +
Task: Block Automatic Delivery of IE 10 - Windows 7 SP1/2008 R2 SP1 (164) = B

@ Standby Behavior
@ Support (16)

@’ BigFix Management

‘:. Patch Management

@ Systems Lifecycle

‘r“’TakeActionv | & Edit ‘ Copy ;aé‘;)Expor‘t| Hide Locally Hide Globally| o€ Rermove

|
This task has been locally hidden. I Unhide |

Description | Details | Applicable Computers (1) | Action History (0] |

Description

To help our customers become more secure and up-to-date, Microsoft will
distribute Windows Internet Explorer 10 as an important update through
Automatic Updates for Windows 7 SP1 and higher for x64 and x86 and
Windows Server 2008 R2 SP1 and higher for x64.

This Blocker Toolkit is made available to those who would like to block
automatic delivery of Internet Explorer 10 to machines in environments

wibhmra Aidkametic Lnd=ban ic anshlad The Dlackar Taallib will nak swenien

[

3. Multiple Fixlets or Tasks can be unhidden by selecting them, right-clicking the

group, and choosing Unhide from the context menu, or select multiple items
and select Edit > Hiding > Globally/Locally Unhide.

File Edit View Go Tools Help

4 Back - @ Forward + | Qﬁhow Hidden Content| ¥ Show Non-Relevant Content é? Refresh Conscle

All Content <«
e e

Feature Packs (3)

-

Micresoft Unsuppe
Optional (1) B
Product Enhancerr
Rollup (3] =
Security Advisory (
Security Hotfix (116
Security Update (7)
Service Pack (3)
Setting (7)

i Bl Setup G)

[} Software Distributii
@ Standby Behavior (
Support (16)

Tools (2] %
4| 1l _| [

() AllContent

@) BigFix Management

‘1‘ Patch Management

@: Systems Lifecycle

»

Hotfix (3]
Maintenance Wind <

All [search Al A0
Mameg, - Applicable Co...  Open Action C... Category Dowr
Block Automatic Delivery of IE10 - Windo... ™ /2 0 Setting <nag

¢ Block Automatic Delivery of JE 11 - Windo.. - 2 ™5 —
Bloc 4 b hdow... 1/2 0 ass
Block Automatic Delivery of IED - Window... 1/2 0 Copy Text
Block Automatic Delivery of IE9 - Window... 1/2 a Copy Text with Headers
Task: Windows Update Service - Startupo.. 4/7 a Select All
Task: Windows Update Service - Stop thes.. 4/7 0

Globally Hide
7 = | Globally Unhide
Locally Hide

Task: Block Automatic Delivery of [E11 - Windows 7 SP1/2008 R2 SP|

4 Take Action - | Edit | Copy [% Export | Hide Locally Hid

Locally Unhide

Take Default Action...

Description | Details | Applicable Computers (1) | Action History

Add Comment...

Edit...

Description

Note:

To help our customers become more secure and
distribute Windows Internet Explorer 11 as an in Export
Automatic Updates for Windows 7 SP1 and highe
Windows Server 2008 R2 SP1 and higher for x64|
This Blocker Toolkit is made available to those w
automatic delivery of Internet Explorer 11 to ma
where Automatic Updates is enabled. The Blocke

Remove

Create Customn Copy...

Add To New Baseline...
Add To Existing Baseline...

Create Mew Fixlet...
Create New Task...

7 items in list, 2 selected.

Connected to 'nc926068.ro

Create Mew Baseline...

Generally speaking, it is not necessary to hide Fixlets or Tasks, because you can
simply ignore them. One important reason to hide them is if you have your own
policy that must take precedence. For example, a Fixlet message might suggest that
it is a good idea to install a particular security update, but you might be aware of
reasons why it must not be applied to your network. In this case, hiding the Fixlet
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removes it from the user interface, so you can focus on other content. A master
operator can also hide Fixlets and Tasks that must not be applied by ordinary
operators.

Viewing Relevance Expressions

When a Fixlet message becomes relevant to some computer in your network, you
might want to know exactly what triggered it, and what action is suggested. This
is easy to investigate, because these items are written in the Relevance Language,
which is a human-readable language for probing and acting on computers.

To view Relevance Expressions:

1. Click a Fixlet message from any Fixlet List Panel to open a detailed Fixlet
document in the Work Area below.

2. Select the Details tab.

This opens a page listing various Properties and below that, the Relevance clauses
and Action scripts:

Frdet: Accounts: Rename adrministrater account ™|
&7 Take Action = | # Edit | Copy [iuExport | Hide Locally Hide Globally | 3 Remove

 Description | Details | Applicable Computers (1) | Action History (1) |

+ Relevance

Relevance 1

*3
name of operating system =

"HinXPE"

Relevance 2

*=
(name of operating aystem = "WinXF"} and not
{{{({({name of cperating system as string) starts
with "Win") AND (exists (values "CurrentVersion" of
kays = LOCAL MACHIMENSO AREYMIcC L indows
KI\Curre araicn™ of regiscries as acring)whoae
(it a=s atring a= lowercase=("5.1%)}}) AND not
[exista local user "Administrator™}))
i 1]} ¥

This window shows you how the computer is interrogated and why it has been
triggered as relevant. Typically there are multiple Relevance clauses that are all
ANDed together to determine if a given IBM Endpoint Manager Client is affected.

Scroll down to view the Action script.
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Introducing Relevance

To quickly and non-invasively inspect various aspects of a computer, the
Relevance Language was created. This human-readable language is at the heart of
the program and allows Fixlet authors to target actions to just those computers that
need the fix -- and no others. You can be confident that only broken machines are
being fixed.

The Relevance Language can query an exhaustive set of computer properties, and
do it quickly. Most Console operators rely on other users to write Fixlet messages,
and so their exposure to the Relevance Language is not critical to operating the
Console. However, as a power user, you can customize the Console with short
lines of code from the Relevance Language (called Relevance Expressions) which
grant you an unprecedented amount of control over the BigFix Client computers
on the network.

A typical Relevance Expression might be:
vendor name of processor

This expression returns the name of the manufacturer of the CPU (Intel or AMD,
for example), which can then be used to determine relevance.

You can use Relevance Expressions to create retrieved properties, which you can
then use to organize and filter the Clients in the network. For example, here are
some possible properties that might be useful to know about your BigFix Client
computers:

Table 1. Properties of the IBM BigFix Client computers

Property name Relevance Expression Result

Pentium family name of main True if the processor is a
processor contains "Pentium" | Pentium.

Small drive Total space of drive "c:" < True if the drive is smaller
2000000000 than 2GB.

Bad clock absolute value (now - True if the clock is off by

apparent registration server more than one hour.
time) > 1 hour

IE Version file version of application Version number of Internet
"iexplore.exe" of the registry |Explorer on a Windows
computer.
Mailto App application of key On a Windows computer, the
"HKEY_CLASSES_ROOT\ name of the app that handles
mailto" of the registry mailto requests from a
browser.
Running Word exists running application True if Word is running on a
whose (name of it as Windows IBM Endpoint

lowercase is "winword.exe") | Manager Client computer.

Bios date date of Bios BIOS date on a Windows
computer, if it exists.

Processors number of processors The total number of
processors in the IBM
Endpoint Manager Client
computer.
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Use the Manage Properties dialog to see how these custom properties work. Click
the Add New button, supply the property name, and type in the Relevance
Expression in the text box.

There are thousands of useful Retrieved Properties — far too many to list here. For

a more extensive list of retrieved properties, check the Support Website. For an
in-depth discussion of Relevance, see the Relevance Language Reference.
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Chapter 3. Actions

Actions are scripts that run on selected targets. They are used to fix policy
violation and security exposures and to run configuration steps. Fixlet, tasks, and
baselines depend on actions to run their remediation mission.

Actions are triggered by a console operator using a take action command. They can
be run independently or as part of Fixlets, tasks, or baselines.

An action is described using a proprietary language, the action language. For more
information about the action language, see [Introducing the action language] the
IBM BigFix: Action Guide.

Actions can be used in synergy with relevance expressions to customize a specific
solution for specific BigFix Clients.
There are two types of actions:

Default actions
They are optionally included in Fixlet and tasks at authoring stage. They
run automatically on relevant targets when the Fixlet or the task is
deployed.

You can view the information about the default action, if any defined, in
the Details tab of the Fixlet message or task.

Fidet: Version of Dbmslpen.dil May Cause Handle Leak on BES Client/Server Components |
& Take Action = | .~ Edit | Copy  “vExport | Hide Locally Hide Globally | ¥ Remove

Descript'mn: Dretails Applicable Computers {1} | Action History (0]

* Actions

Actioni
Script Type BigFix Action Script

regsec "[REEY_LOCAL MACHINE)\SOFTWARE\Microsoft\MSSQ
LServer\Clienc]® "SharedMemoryinT=dword: 00000000

Success Criteria

This action will be considered successful when the applicability relevance
evaluates to false. -

Link2

Sy

IYype URL

htop://medn.microsofc.comflibrary/defaultc.asp?
url=flibrary/en-us/adminagl/ad 1 client Tv03.asp

You must run the Take Action command to deploy the related Fixlet or
task. You can still customize on the fly the action when you run the Take
Action command. Depending on the number of Fixlets or tasks that you
want to submit concurrently, one or more than one, you can:

+ |“Taking a default action as part of the deployment of a Fixlet or a task”|

on page 24|
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+ [“Taking multiple actions” on page 26|

Custom actions
They are used to fix problems or to address issues that are not covered by
the default action or to customize the action for your specific environment.
Custom actions override default actions. To create and submit a custom
action you must run the [“Taking a custom action” on page 27| command.

Note: Actions cannot be automatically undone. If you need this capability you
must code it in the action itself.

These are the activities that you can run against actions from the BigFix console:

+ |“Taking actions”]

* [“Monitoring an action taken” on page 28|

+ [“Viewing the details of an action run” on page 30|

* [“Running commands on actions” on page 32|

+ [“Adding a comment” on page 33|

+ [“Making an offer using a custom action” on page 33|

Taking actions

At the heart of the BigFix is the ability to take actions to apply policy or fix one or
many computers. This topic describes how to do it.

These are the different ways to deploy an action:

+ [“Taking a default action as part of the deployment of a Fixlet or a task”]

* [“Take multiple actions” on page 242|

* |“Taking a custom action” on page 27|

Whatever type of take action you choose, this is what happens after you clicked
OK to take the action:

1. The console sends the request to the server.

2. The server stores the action to the op site folder associated with the console
operator who issued it, or the actionsite folder, if the action was issued by the
master operator.

3. The server propagates the action to the computers selected in the Target tab of
the action or to all computers managed by the operator who issued the action.

4. On the computers the applicability of the action is evaluated. If the relevance
expression described in the action is evaluated true then the action is
applicable.

5. If the action is applicable to that computer, the action is pulled from the server
folder down to the computer and it is run.

The computer is added to the Computers tab and the status of the action
running on the computer is updated up to completion.

Taking a default action as part of the deployment of a Fixlet or
a task

You deploy a Fixlet or a task by taking the action that it contains. Follow the
instructions provided in this topic to see how to do it.

1. Click on a relevant Fixlet or task, the content of the selected object is displayed
in the Work area below.
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1y Tasks Only (41
Baselines (0)
Analyses (7)
Actions (6)

#-£2) Dashboards
&-E3 Wizards

-5 Custom Content
£5] Custom Filters

J Computers (2)

4 Operators (1)

Sites (9)

= LDAP Directories (4)
73] Roles (0)

cal | il

Computer Groups (D) ..
Unmanaged Assets (1]

File Edit View Go Tools Help

Description | Details | Applicable Computers (1) || Action Histary (0)

= Back - By # Show Hidden Content ¥ Show Non-Relevant Content i ¥ Refresh Console

| Name Source Seve... | Site
Enable Wake-from-Standby by Magic Packet - Wi... N/A BES Support
Force BES Clients to Run Manual Relay Selection  Lows BES Support
Hide BES Clients from the Add/Remove Program... <Unspecified> BES Support
Install BES Client Helper Service <Unspecified=  BES Support
Install BES Server Plugin Service <Unspecified> BES Support
Install Tivoli Endpoint Manager Relay (Version 8.... <Unspecified> BES Support
Install Tivoli Endpoint Manager Relay on Linux an... <Unspecified> BES Support
Restart Service Lows BES Support
Start Service Lows BES Support
Stop Service Lows BES Support
TROUBLESHOOTING: Disable Mini Dumps <Unspecified>  BES Support
TROUBLESHOOTING: Enable BES Client Usage Pr... <Unspecified> BES Support
£ J
&7 Take Action | Copy | Export  Hide Locally Hide Globally | 3¢

1/2
2/2
1 fa
1/2
1/2
g
T
1/2
1/2
1/2
1/2
2/2

IR =!

| Applicable C... | Open Action ... Categuri_":'

Wake-or
Support
Support
Support
Support
Upgrade
Upgrade,
Commor|
Cummuri
Commor|__|
Support
Troubles|, |

T ooocoocooooooo

2l
L=

Description

Your BES Server does not currently have the BES Server Plugin Service installed.

The BES Server Plugin Service is required by several BigFix Applications to facilitate automation of processes
that require communication with the BES Server and Webreports.

Important Note: This action will create three registry keys. Once the action completes, the values for these
keys must be set for correct functioning of BES Server plugins. To configure the BES Server Plug-in Service,
use Configure SOAP API credentials for BES Server Plugin Service.

You can run the action associated to the Fixlet or to the task in one of these

ways:

* Right-click a relevant Fixlet or a task and choose Take Default Action from
the pop-up menu.
* Click a relevant Fixlet or task and select Take Default Action in the Work
Area toolbar.

* Click a relevant Fixlet or task and select the Description tab. Scroll down to
see the suggested actions. Click the link related to the action that you want

to run.

Note: These options are available only if the selected Fixlet or task contains a

default action.

The Take action dialog opens.
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& Take Action M= X

Mame: | Install BES Server Plugin Service Create in domain: | All Content i ~ |

Preset: Default ,:] [CIshow only personal presets

ffer | Post-Action |

Constraints
[ starts on [ lat |
=
|

Ends on

[J Run between | , and | 59,1 : dient local time

[ Run only on Sun 2 - dient local time

[ run enly when

dient local time

Behavior
[ on failure, retry times

[ reapply this action

[ start dlient downloads before constraints are satisfied

[ stagaer action start times aver 5 minutes to reduce network load

[ Ok l [ Cancel ]

3. In that dialog you can review and, if needed, update the action values. For
more information about the values that you can set in its input fields and tabs,
see [“Take action” on page 240.|

4. When you finish editing, click OK to deploy the action.
5. Enter your authentication password and click OK.

Taking multiple actions

This topic describes how to deploy a set of Fixlets or tasks in a single grouping
using the Take multiple actions command.

As a requirement, each Fixlet or task involved in the group must have associated a
default action.

These is how you can accomplish this task:
1. Right-click a selected group of tasks or Fixlets containing default actions.
2. Select Take Default Action. The Take Multiple Actions dialog opens.
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& Take Mu ltiple Actions

Mame: | Multiple Action Group Create in domain: | All Content | w ;
Preset: I[Custnm] Default | s | [Ishow only personal presets
Target | Execution | Users | Messages | Offer | Post-Action | Pre-Exeaution Action Script | Post-Execution Action Scrit | Appiicabilty.

Target:
() Select devices

() Dynamically target by property
) Enter device names

- Selected Computers (1) fA; Compu... 0s CPU |
=] By Retrieved Properties (Wi %nc926028.r... Linux Red Ha... 1900 MHz Xe... 0¢
®-E5 By Computer Name
=& By 05
Tj Linux Red Hat Enterprise Serve|
£ By CPU
£ By Last Report Time
51 By Locked

[+

E51 By BES Relay Selection Method
= By Relay
#-f] By User Name
=& By RAM
[ 3840 MB (1) ‘
-] By Free Space on System Drive

-5 By Total Size of System Drive
5] By Subnet Address el
< m | | »
[ Ok ] [ Cancel ]

3. In this dialog, specify how the selected actions must be deployed to the
computers in your network. The input fields contained in the dialog are the
same as those contained in the [“Take action” on page 240| display with the
exception of the following additional fields:

Run all members actions of action group regardless of errors
This field belongs to the Execution tab and specifies whether the action
run should stop if an error occurs for one or more object of the group
or not.

Pre-Execution Action Script tab
Lets you specify an Action Script to run before the group of Actions is
deployed.

Post-Execution Action Script
Lets you specify an Action Script to run after the group of Actions is
deployed.

4. When you finish editing, click OK to deploy the action.

5. Enter your authentication password and click OK. A progress dialog opens to
keep you informed about the stage of the deployment.

Note: The difference between grouping Fixlets or tasks and creating a baseline
containing the same set of object is that the objects contained in the baseline are
bound in sequence.

Taking a custom action

This topic describes how to create and take a custom action in one shot using the
Take custom action command.
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These is how you can accomplish this task:
1. Log on to the Console as an Operator with Custom Content permissions.

2. Either select Tools in the main toolbar and then choose Take Custom Action or
right-click with the mouse on an item in the action List panel and select Take
Custom Action. The Take Action dialog opens.

7 Take Action Q@@

Mame: | Custom Action Create in domain: EAII Content .:"V

Preset: Eﬁe.f.aul.t- v"': [ show only personal presets

Target | Execution | Users | Messages | Offer | Post-Action | Applicability | Success Criteria | Action Script

Target:
(®) Select devices
) Dynamically target by property
() Enter device names

= {3 All Computers (1) | compu... 0s CPU
%ncgzﬁﬂzs.r... Linux Red Ha... 1900 MHz Xe... 0f

Ol ] [ Cancel

Fill in the input fields as it is described in [“Take action” on page 240

When you finish editing, click OK to deploy the action.

ook w

Enter your authentication password and click OK.

Monitoring an action taken

This topic explains how you can keep track of the progression of the deployment
of an action taken.

After actions have been scheduled, the BigFix server attempts to signal individual
computers that there are actions waiting for them. Ideally, the BigFix client gathers
the action information from the action site and runs it immediately. More typically
however, some computers are powered off and others are mobile and undocked at
the time of the deployment. As soon as these computers are powered on or docked
to the network, the remedial actions are applied to them as well.

At any time you can see the status of the actions taken from the BigFix console.
You can:

Monitor the overall state of the action
You can see it in the State column of the Actions List panel.
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| A B

Time Issued State % Complete Mame Site

08/07/2013 13.11.28 Open 100,00% (1/1) TROUBLESHOOTIMG: Run BES Client Diagnostics (Linux/UNI{/... BES Support
04/07/2013 14.19.10 Expired RHBA-2011:1114 - Seekwatcher Bug Fix Update - Red Hat Ent... Patches for RHEL ¢
04/07/2013 14.18.30 Expired RHSA-2013:0245 - Java-1.6.0-Openjdk Security Update - Red ... Patches for RHEL ¢
04/07/2013 12.59.51 Expired TROUBLESHOOTING: Run BES Client Diagnestics (Linux/UNIX/... BES Support

The state can be:

Open The action is active on one or more computers. It remains open
until its expiration date elapses, or an operator stops it.

Stopped
The action was stopped by an operator. It remains stopped until its
expiration date elapses or it is removed.

Expired
The expiration date for the action expired. An action expired
cannot be removed.

Monitor the status of the action on selected computers
You can see it in the Computers tab of the selected action .

- |
B stop | Copy [#»Export | X
j E ¥ Computers (1) Target - - - - - )
Computers (1) Status Compu... 0s CPU Last Report ... | Locke

[ completed  nc926028.ro... Linux Red Ha... 1900 MHz Xe... 08/07/2013.. No

To access this dialog:
1. Click the Action icon in the navigation tree.

2. Select an action in the Actions List Panel. Information about the action
is displayed in the Work Area.

3. Select the Computers tab in the Work Area.

For information about the different statuses, see [“Action: Computers” on|
-e 134.

Monitor the action progression on a computer

You can see the result of each step of the action run on a specific computer.
This is shown in the View Action Info dialog.
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TROUBLESHOOTING: Run BES Client Diagnostics (Linux/UNIXMac)

» Summary

The sction executed successhslly b
This action has been applied 1 time and will not be apphied again b
Sratis Completed

Star Tine - DBAOTIZ013 13 1131
End Tme 0807I201213.11.4
Exit Code D

* Action Script Execution Detail

Completed = /7 Remoye previous runs client diagnostics if found

delete "{{preceding text of last I of Jelient folder of
Completed curTent site as atringll & "/ClientDisgnostics " &
computer name: & ".tar.gz™i"

delete ¥ {preceding text of last "/BESClient™ of iclient
Comple‘ted folder of current site &8 STringh) & "ﬁ'CllEnEﬂldﬂECEl’..‘lCd‘_"
& Computer name & ".tar.gztin

delete " {preceding text of last 0% of elient folder of
curTent site &3 stringi) &
i
Comted ry Global/Archive/Last/client O ClientDisgnostics " & .
comoutes name & " tar.ozhi? Sl

To access this dialog:

1. Click the Action icon in the navigation tree.
Select an action in the Actions List Panel.
Select the Computers tab in the Work Area.
Right-click any computer in the list.

Al A

Either select Show Action Info from the context menu or select Show
Action Info from the Edit menu.

For information about the values in this panel, see [“View action info” on|
-ae 247,

Viewing the details of an action run

Follow the indications provided in this topic to see the details about an action that
is being deployed.

To view this information do the following:

1. Click on the Actions icon in the Domain Panel navigation tree.

2. Click an action in the List Panel. The details about the action run are displayed
in the Work Area beneath.

30 IBM BigFix: Console Operator’s Guide



File Edit View Go Tools Help

%= Back - mp ) Show Hidden Content |5 Show Non-Relevant Content| & ¥ Refresh Console
; t « Al B
Fixets and Tasks (810} || Time Issued State % Complete Name Site
24/07/2013 17.21.56 Open 100,00% (1/1) Accept License for Software Use Analysis Master Operator Site
24/07/2013 17.21.25 Open 100,00% (1/1) Accept License for Server Automation Master Operator Site
o Tasks Only (254) 24/07/2013 17.21.05 Open 100,00% (1/1) Accept License for Security and Compliance ~ Master Operator Site
Baselines (0) 24/07/2013 17.20.31 Open 100,00% (1/1) Accept License for Power Management Master Operator Site
@y Analyses (87) 24/07/2013 17.20.13 Open 100,00% (1/1) Accept License for Patch Management Master Operator Site
24/07/2013 16.17.08 Open 100,00% (1/1) Accept License for Lifecycle Management Master Operator Site
£5) Dashboards
-5 Wizards
# E Custom Content
£5) Custom Filters
= @ Computers (2)
Computer Groups (0) |
Unmanaged Assets (0) | %] | 2
74 Operators (1) canse 20
Sites (9) -
LDAP Directories (4) | @ stop | Copy [=:Export | X

& Roles (0) Summary | Reported Computers (1 | Target|
* Status
100,00% Completed (1 of 1 applicable computers)
Status Count Percentage
Completed 1 100,00%
~ Behavior
o Messages
0 e AiLEsns Mo user interface will be shown before running this action.
@ BigFix Management No message will be shown while running this action.
S a Users [+]|

There are three tabs in an action document. They are:

Summary
This tab summarizes the action, with sections on the status of the action
and the progress of the download. It displays information about the
behavior of the Action, including:

* Progress of the download

* Action ID

* Users

* Run options

* Post actions

* Relevance clause

* Text of the action script

* Success criteria

At the bottom of this dialog there is a text box where you can insert a

comment that can be viewed by other operators accessing the same
content site.

For more information about the content of this tab see
[Summary” on page 143

Computers

It shows the computers affected by the specified action and the states of
the action on each of them.The deployed action progresses through a
series of well-defined stages on a given computer.

For information about the values displayed in this tab and the status of
the action on a computer across the different stages, see
[Computers” on page 134.|

Target It shows the targeting method and the subset of computers that was
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originally targeted by the action. The content of this tab is read-only
and it can be static or dynamic depending on the targeting method
specified when the action was taken, explicitly from a list or indirectly
by retrieved property.

For more information about targeting methods and their results, see
[“Action: Target” on page 145

Running commands on actions

32

This topic explains how and which commands you can run on actions.

Do the following to get to the available commands:

1. Click the Actions icon in the Domain Panel navigation tree.

2. Click the action in the List Panel. At the top of the Work Area there is a toolbar
with four icons:

File Edit View Go Tools Help

™ Back -~ B #) Show Hidden Content | ¥ Show Non-Relevant Content| & ¥Refresh Console
« [ I =!
Fidets and Tasks (810) Time Issued State % Complete Name Site
All (810) 24/07/2013 17.21.56 Open 100,00% (1/1)  Accept License for Software Use Analysis Master Operator Site
= [y Fixlets Only (556) 24/07/2013 17.21.25 QOpen 100,00% (1/1) Accept License for Server Automation Master Operator Site
15 Tasks Only (254) 24/07/2013 17.21.05 Open 100,00% (1/1) Accept License for Security and Compliance  Master Operator Site
‘# Baselines (0) 24/07/2013 17.20.31 Open 100,00% (1/1) Accept License for Poveer Management Master Operator Site
& Analyses (37) 24/07/2013 17.20.13 Open 100,00% (1/1) Accept License for Patch Management Master Operator Site
Z Actions (6) 24/07/2013 16.17.08 Open 100,00% (1/1)  Accept License for Lifecycle Management Master Operator Site
-] Dashboards
#-E5 Wizards
®-E5) Custom Content
2] Custom Filters
Computers (2)
Computer Groups (0) |
Unmanaged Assets (0) 1€ ] n | 2|
% Operators (1) 20
Sites (9) -
LDAP Directories (4) @ stop | Copy [“Export | X

£ Roles (0)

Summary | Reported Computers (1) | Target

 Status

100,00% Completed (1 of 1 appli computers)
Status Count | Percentage
Completed 1 100,00%

* Behavior
........ s
@ St Mo user interface will be shown before running this action
.@ BigFix Management Mo message will be shown while running this action.
Lol N Users [s]
Stop  Click this button to halt the deployment of an action that has already

Copy

been triggered but has not expired yet.

This command completes the run on the computers where the action
has already started and prevents the action from running on the
computers where the action has not yet started to run, for example
because of computer unavailability, lack of network connectivity or
gather frequency.As an alternative, you can stop an action by
right-clicking the action and choosing Stop Action from the pull-down
menu or by selecting Stop Action from the Edit menu.

Note: You must enter your password to confirm the action halt.

Click this button to create on the fly a copy of the action to deploy. A
Take Action panel is opened to allow you to customize the copy and
trigger it.
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Note: There is no way to modify the targeting or scheduling of an
action after the deployment is initiated. If you want to modify an action
that has been deployed but has not finished running, you must first
stop the action as it is described here and then start a new action with
the desired characteristics.

Export Click this button to save a copy of this action. Later on you can import
the edited action as a custom action and run it.

Remove
Click this button to delete this action from the database. You can
remove an action only when it is stopped.

The commands that cannot be run on an action in its current state are greyed
out

Adding a comment

BigFix Console operators can make comments on most of the BigFix objects. This
topic describes how to add a comment to an action.

Run these steps to create a comment for an action:
1. Click the Actions icon in the Domain Panel navigation tree.
2. Right-click an action and select Add Comment.

3. Type your comment into the dialog box that opens.

Similarly, you can attach comments to tasks, Fixlet, computers, and analyses. These
comments can include keywords or operating notes. This is a freeform field, so
you can make up your own rules for commenting.

To view an aggregated list of all comments, select View Recent Comments from
the Tools menu.

Recent Comments =]
Object Comment Console Operator Time Entered
Refer to new Admin Policy joe 11672011 3:02:48 PM
Made part of Client package joe 116/2011 3.01:56 PM
Run on all Tokyo systems - 1/15/11 joe 1/16/2011 3:00:22 PM

This dialog lists all the comments created to date, sorted by timestamp, with the
most recent comments at the top. The name of the console operator responsible for
the comment is listed next to the description. Each comment contains a link that
opens the original object in the main window, allowing you to view the description
and other aspects of the object.

Making an offer using a custom action

Follow the instructions provided in this topic if you want to offer to users a set of
downloads that they can select at their own discretion. This capability is also
referred to as self-provisioning.
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34

These offerings are delivered as a type of custom action, so they include all the
targeting and scheduling capabilities that you would expect from a typical action.

Important: These actions run with elevated permissions, so this can be used to
allow non-privileged users the ability to trigger specifically-approved actions that
run with higher permissions.

To advertise such an offer, follow these steps:

1. In the main toolbar select Tools.

2. Select Take Custom Action. The Take Action dialog opens.

3. Click the Offer tab.

| 7 |
4 Take Action M=) <
Mame: | Custom Action Create in domain: EAII Content | ;i

Preset: :[Custom] Default lv! [C]show anly personal presets

| Target || Execution | Users | Messages I Offer 'Postﬂcﬁon Applicability | Success Criteria | Action Script

An action that is made into an "Offer' becomes available in the list of offers in the dient UL on applicable machines. Users can browse
through the list of available offers and apply those that they are interested in. Offers will only be visible to users selected on the
"Users' tab and on machines where the dient Offer UI is enabled.

Make this action an offer
[ Motify users of offer availabiity

Title: Custom Action
Category:
[ ¥|[ [v] A B ru == == === @& ., Z
: o
Custom Action m
Description
‘ ® Click here to accept this offer. ‘
~

[ OK ] [ Cancel ]

For more information about the values that you can set in its input fields and
tabs, see [“Offer tab” on page 220

Click the other tabs in the Take Action dialog to further customize the action
that will advertise your offering.

When you are ready to deploy your offering, click OK.

Your action offer is distributed to all the computers that have been specifically
targeted. This select group of users is then presented with your offer and
prompted to accept it on their own schedule.

Note: This tab is available also when taking a default action as it is described in

“Taking a default action as part of the deployment of a Fixlet or a task” on page]
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Chapter 4. Sites

Introducing Sites

Sites are collections of Fixlet messages that are created internally by you, by IBM,
or by other vendors. You subscribe to a Site and agree on a schedule for
downloading the latest batch of Fixlet messages.

You can view and manage your collection of Sites by navigating to them and
opening them in the Domain Panel. You can add a new Site subscription by
acquiring a Masthead file from a vendor or from IBM. Sites are generally devoted
to a single topic, such as security or the maintenance of a particular piece of
software or hardware. However, several sites might share characteristics and are
then grouped into Domains, which are designed to be in accordance with the
typical job duties of your various Console managers. For example, the person in
charge of patching and maintaining a common operating environment finds
Support sites and Patching sites for various operating systems all bundled in the
Patch Management Domain.

You can set up your own custom Site and populate it with Fixlets that you have
developed specifically for your own network. You and other operators can then
send and receive the latest in-house patches and quickly deploy them to the
appropriate locations and departments.

Selecting Sites

Upon installation, the program is automatically set up to subscribe to certain
management and maintenance sites. Depending on the terms of your license, you
might have subscriptions to other sites as well. This means that content from those
Sites automatically flows into your enterprise and is evaluated for relevance on all
computers running the BigFix Client. These sites, in turn are automatically
registered with an appropriate Domain, providing a simple way to divide the
content into functional sections.

Subscribing to Sites from the License Overview dialog

1. Select the License Overview node from the BigFix Management domain. The
License Overview dialog appears, listing available sites.

2. Click the enable button associated with the site to which you want to subscribe.

3. Enter your password to subscribe to the site. The new site will now be listed in
the Manage Sites node of the domain panel.

4. Open the Manage Sites node and select your newly subscribed site.

5. From the site dialog, click the Computer Subscriptions tab to assign the site to
the appropriate computers.

6. From the Operator Permissions tab, select the operators you want to associate
with this site and their level of permission.

7. Click Save Changes when you are done.
Note: If you change your license, you will need to resubscribe to your Fixlet sites.
Although your new license is associated with your old one, only the Support site

will be automatically renewed.
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Subscribing with a Masthead

To subscribe to a site using a masthead file, follow these steps:

1. First, find an appropriate Site masthead file, which has an extension of .efxm.
There are several ways to do this:

* Fixlet Sites: IBM might post links list to new Sites as they become available.

* Fixlet Subscriptions: Sometimes a Fixlet message might offer a subscription.
Just click the Fixlet action to initiate the subscription.

* Download Mastheads: You can also subscribe to a Site by downloading a
masthead file from a vendor's website.

2. When the masthead is saved to your computer, you can activate it in one of
two ways.

* Double-click the masthead, or

¢ Select Add External Site Masthead from the Tools menu, browse to the
folder containing the masthead, and click Open.

3. You are prompted for your private key password. Type it in and click OK.

The masthead is propagated to all Clients, which immediately begin to evaluate
the Fixlet messages from the new site.

Subscribing with the Licensing Dashboard

You can also subscribe to a Fixlet Site by using the Licensing Dashboard in BigFix
Management, found in the Domain Panel:

1. Open the BigFix Management domain and scroll to the top to view the
associated dashboards.

2. From the Licensing Dashboard, select the sites you want to subscribe to.

Viewing Site Properties

36

After initiating a subscription, you can inspect its properties and signing
authorities. This can be useful when tracking down the origin of a particular Fixlet
message or action. Here is how:

¢ Click the site from the Domain Panel on the left.

The Site Properties are shown in the Work Area, detailing information about the
site publisher and the URL from which the content has been gathered.
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File Edit View Go Tools

Help

il Back = @ Forward » | ® Show Hidden Content | v Show Non-Relevant Content | @Refresh Console

All Content

I £ By Source Release Date
b [ Fixlets Only (1.884)
b [y Tasks Only (93)
@ Baselines (0)
[ @ Analyses (33)
B @ Actions (90)
> B3 Dashboards
> B3 Wizards
> 5 Custom Content
E5 Custom Filters
[ @ Computers (7)
3 @ Computer Groups (3)
[ Unmanaged Assets (20)
Clpscaty

< (1] | b

0 All Content

-

« Sites Search Sites P| [m}

MName : Type Domain Creator k-

BES Asset Discovery External A
BESIn and License External

BES Support External =

External Site: BES Asset Discovery 0

m

1

C

@ BigFix Management

.,t. Patch Management

@3 Systems Lifecycle

BSE‘:EChanges Discard Changes | Gather Add Files.. 3¢ Remove

Details | Computer Subscriptions | Operator Permissions | Rele Permissions

»

LV Details

Type

Current Version
Gather URL
Publisher

Extemal Content Site
77

http://sync_bigfix.com/cgi-bin/bfgather/assetdiscovery
BigFix, Inc.

m

¥ Subscription

All clients that satisfy the externally defined criteria are subscribed to this site.

External Subscription Constraints

Depending on its type, a site might have other properties as well. You can assign a
site to a specific set of computers. A custom site allows you to assign operator
permissions for owning, writing, and reading a Site. External sites (except essential
support sites) can have restrictions placed on both computers and operators,
allowing a Master Operator to fine-tune the domain of a Site.

You can also assign roles to any site, allowing you to select pre-created directory
access roles and grant them read privileges to the site. To access these extra

properties, click the Role Permissions tab.

"1 Extemsl Ste: BES Support

i Marme
: windows
| patch

deskpatch

Sites

it

B}we Changes Discard Changes | Gather Add Files.. 3 Remowe
| Details | Computer Subscriptions | Operator Permissions | Role Pemaissions

Roles with read permission will be able to view this site and take actions baszed on its content,

Permission: Reader
Computers Operators
: 1
o 0
1 1

Permnission
Mone
MNone
MNone

Click a role from the list, and use the buttons to assign or deny reader permissions.
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Restricting Computers

There might be occasions where a BigFix Client or a group of Clients is storing
redundant Fixlet messages, typically due to an overlap in site content. In addition,
some BigFix Clients might collect superfluous Fixlet messages, as when a Linux
machine retrieves Windows Fixlets. This poses no problem to the operation of the
program, which knows to ignore irrelevant or redundant Fixlet messages, but it
might consume Client disk space. The Site Subscription dialog lets you narrow
down the number of clients subscribed to the selected external Site. Here is how:

1. Select the desired site from the Domain Panel.

File Edit View Go Tools Help
=l Back = Forward = | # Show Hidden Content ¥") Show Non-Relevant Content | & ¥ Refresh Console

All Content <« Custom Site: Legacy Patches =

> 5 BESAsset Discovery  ~ BSave Changes }Discard Change;| Gather Add Files... 3§ Remove
s BESInventory and Lice

> =/ BES Support Details | Computer Subscriptions | Operator Permissions E Role Permissicns
» |3/ Patches for RedHat En

5| Patches for RedHat Lir The following computers will be subscribed to this site:

| Patchesfor RHELS () All computers

» | Patches for RHELS - D
> |sv Patchesfor RHELG - Dy

- | Patches for RHELG - N
\ Patches for Windows ( @ Computers which match the condition below

_) No computers

") Computers subscribed via ad-hoc custom site subscription actions

. Patching Support
> = Software Distribution
> = Updates for Windows |
stom Sites (4)

[E Computer Name '] Icontains '] Qﬁ‘l = B

+@ BigFix Management
.1. Patch Management

% Systems Lifecycle

2. Select the Computer Subscriptions tab. You have several choices for selecting
computers.

* All computers. Click this button to automatically subscribe all Clients to this
site. This is the default action.

* No computers. Click here to unsubscribe all Clients.

* Computers subscribed via ad-hoc custom site subscription actions. If you
choose a custom site, this option is also available to flexibly assign computers
on ad-hoc basis by creating an Action to subscribe relevant computers to the
site.

* Computers which match the condition below. Click here and then create a
condition that must evaluate to TRUE for the IBM Endpoint Manager Client
to be subscribed to the site. The default is to parse computer names, but the
pull-down list contains several properties that you can use as useful
subscription criteria. Press the plus sign to add more criteria. You can
combine conditions by ANDing or ORing them.

3. When you are satisfied with how your computers subscribe to this site, click
Save Changes from the Work Area Toolbar. Enter your private password to
propagate the subscription request to your network.
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Restricting Readers

Restrictions can be placed on Sites to limit access. As with operator permissions on
Custom Sites, you can restrict both the operators and computers of most external
Sites.

Not all operators need to know about all sites, and some sites might be most easily
managed by a single operator, such as an appointed Anti-Virus Czar or the Finance
IT Manager. If you have Master Operator privileges, you can limit how many
Non-Master Operators are able to view any specified Site. Here is how:

1.

4.

Select the desired site from the Domain Panel.

File Edit View Go Tools Help
= Back = Forward = ‘ @ Show Hidden Content ") Show Non-Relevant Content | & ¥ Refresh Console

All Content «  External Site: BES Support =
a -%' Si;:es (22) i Ea‘.r: Changes Discard Changes | Gather Add Files... 3 Remove

» | Master Action Site

4 [7 External Sites (13)

| Details | Computer Subscriptionsl Operator Permissions | Role Permissions

oMl BEY Asset D‘SCDV:WL_ Operators with read permission will be able to view this site and take actions based on its content.
> eadgry and Lice
> 5w, BES Support |= & 5
S eRatcheeferfedHat Enl— Grant read permission globally Permission: Reader MNone
s Patches for RedHat Lir i T ol
5 Patches for RHEL 5 s zstbooin Tine =
. &/ PatchesforRHELS5-D IEMAdmin 08/09/2014 17:02:48 Lo
] T = ' : Fabio 26/08/2014 15:44.59 Lo|
""""" Winpatch 19,/08/2014 15:48.09 Lo|E
0 All Content Inxpatch Lo|
oy Gabriella 14/09/2014 13:35:48 Lo|
B e e canreboot 26/08/2014 08:53:28 Lof™
Adolfo 27/08/2014 10:37:36 Lol
‘j. Patch Management - .
< T 3
o B
ok

The site properties are shown in the Work Area. Click Operator Permissions.

You can click the box to Grant read permission globally. Otherwise, clear the
box and set permissions on a user-by-user basis.

When you are satisfied with your selections, click OK.

Creating Custom Sites

You can create a Custom Site to host your own Fixlet messages that are pertinent
to your network. Here is how:

1.
2.
3.

Select Tools > Create Custom Site.
You are prompted for a name for your custom site. Enter a name and click OK.

From the Domain panel, find your site under Sites > Custom and click it to
describe your site.
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Custem Site: WyCorp Policies =

[l Save Changes Discard Changes | Gather Add Files.. 3 Remove

Detsils | Computer Subscriptions | Operator F'en'ni:siunsl

* Details
Type Custom Site
Creator Evaluationlser
Created 120172010 5:09:50 PM

The MyCorp Policy site is a »

collection of Fixlets and
Descoplion Tasks to establish corporate

policies across the network.

m

Domain All Content -

w Subscription

Mo clients are subscribed to this site, but Tvoli Endpoint Manager
will continue to maintain an up-to-date version of the site in the
dstabase

From the Details tab, enter a description of your site. From the Domain
pull-down menu, select a Domain to house your site.

4. From the Computer Subscriptions tab, indicate which subset of your BigFix
Client computers you want to subscribe to this site.

Custom Sibe: My Corp Pohicies =

fpl Save Changes Discard Changes | Garher Add Files... 3 Remove

Details | Computer Subscriptions | Operator Fletmirs:iuml

The following computers will be subscribed to this sites

© All computers

71 No computers

7 Computers sub Lctit}d via ad-hoc custom site subscription actions
1 Computers which match the condition below

Computer Name contains

There are several choices:

* All Computers. Click this button to automatically subscribe all Clients to this
site.

* No Computers. Click this button if you are not yet ready to subscribe any
computers.

* Computers subscribed via ad-hoc custom site subscription actions. This

choice requires you to create an Action to subscribe relevant computers to
the site.
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* Computers which match the condition below. This choice allows you to
describe a set of criteria that must all evaluate to TRUE before a BigFix
Client is subscribed. From the pull-down menu, you can select from dozens
of properties to test for inclusion.

5. From the Operator Permissions tab, you can grant specific access permissions
to specific operators.

Custom Site: Wy Corp Policies of

k-l Save Changes Discard Changes | Gather Add Files... 3 Remove

Details [E;IF;EELE&&EQEE Operator Permissions

Custom site owners are allowed to grant other operators read or write permission. Writers are allowed to create new
content in the site. Readers are allowed to view and apply content in a custom site.

nglobalhy  Permission:
Mame Last Login Time Permission
Boh Mone
Jeb Mone
Kim Nane
Pat Mone

There are several options:

* Grant read permission globally. Click this button to provide read
permission to all operators.

* Or click specific Operators from the list and assign them specific rights, such
as Owner, Writer, Reader, or None.

6. Click the Save Changes button above the work area to complete the
description of your site. You must enter your password to propagate your new
custom site.

Canceling a Subscription

You can try out different Site subscriptions for your organization, because no
actions are ever taken without your approval. Nevertheless, if you find that a
subscription is not useful, you can cancel it by removing the site from the domain
in which it is located, as follows:

1. In the Domain Panel, expand the icon containing Sites. From the External or
Custom icon, select the site you want to delete.

2. Open the site and from the Work Area Tool bar, click the Remove button.

3. Click Yes on the confirmation dialog, and enter your password to complete the
site removal.

Note: You cannot unsubscribe from the BigFix Support site because it is needed to
upgrade and manage licensing issues in the Console program.

Adding Files to Sites

Starting with version 8.1, you can add files to a Site. These can be as simple as text
and utility files or as powerful as Dashboards and Domains (described at the end
of this section). Files can be added to the master action site, custom sites, and
operator sites, but you must have write permissions for the site. This means that
only master operators can add files to the master action site, custom-site writers
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can only add files to custom sites and non-master operators can only add files to
their own operator site. There are several useful things you can accomplish using
this feature:

Place utility files on all clients subscribed to a site
Share custom dashboards with multiple console users
Share custom domains with multiple console users

Here is how to add files to a site:

1.

Select Tools > Add Files to Site. You can also navigate to the domain tree node
for the site you want, right-click the Files subnode, and choose Add Files from
the context menu. The Add Files dialog opens.

Add Files to Site [=5) :
Add to sibe: .Mag,tgr Action Site - l
Files to add: i Browse.. J Send to clients %
. Mame F Size

Choose files to add to the site.

[ Add files | ~ Cancel

If you get to this dialog through the domain tree, your site is already selected.
Otherwise, select the site you want from the Add to site pull-down.

Click the Browse button and then select all the files you want to add from the
file-picker dialog. You can select multiple files and you can click the Browse
button multiple times to add more files.

Check the Send to clients box if you want to deploy this file to all the clients
that subscribe to the selected site.

When you are satisfied with the set of files you have selected, click Add files
to finish.

There are a few restrictions on which files can be added:

All file names in the site must be unique. In case of conflict, you are asked if
you want to overwrite the existing file.

Files with a .fxf extension cannot be added, because the client treats those files
as Fixlet documents. Attempts to add files of this type cause an error.

Files starting with "__" (double underline) cannot be added, because they are
reserved for special site metadata. Attempts to add files of this type cause an
€erTor.

If you attempt to add a large file (over 100 KB) and Send to clients is checked, a
warning dialog opens. This is to notify you of a possible spike in network traffic
if you proceed.

Some files are interpreted differently, according to their file extension:

ojo: A site file with the extension .0jo is loaded as a dashboard and is visible to
all readers of the site. The dashboard is also visible in the Dashboards subnode
of the site node in the domain tree.
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* BESDomain: A site file with the extension .BESDomain is loaded as a domain

visible to all readers of the site and is shown in the list of domains in the

domain bar.
* bfa: A site file with the extension .bfa is treated as a BigFix archive file created
by the bfarchive tool. The archive is unpacked, and all files are added.

Viewing and Deleting Site Files

After adding files to a site as described in Adding Files to Sites, you can view or

delete these files. The site files you created can be selected directly from the

Domain tree:

1.

Open the site of interest in the domain tree.

2. Click the Files node. The List Panel displays the files of interest. Click one to
display it in the work area below.

3.

File Edit View Go Tools Help
Forwzrd = | % Show Hidden Content +") Show Non-Relevant Content | 5 ¥ Refresh Console

“Back «
All Content <« Files Search Files P‘ [m|
» 3w/ Fabio * | Name o Size Date imported Clien...
4 [ Legacy Patches MyCorp Policy.bt 52 KB 14/09/2014 22:.. Mo
[} Fixlets and Tasks (0

@ Baselines (07
a Analyses (0)
@ Computer Groups

(| — - x
() Ancontent

@ BigFix Management

':. Patch Management

5 =
w .

Filez MyCorp Policy.bet

2 Remove from site

|

s

* Details
[Mame MyCorp Policy txt
Size 52 KB
Date imported  14/09/2014 22:47:20
Client file Mo

¥ Preview

The column headers in this list include:

* Name: The name of your site file

* Size: The size of the file
* Date imported: The date that the file was imported to the site
* Client file: Whether the file is downloaded by clients subscribed to the site
Click any file in this list to display informational details and a preview.

Click Remove from site if you want to delete this file from the site.
Alternatively, you can select Edit > Remove. The same permissions used to add

files are required to delete them.
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Chapter 5. Domains

Introducing Domains

Domains represent the major organizing principle in the BigFix Console. Domains

contain a set of related sites, such as Patch Management for various operating

systems. Domains are reflect the tasks of specific Console Operators, such as Patch
Management, AntiVirus Management, Power Management, and so on.

Domains are located on the

leftmost panel of the Console.

i) Tiveli Endpeint Manager Console
File Edit View Go Tools Help

£l
@ All Content

@: BigFix Management

oo s

‘G Back = W) Forward = | % Show Hidden Content +" Show Mon-Relevant Content | % Refresh Console

Patch Management ’ ® 'Exl:emarﬁb: BES Support
. lﬂ Carmputears (3) . HS.-..--.—' Changes Discard Changes | Gather Add Files.. 3 Remove
¥ Computer Groups (D) - — - - -
4 [ Sites (8) Detsils | Computer Subscriptions | Operator Permissions
4 [ External (T)
7 BES Support T
Linux RPM Patchin | = Details
S Patches for Mac 02
3 Patches fer RHEL 5 Type External Content Site
an Pakches for Solans | = = ;
Current Version
= Patches fer Windo ec I e
. = Updates for Windo Gathar URL h_tlp:.fa'sync bigfix.comicgi-
= Custom (1) = binfbigather/bessuppon
L] L Publisher BigFix, Inc.

[ = Subscription

,i‘ Patch Management

All clients are subscribed to this site.

Select the Domain you want from the buttons at the bottom of the panel. The
contents of the domain are then displayed. Some Domains have extra structure,
such as Content Filters that allow you to narrow down the viewable content by

Vendor.

Generally there is a Domain Overview, to help you understand the extent of the

content.
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?B Tiveli Endpoint Manager Console (o llE e |
File Edit View Go Tools Help
‘g Back = B Forward = | % Show Hidden Content " Show Mon-Relevant Content | eﬁtfrﬁh Console

v &
- =r) =i
o e Patch Manﬂgﬂ ment Domain
« (5 05 Vendors
F E Al Pateh Mﬂl‘lﬂgtl'l'ltﬂf = The Patch Management domain provides patching capabililies aoros a8 vaniety of

2= 3 operating sysberna snd spplications. A list of recent additions fo the domain is availsble
}ﬁ Fulﬁ_s and Tasks (19) below with spedific controls and views available to the el
[ Baselines ()

. @ Analyses (8) Content released or modified in the last 30 days:

i g ;ni:gst?j Hame Type | Site Modif Date Applicatk
AENDoands
Fj_] Wizards ::::er s:;?::'l:h e Fhcet Patches  Modifi Thu, 02 0 ":
» §5 Custom Content SR s—’ = forSolaris ed  Dec2010
5 Custom Filters - . e
|« (] | b 11878315 Sund5 5.10: Fidet Fatches Meodifi  Thu, 62 I
i bind patch [Superseded) for Solaris  ed Dac 2010
| 0 All Content 14359306 Sun0S .
| 5.10_x86: ipt ipts impool Fodet Patches Modifi  Tha, 62 o
. o g - ” a 1
@) BigFix Management e iy forSolaris ed  Dec2010
| .1‘ Patch Management 143318-02: GNOME
| 2.6.0_xEE: Instant Eicat Patehes Madifi  Thu, 02 o
| i:}‘ P Messagng paich for Solans  ed Dec 2010 s
g - P PP Ty [

This particular overview shows you at a glance what new Fixlets, Analyses, Tasks,
and so on. have recently been added to the Domain.

In the General Content section, the information available can be further broken
down by opening the various topics, content types and folders. For most topics
here, a single click causes the contents to be shown in the List Panel, top right. On
items with a disclosure icon (plus/minus or triangle icon), you can click it to open
up filtering options. Drill down through any folders to reach a leaf node that

represents a subset of the original topic. Now, in the List Panel, only the specified
subset is displayed.
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Patch Management «

.t Patch Management Domain =
- ) Apphication Vendors
5 05 Vendors
2 = Al Patch Management
& T Fixlets and Tasks (79)
4 IEJ By Source Severity
» [l <Unspecified> (33)
» Bk Moderate (3)

ik

.

:

=4

TN
Critical (23)

[l By Category
» B3 By Source
. 5] By Source Release Date

T Baselines (0
R Analyses @) :

(*) AN Content
& BigFix Management
':‘ Patch Management

Here the Fixlets and Tasks have been opened to disclose the Source Severity
folder. Within that folder, only the Critical Fixlets have been selected, making the
resulting List Panel shorter and easier to deal with.

In general, there is a Sites section that you can open to examine the sites

individually should you need. Different domains have different structures, so
explore them.
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Domain Sites

Domains are composed of related sites, grouped together for convenience and
because they share a similar structure. You can easily examine the Sites that
comprise a Domain.

Patch Management %“

.| Patch Management Domain

=

] Application Vendors
& 05 Vendors
# & Al Patch Management
5, Fodets and Tasks (79)
& Baselines (0)
B Analyses (8)
35 Actions (0]
i Dashboards T
B Wizards
B Custern Content
(5l Customn Filters
. F Computers [5)
E Computer Groups (0}
a B Sites (8)
4 [ External 7)
w BES Support
w1 Linux RPM Patching
7 Patches for Mac 05
o Patchesfor RHELS -

4 (rl} ]

Find the Sites heading and click the disclosure icon, opening the navigation tree to
External and Custom sites. Click the disclosure icon next to External to view the
various Sites. Each site is clickable so you can examine its top-level properties.
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File Edt View Go Tools Help
e Back ~ B Forward - | ﬁﬂmi-hddmtommt ¥ Show Man-Relevant Content | ¥ Refresh Cansole
Plh:hlnlmgunut

» @ Computers (5] * | ligiseve Changes Discard Changes | Gother Add Files.. 3¢ Remove |
=) Cumputu Growps () -

Details | Computer Subscriptions | Operator Permissions |

= Details

Type External Content Site
Current Version 721

http://sync bighs.comfcgi-
Gather URL  pinjbfgatheribessupport

Publisher BigFis, Inc_

w Subscription

All clients are subscribed to this site. LS

Click the disclosure icon next to the site icon to examine subsets of the data. You
can continue to drill down until you reach a leaf node, allowing you to examine
specific subsets of each site. When you reach the subset you want, the content is
displayed in the List Panel.

File Edit View Go Tools Help
= Back = b Forward ~ | % Show Hidden Content ¢') Show Non-Relevant Content | & Refresh Console |

Patch Management @ @mm Fidets and Tasks Pm

o [(E) Sites (8) i Applicable Co.. Ope.. Category >
<& Eﬂ!;::sm Administrative Login Meaded 1/5 0 Computer Sup... -_l
“ '—\:% I__:T:‘;":': dTasks 2000 Flash Ployer - BES Comsole __1/5 0 Support ’
p By;qm:’ { Version of Dbmsipen.dil May Cavse., 175 0 Suppot
'8 ‘umm;’:ﬂ I ST A 0 Swpot -
/A (1)
v B Low (B) %Wd%MWCmML&mBBWCMEE
Take Action~ | # £dit | Copy [2Export | HideLocally Hide Globally 2

Description | Details | Applicable Computers (1) | Action History ()

Description =

The listed computers have a version of dbmslpcn.dil
that may cause the BES Client, FillDB, and/or
GatherDB Services to leak handles. To resolve this
issue, use the action below to set a ragistry key
value and disable the 'Shared Memory Net-Library'
for SOL Server client.

M R L S
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Selecting Domains

You typically have several Domains available to you, each covering a group of
related tasks that fall into the purview of a specified Console Operator. As you add
sites to your Console, they find their way into the appropriate Domains, and create
new Domains when needed. The Domain Panel is on the left side of the Console,
and buttons corresponding to the Domains are shown at the bottom of that panel.

&) Tiveli Endpoint Manager Console
File Edit View Go Tools Help

Endpoint Protection

1| Endpoint Protection Domain

£ Client Manager for Endpoint Prote
E5] Device Control

Bl All Endpeint Protection

Endpoint Protection Domain

The Endpaint Probection domain pravides mansgemant functionality for endpaint protediion
produdts, including anti-malware, endpoint frewall, device contrel and other funclionality. A
list of recent additions o the domain is available below with spedific controls and views

available to the left

Content released or modified in the last 30 days:

Hame Type | Site Muohifi

UPDATE: Cuidated Trend

‘om Back = ® Forward = ¥ Show Hidden Content ") Show Mon-Relevant Content | g}ﬂdrﬁh Console
+ Endpoint Protection Domain

)

Date

Uicro DfficeSean Virus ;il": N
Patiern File Delacled - Ficlat for o Modifie Tha, 02
Yindows. E it Dec 2010
XPr200MiSar2 008720088 gt

Pratectsn
2 (xE84)
UPDATE: Ouidated Clent
Symantec Anfl-Virus Virus Manager

11 Th

Defintion Detected - Focel  for Sn D;'zu; 5
Symantec AnfiVirus 10.2 for Endpoint

Applicable

Depending on the Domain you click, an overview is typically displayed in the
Work Area. It shows a list of the most recent additions to the content for a quick

appraisal.

At the bottom of the button list is a pull-out menu that lets you adjust the number
of buttons you want to display.

Navigating Domains

50

Domains are a logical collection of sites that all have similar purposes and
structure. As a consequence, each Domain reflects a unique structure and displays
its contents appropriately. Nevertheless, all sites have certain similarities in how
they manage content, and a simple domain is sufficient to explore most of their
options and how to navigate amongst them. The example used here is Patch

Management.
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O Tl Endpint Manages Consoe By =)
File Edit View Go Tools Help
‘% Back = "0 Forwerd = | % Show Hidden Content ' Show Non-Relevant Content | £ Refresh Console
|Patch Management "% [Fixlets and Tasks Search Fidets and Tasks ,‘U] =
..1| Patch Management Domain » _Name = I Applicable Co... Ope.. Category ' =
= gz'ilr'“:“" Venrdoes 971029: Update for Windows Autor..  1/5 ] Security Advis...—
g E i F:;h";_:m cment || 9710+ Update for Windows Auter.. 1/5 0 Security Advis..
2 % Fad oo :“IG o9) | 971023: Updete for Windows Autor... 175 0 Security Advis...
-:a Baselines [0) 974554: Secunty Update for Microse... 1/5 1] Secunty Hotfix
; % Analyses (8] Adobe Acrobat 3_.1.2 J-'!.l..lail_ablt -Ad.. 1/ 5 1] Update -
3 Actions [0) ¥ b ;
E5] Dashbosrds Fixlet: 571025: Update for Windows Autorun Functionality - Windows Vista Gol... of' &
; E :ﬁ:‘: Mres £ Take Action = |  Edit | Copy [1:Export | Hide Locally Hide Globally »
Sl Custom Filters = || Description | Details | Applicable Computers (1) | Action History (0)
1 5 " i et rrt R U et M B
0 All Content Description EI
- & |
@ BigFix Management Microsoft has released an update that comrects an
issue that prevents AutoPlay from working with USB
W tndpoint Protection media.
'1' Patch Management AutoRun entries were populated for all devices that
had mass storage and had a validly formatted
i JE.I._IEDR_Lfll.infﬁl_e_illﬂ'lelmlnl_‘. directqr'.r. "'.'i.s in:llulq_:lp:d =

=

Click the Domain button to view it in the Domain Panel. For this example, there
are two folders, Application Vendors and OS Vendors that act as domain content
filters. Not all domains have such filters, but they are fairly common when there is
a benefit to grouping the information into logical partitions. Here, there is a way to
group the content based either on the software vendor (such as Adobe, Mozilla,
and so on.) or the OS vendor (Mac, Windows, Linux, and so on.). You can click the
disclosure icon (either a plus-minus icon or a rotating triangle icon, depending on

your operating system) or double-click the tree node itself to open it up and

explore its subheaders.
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Patch Management «

¢' Patch Management Domain -
# & Application Vendors
a Warnings (1)
. fy Recent Content (15)
_3-5:'& Configuration {7)
- [y Adobe Systems (14)
-|_I Apple ()
Microsoft (15)
Mozilla Corporation (2)
Mudlscft ()
Real Metworks (0
Skype Limnited (1)
Sun Microsystems (4)
+ [y Windip International LLC (3)
F) Iﬂ 0% Vendors
; 3_ Apple Mac O5 X (D)
Microsoft Windeows (76)
Mevell SuSE (0)
Red Hat Enterprise Linw (1)
=|_’-‘ Sun Microsystems Solaris (2) -

i | 1Bl | ¥

1

4 i gl il il e g

5 505

Below any domain filters, you find a more generic presentation of the domain

content.
Patch Management o
.u| Patch Management Domain -
- 5] Application Vendors
=5 05 Vendors

a & All Patch Management
4 i Fixlets and Tasks (79)
(5 By Source Severity
» ) By Site
: (& By Category
5l By Source
B By Source Release Date
@ Baselines {0)
- G Analyses [8)
. P Actions (0)
4 & Dashbeards
- Deployment Health Checks
.u1| Deployment Overview *

4 m ¥

ne

Notice the icon labeled All Patch Management. This icon represents the main
content of this domain, and is composed of a union of Fixlets and Tasks combined
from all the sites that make up this domain. You can open this category and drill
down by sources or severity. Under the Source Severity folder is a breakdown of
the content that allows you to select only critical, important, or other categories of
Fixlet severity to concentrate on. Click these icons once to view all the content that
fits this criteria in the List Panel to the right.
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) Tivoli Endpoint Manager Console E
File Edit View Go Tools Help
‘4= Back = Wb Forwerd = | 9% Show Hidden Content ') Show Mon-Relevant Cantent | &% Refresh Conzole
Patch Management 4 Fodets and Tasks '|‘:-calcnl xlets and Tasks

.| Patch Management Domain * | Name s Applicable Co.., ‘I
ESl Application Venders &

ey [ Adobe Acrobat 8.1.2 Available - Ad.. 175 3
E 5 P::::;m — £ | Adobe Reader81.3 Available - Ado.. 175
= \
4 i Ficlets and 'lis!ts 79 Adobe Renderd.2 Available 175 y
« {8l By Source Severity Adobe Resder 9.1 Available - Adobe.. 1/5
. By <Unspecified> (33) - = f
. B4 Moderate (3) Fixlet: Adobe Acrobat 8.1.2 Available - Adobe Acrobat 8.1.1
i ik Impartant (20) . = r
i a Critical (23) ‘:-"’ Take Action~ | # Edit | Copy |:%Export | Hide Loca
a S By Site

i-be‘scriplinn-f Details | Applicable Computers (1) | Action

< B Patches for Windows (English) (2)
5 Updates for Windows l\qplic\rbions {20)

| Description '

» By Category
. [ BySou Adobe has released a new version of Ad
Fii P S — i Acrobat. This update addresses saveral
known issues in Acrobat & Professional an
Standard software. Use the acbion below
0 All Content update Acrobat to the latest version (8.1.2

@ BigFix Management Note: Affected computers may report bac
as 'Pending Restart’ once the patch has r

% W gingpeint Pratsion_ 4., gp-asmsare. 4.9 j@\iwwwﬂrewrt bask

Double-click to open the icon for further filtering of the content. For example,
under Source Severity > Critical you can filter the resulting set of critical Fixlets
by Site. Finally, at the leaf node, you can click an icon to produce a list of the
severity- and site-filtered content in the List Panel. As you drill down, you are
ANDing the various filters, producing a smaller and more targeted set at each
level.

All of these navigation icons work in the same way. A single click highlights the
particular category and a double click opens it for further refinement. In general,
each icon can be a destination or the head of a new tree to examine. When you
click it, the particular subset of data implied by that icon opens in the List Panel to
the right. The drill-down ends at an ultimate leaf node, where all the possible
fields have been exhaustively ANDed together. Note that there are many ways to
achieve the same subset of leaf items. because the field criteria are simply ANDed
together, it does not matter which order you choose.
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Patch Management «

F] E] All Patch Management -
a G5 Fislets and Tasks (79)
4 & By Source Severity
+ B <Unspecified> (33)
2 Moderate (3)
i Impertant (20)
« [3h Critical (23)
a S By Site
4 BES Support (1)
4 (35 Patches for Windows (English) (2)
Fl E.] By Category
o [} Security Hotfix (2)
4 &l By Source
# by Microsoft (2)

m

B 8/11/2009 (1)
& /12010 (1)

» B By So
4 =] By Source
a [ Microsoft (2)

F J.ﬂ By Category

4 G} Security Hotfix (2)

Note that Fixlets, Tasks, Analyses, Actions, Baselines, Computers, and Computer
Groups are almost always represented in the main navigation tree of any given
Domain. Other content, such as filters, custom content, and custom sites are often
represented as well. As the Operator responsible for a Domain, you should find it
easy to see the overall structure at a glance. You soon become familiar with drilling
down to filter and narrow your selections.
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Minimizing the Domain Panel

If you need more panel space, you can minimize the Domain Panel by clicking the
minimize icon at the upper right of the panel.

F-;bch-h;lmagun!nt

4 T Critical (23)

i G5 By Site

<] A —

Fl a &ll Patch Management
4 Fidets and Tasks (79)
4 & By Source Severity |
b B <Unspecified> (33)
b rﬁ Moderate (3)
v B Important (20)

File Edit WView Go Tools Help |
*M**Fumardvlﬂﬂm I

« & By Category
o Bl Security Hotf
v By Security Updi _ | |

¥

| | [Adobe Reader 8.2 Available

Search Fidets and Tasks
: | Applicab

1/5

i | Adobe Reader 8.3 Available 3/5
Adobe Reader 9.4 Available 4/5
1/5

Adobe Shockwave Plaver 11.5.9.615 ...

4 ] | r
Ficlet: Adobe Reader 8.2 Available
| 7 Take Action= | »# Edit | Copy (% Export | r
Description | Details | Applicable Computers (L)

1|

O Arcomen Descriptin |
Adobe has released a new version
O BigFix Management | Adobe Reader, Use the action belo
1l to update Adobe Reader to the lat
W Endpoint Protection version (8.2).
1, Patch Management This update disables Adobe Up
for all Adobe applications.

This reduces the panel to a small stub at the left of the Console window. To restore
the Domain Panel, click the stub.
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ew Go Tools Help
MBack = W Forward = | % Show Hidden Content ¥ Show Non-Relevant Content |
and Tasks |‘Search Frefets and Tasks

Applicable Co... Ope.. Category '

bdobe Reader 8.2 Available 115 1] Security Update
lidobe Reader 9.3 Available 355 0 Security Update™
Adobe Reader 9.4 Available 4/5 i) Security Update
Adobe Shockwave Plaver 11.59615... 1/5 1] Secunty Update

| n |

" Eodet: Adobe Reader 3.2 Available
4§72 Tske Action = | # Edit | Copy [%:Export | Hide Locally Hide Globally | 3¢ R

| Deseription | Dietails | Applicable Computers (1) | Action History )|

Description

\;dyﬂ'las released a new version of Adobe Reader. Use the
gl A g A ne A Ve G A

Deleting Domains

A domain can be deleted when all of its constituent sites have been deleted. In the
Domain Panel, find the icon for the collection of sites.

| File Edit View Go Tools Help
| 4= Back = #b Forward = | % Show Hidden Content ¢ Show Non-Relevant Cantent |e|wmhr.:nmh|

Security Cnn;ﬁguraﬁun # External ! Hs5et WEY. e
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» 5 Computers (5) aSarvthaﬂges Discard Changes | Gather Add F
| Details | C Subscripti (0] r Permissions |
s | Computer Subscriptions | Operator n: i
« [ Btemal (5) Y
>[5 BES Asset Discovery - Datails
o [l SCM Checkdist for O
w2 h F :
; % g:c “"?:‘;“ Type External Content Site 3
L :.q]ﬂlt i
s 5 Security Policy Ma Current Version 55
s hitp://synec. bighix.com/cqgi-
N ' Cather R pinibigatheassetdiscovery
N Publisher BigFix, Inc. A
0‘ BigFix Management
' i w Subscription
[ ™M " All clients that satisfy the extemally defined criteria
‘t'_ Patch are subscribed to this site.
‘ﬂ' Security Configuration External Subscription Constraints o
g o 1 ] |k
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Open the site icon, and navigate to External sites. Double-click each site in turn
and use the Remove button at the top of the Work Area to delete all of the sites
that exist there. Do the same for any Internal sites. The domain is no longer visible.
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Chapter 6. Operators

Introducing Operators

When you install BigFix, you also set up specific personnel to act as Operators.

There are three classes of operator:

* The Site Administrator is responsible for installing and maintaining the BigFix
components, as well as managing the certificates and keys. Only the
Administrator can create new users.

* The Console Master Operators can assign management rights to other
operators.

* The Console Operators are the day-to-day managers of their own domains, but
they cannot assign management rights.

Often these administrative roles overlap and one person might be assigned
multiple duties.

Adding Console Operators

You can create accounts for new console operators, assigning them roles or
granting them permissions to view or manage specific computers and sites. You
can create local operators or select predefined operators from LDAP or Active
Directory servers.

You can add single operators at any time by selecting the Tools > Create Operator
item or by right clicking in the operators work area and selecting Create Operator
as described in [“Adding Local Operators.”|

If you are using Active Directory or some kind of LDAP, you can add previously
defined users by selecting the Tools > Add LDAP Operator item or by right
clicking in the operators work area and selecting Add LDAP Operator as
described in [“Adding LDAP Operators” on page 68|

You can also associate an LDAP group to an existing role, in this way, with just
one click, you add an operator for each user specified in the LDAP group and you
associate that operator to the role. For more information about this capability, see
[Associating an LDAP group” on page 70.|

Note: For LDAP operator and LDAP Group an Active Directory or LDAP
directory must first be added to IBM Endpoint Manager.

Adding Local Operators

You can create accounts for operators that access the console using the local BigFix
account.

To add a local operator perform the following steps:

1. Click the Tools > Create Operator menu item or right click in the operators
work area and select Create Operator. The Add User dialog appears.
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Add User
Username: larmes Baud
Paﬁwnrd: Tl
Verify password: ssanes
[ OK ] | Cancel

Enter the Username of the person you want to designate as a publisher or
operator.

Create a Password and retype it for confirmation. When you give the keys to
your operators, they can change their passwords if they want.

Click OK. The Console Operator window opens.
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5. From the Details tab, assign operator permissions.

You also decide to influence the ability of the operator to trigger restart and
shutdown as Post-Action or to include them in BigFix Action Scripts.
Depending on the configuration that you set for a specific operator for
shutdown and restart, the radio button in the Take action panel might be
disabled for that operator. This configuration has no effect on actions with
type other than BigFix Action Script.

You can also set permissions to access the BigFix Console and REST APL

From the Administered Computers tab, assign the desired computers to this
operator.

7. From the Assigned Role tab, select the roles to apply to this operator.

8. From the Sites tab, assign the sites you want this operator to have access to.
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9. From the Computer Assignments tab, specify the properties that must be
matched by the computers that the operator can manage. For master
operators, the assigned computers are always all the computers irrespective of
the computers being assigned.

10. To save the changes click Save Changes.

At any time, you can also convert a local operator to an LDAP operator. To do so,

follow these steps:

1. From any list of local operators, right click on the operator you want to
convert.

2. From the context menu, select Convert to LDAP Operator.

Monitoring Operators

If you are a master Operator (you must have a correctly authorized user name
created with the BigFix Administration Tool), you can monitor what other
operators are doing and what computers they are authorized to administer.

Each operator is represented by, among other attributes, a Name, User Type and
Login type. To view the list of Console Operators, select the All Content Domain
and then click the node labeled Operators from the Domain Panel. In the List
Panel on the right, all the current Operators are listed.

Click any operator from the List Panel to open the Operator work area.

» B Wizards
> £ Custom Content

Sa-.e Changes Discard Changes | Reset Password 3§ Remove

File Edit View Go Tools Help
o Back ~ B Forward | % Show Hidden Content [ﬁ Show Non-Relevant Content” ¥ Refresh Console
All Content <« Operators Search Operators }D| [m]
i} Fixlets and Tasks (81| pyame Operator Type  LDAP Server  Master Operator  Sites  Last Login Time L=
i“el"”es (02) IEMAdmin Local Ves 1 06/10/2014 09:48:12 [,
Ana. )rseso(l ) James Baud Local Mo 1 L
I+ [ Actions (0) T \ m 3
» [ Dashboards - e, -
Console Operator: Jares Baud =

[ Custom Filters
Computers (1) Details |Adm|mstered Computers (0) ! Issued Actions (0) I Assigned Roles (0) I Sites (1) I Computer A55|gnment5|

Computer Groups (0] 7
Unmanaged Assets ([ |

Overview | 3

MName James Baud

User Type Local Console Operator

Last Login Time  Mever

® Always allow this user to log in_

() Only allow this user to log in when they are a member of at
least one role.

() Disable this user's login.

Login

@' BigFix Management

» 4 [

o .

There are several tabs to choose from:

* Details: Describes the operator by name and type and lets you select a login
type. This is also where you can view and alter operator permissions.

* Administered Computers: Presents a list of computers that are currently
assigned to the selected console operator.

* Issued Actions: Presents a list of actions that have been issued by the selected
console operator.
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» Assigned Roles: Displays the currently assigned roles, and lets you reassign
them.

* Sites: Displays the sites currently assigned to this operator, and lets you reassign
them. If the site is a custom site, you can also set Read /Write/Owner
permissions.

* Computer Assignments: Lists the properties that must be matched by the
computers that the operator can manage. If you specify a property to be
matched, any time a computer is changed to match that property, it is added to
the list of computers assigned to the operator. On the other hand, if a computer
is changed not to match that property, that computer is removed from the list.

This tab is available only for not-master operators.
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Chapter 7. Roles

Introducing Roles

Roles provide a powerful tool to help you organize and grant complex
permissions. Like groups, roles can have various members defined, but each role
includes implicit permissions.

You may have already assigned permissions to your console operators, so when
you also assign a role to that user you will effectively expand their permissions.
When permissions conflict, the highest level will be selected.

To view the available roles, select All Content from the domain panel and select
the node labeled Roles. From the list that appears, select the computers, operators,
groups and sites that you want to associate with the role.

Creating Roles

You can create roles to define a set of permissions that can be shared by various
operators. Roles allow you to create a generic category of permissions. You can
then associate individual operators, computers, groups and sites to the role.

To create a role, perform the following steps:

1. Click Tools > Create Role or right click in the Roles work area and select
Create Role. The Create Role dialog appears and prompts you for a name.

2. Enter a descriptive name for your role. The role panel appears.

Fole NMORoke1
[ B L X Remove
Defails | Compiner Assgnments | Operators (1) | LDWS Geoups (1) | Sites 60

HMOR

MO = Bg - SUATOm CONTARL = Yea - Show Other = Yes - Unmanaged = Show None

e [w]
Yes v
g ]
ves[v]
s [
¥es [v]
Show Nang [v]

Reatsn and Shusdows | 1]
Adow Restart and Shuldown v
Abcrw Resstiit éwd Shukdamn ]
Iatisilisce Lo Privibisgers

Yo [

s

3. Enter a short description of the role and then set the permission levels
associated, the restart and shutdown ability associated to this role and the
permissions to access the BigFix Console and REST APL
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4. Set the computer assignments, operators, LDAP groups and sites by clicking
the various tabs.

5. Make sure to click Save Changes when you're done.

Assigning Roles

64

Once you have created a role and set its permissions, you can assign console
operators, client computers, LDAP groups and Fixlet sites to that role.

To accomplish this task, perform the following steps:

1. Click All Content in the domain panel and then select the node labelled Roles.
The list of currently defined roles is displayed.

2. Click the role to which you want to associate objects. The Role dialog opens.

Jools Help
4 Back ~ B Forward + [§ Show Hidden Content Iﬁ Show Non-Belevant Cunb!rlt" & Refresh Console
| All Content 4 Roles [écar:F Roles P] [ m|
| l% Firlets and Tasks (958 MName Master Operater  Unmanaged A...  Custom Content  Sites Computers Operater |
% i“?mes[?;] new_role Mo Show Mane Wes (1] (1] 0
: nalyses
: P Adi::s (50) Patches Mo Show Mone Ves 0 0 0
» (5 Dashboards <[ LI} | ;
[ Wizards Role: Patches [ |
> B Custom Content
I:J Custern Filters HSaue Changes Discard Changes 3§ Remowve
» [ Computers (6) 7 = o \—I—l
> @ Computer Groups ©) | Details | Computer Assignments | Operators (1) | LDAP Groups (0) | Sites (0)
F, Unmanaged Assets (( . —
[» f% Operators (1) Lo
;;‘;— Sites IEJ. Marme Operatar Type  LDAP Server  Master Operator  Sites  Last Login Time
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(2) AnContent
@h BigFix Management
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3. Click on the tabs to assign specific objects to the role. Each tab contains a
button to add or assign objects to the role.

4. Click the Add or Assign button to bring up a dialog that lets you select one or
more items to associate to the specified role. In the case where permissions
conflict, the least restrictive permissions have priority.

5. Make sure to click Save Changes when you're done.
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Chapter 8. LDAP Directories

Adding LDAP Directories

You can add Lightweight Directory Access Protocol (LDAP) associations to BigFix.
That allows you and other users to log in to the console using those credentials.
The same advantage applies also to Web Reports.

To add an existing LDAP domain to the console, follow these steps:

1.

9.

From the Tool menu, select Add LDAP Directory or right click in the work
area and then select Add LDAP Directory. The Add LDAP Directory dialog
appears.

Add LDAP Directory — =)
Mame: My LDAP Server
Type: Generic LDAP Server v|
Server: 987126154 i ]
Port: 636 [ Use SSL
Base DN: o=test.com C}‘

Login attribute: iy i}
Authentication
Connect anonymously

@ Use the following credentials to connect to the directory server:

User DN: cn=root

Password:  sssssss

The credentials will be encrypted and stored in the database.

Show advanced

Test Add Cancel

settings

Provide a name and from the Type pull-down, make sure Generic LDAP
Server is selected. Note that no global catalog option is available on generic
LDAP servers.

Fill in the information pertaining to your LDAP installation. Under Server,
enter the host name or IP Address of the server.

Enter the port number, typically 636 if you are using Secure Sockets Layer
(SSL).

Enter the base distinguished name (Base DN), of the form dc=example,dc=com.
Click the button to connect anonymously or to use credentials. If you choose
to connect using credentials, enter your User DN and password.

Click Test to ensure you have entered your information correctly and a
connection can be made to your LDAP.

If you want to include user or group filters, click the Show advanced settings
link. After specified, all further LDAP searches will be subject to the
appropriate filter.

Click Add to complete the LDAP setup.

Your LDAP Server is now configured and available for use in the console.
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Adding Active Directory

66

You can use Microsoft Active Directory (AD) to handle authentication on IBM
BigFix. That allows you and other users to log in to the console using your Active
Directory credentials, taking advantage of your existing authentication policies. The
same advantage applies also to Web Reports.

Note: To integrate the Linux BigFix server with Active Directory you must
configure the Kerberos protocol, downloaded as a prerequisite with the Linux
BigFix server installation. For additional information, see the IBM Endpoint
Manager: Configuration Guiddintegrating Linux Server with Active Directory]

To add an existing Active Directory to the console, follow these steps:

1. From the Tool menu, select Add LDAP Directory. The Add LDAP Directory
dialog appears.

Add LDAP Directory S5

Marme:

Type: lMicroso‘Ft Active Directory ,J

Server: .:t:}:,
[] This is a global cataleg server .;&:,

Authentication
Connect as the root server service user
@) Use the following credentials to connect to the directory server:
Username:
Password:

The credentials will be encrypted and stored in the database.

Add | [ Cancel

2. Provide a name for the Active Directory and from the Type pull-down, make
sure Microsoft Active Directory is selected.

3. Under Server, enter the host name, IP Address or fully qualified domain name
of the server.
4. To access an entire Active Directory forest, click This is a global catalog server.

5. Click the button to connect as the root server service user or to use
credentials. If you choose to connect using credentials, enter your Active
Directory Username and Password.

6. Click Test to make sure you have entered your information correctly and a
connection can be made to your Active Directory server.

7. Click Add to complete the Active Directory setup.

Note: When you add an LDAP Server as Microsoft Active Directory, ensure that
on the LDAP server you have defined the UserPrincipalName attribute
corresponding to the User logon name of each user. This attribute value is used on
the BigFix Console for each user authentication.
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To add an existing Active Directory running over SSL, you must perform the
following steps:

1. Select Generic LDAP Server as server type.

-

L

Add LDAP Directory

Mame: My LDAP Server

Type: Generic LDAP Server v]
Server: .@.
Port: 636 Use SSL

Base DN: .@.
Login attribute: | - u@.
Authentication

Connect anonymously

@ Use the following credentials to connect to the directory server

User DN:
Password:

The credentials will be encrypted and stored in the database.

Show advanced settingd

Test [ Add H Cancel

2. If the server is a global catalog server, specify as port number 3269.

3. Click the Show advanced settings link. The user filter and group filter options
are displayed:
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9.

Add LDAP Directory =5

Mame: My LDAP Server

Type: Generic LDAP Server v]
Server: u;ﬁ;.
Port: 636 [¥] Use S5L

Base DM: I:&I
Login attribute: ;14 [@.]
Authentication

Connect anonymously

@) Use the following credentials to connect to the directory server:

User DN:
Password:

The credentials will be encrypted and stored in the database.

Hide advanced settings

Advanced Settings
User filter: (ohjectClass=person) Iiﬁil I
Group filter: (objectClass=groupOfMNames) itj]

Test [ Add || cancel |

Enter UserPrincipalName in Login attribute.

Note: The UserPrincipalName attribute cannot be one of the following formats:
domain/user, domain.com/user, or user.

Enter (objectClass=user) in User filter
Enter (objectClass=group) in Group filter.

Click Use the following credentials to connect to the directory server and
enter your Active Directory Username and Password.

Click Test to ensure you have entered your information correctly and a
connection can be made to your Active Directory server.

Click Add to complete the Active Directory setup.

Your Active Directory Server is now configured and available for use in the
console.

Adding LDAP Operators

68

You can create accounts for operators to access the console by using an existing
Active Directory or LDAP account. When you select this option, an operator with
the same name as the one specified in the LDAP directory, is added to the
operators node in the Domain Panel on the BigFix console. These operators can
then log in as usual, using one of the following notations:

username
username@domain
domain\username
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The permissions assigned to that user in the LDAP directory are not inherited by
the newly created operator. You must either assign the needed permissions to the

operator or assign the operator to an existing role.

To add an LDAP operator, complete the following steps:

1. Ensure that the needed Active Directory or LDAP directory is added to the

BigFix environment.

2. Click the Tools > Add LDAP Operator menu item or right click in the work
area and then select Add LDAP Operator. The Add LDAP User dialog

appears.

-

Add LDAP User

Search LDAP o]
@ Contains Starts with

MName Distinguished ...  LDAP Server

JutaaNMO cn=JutagMMO... My LDAP Server

lucal cn=lucal,cu=.. My LDAP Server

lucal cn=lucad,ou=... My LDAP Server

lucad cn=lucad,ou=... My LDAP Server

fraGenericl cn=fraGeneric... My LDAP Server

fraGeneric2 cn=fraGeneric... My LDAP Server

danyl cn=danyl,ou.. Ny LDAP Server

dany2 cn=dany2,ou.. My LDAP Server
E Fabio (fabio) cn=Fabio,ou=... My LDAP Server :

Francesca (fran.. cn=Francy,ou... My LDAP Server

Lorenzo {lory) cn=Lory,ou=t.. My LDAP Server

Add

l

Cancel

nt

I

h

3. You can query and filter the users defined on the specified LDAP server using

the Search field and the two radio buttons.

4. When you find the user to add as LDAP operator, select it and click Add. The

Console Operator panel opens.
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5. From the Details tab assign operator permissions.

You can decide to give the operator the ability to trigger restart and shutdown
as Post-Action or to include them in BigFix Action Scripts. Depending on the
configuration that you set for a specific operator for shutdown and restart, the
radio button in the Post Action tab of the Take Action panel might be disabled
for that operator. This configuration has no effect on actions with action script
type other than BigFix Action Script.

You can also set permissions to access the BigFix Console and REST APL

6. The Administered Computers tab lists the computers managed by this
operator.

7. From the Assigned Role tab, select the roles that you want to assign or
unassign this operator to.

8. From the Sites tab, assign the sites that you want this operator to have access
to or unassign them.

9. From the Computer Assignments tab, specify the properties that must be
matched by the computers that the operator can manage.

10. To save the changes click Save Changes.

At any time, you can also convert a local operator to an LDAP operator. To do this,
follow these steps:

1. From any list of local operators, right click on the operator you want to
convert.

2. From the context menu, select Convert to LDAP Operator.

Associating an LDAP group

You can associate LDAP users or groups, that have been defined in an existing
Active Directory or LDAP directory, to console operators or roles.

To add such a group perform the following steps:

1. Ensure that the needed Active Directory or LDAP directory is added to the
BigFix environment.

2. Create a role to accept your new group by selecting Tools > Create Role or
right click in the work area and then select Create Role.

Create Role @

Please enter the name of the role:

-

Finance Group|

I QK ] | Cancel

Enter a name for your group and click OK.
3. The Role panel appears.
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Role: Finance Graup e
@
[ | Details I Computer Assignments | Operators |_|-DAP %DUFS Sites

Assign LDAP Group Remove LDAP Group

MName Distinguished Name LDAP Server

Save Changes Discard Changes 3 Remove

4| m | 3

Click the LDAP Groups tab.

4. Select the LDAP group that you want to assign to this role and click Assign
LDAP Group.

5. To save the changes click Save Changes.

When you assign an LDAP group to a role, any user from that group can then log
in to the console. Only those users who actually log in will be provisioned with
accounts and thus end up in the list of operators. This avoids the creation of
unnecessary accounts. Operators are granted the highest privileges resulting from
the sum of all their roles and permissions. For instance, if a user has access to
computer set A and sites X from role 1, and computer set B and sites Y from role 2,
they will have permissions for Sites X and Y across both computer sets A and B.
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Chapter 9. Client Computers

Introducing Client Computers

Client Computers represent those computers in your network running the BigFix
Client. When the client software is installed, you have a high level of control over
these machines, allowing you to maintain common operating environments, roll
out the latest patches, detect spyware, view and summarize properties, create
reports, and much more.

Client computers can have settings applied to handle a multiplicity of features,
including the ability to define and organize corporate departments. Client
computers can be automatically grouped according to these settings or other
computer properties, allowing you to target specialized remediation to distinct
domains. Settings are used to define Relays, bandwidth, idle time, buffers, and
much more.

The Computers icon in the Domain Panel navigation tree in the main interface lets
you quickly see your network, with the ability to filter and sort large numbers of
computers by dozens of properties.

The Visualization Tool allows you to quickly monitor large, globally distributed
networks, and follow remediation deployments and compliance, corporate-wide.
Web Reports allow operators with access to a browser to view audit trails and
generate listings and graphical reports with just a few mouse-clicks.

Running actions on the computers

You can perform the following actions on the computers:

Send Refresh
If you right-click any computer and select Send Refresh, the computer
information displayed is refreshed.

Send Wake on LAN Request
If you right-click any computer and select Send Wake on LAN Request,
the computer is powered on.

Send Client Alert Request
If you right-click any computer and select Send Client Alert Request, the
computer that is sleeping in deep mode is woken up and performs a full
cycle to go through all the content before going back to sleep again if
nothing has changed.

Monitoring Computer Status

BigFix can be used to analyze the computers in your network. Using the Relevance
Language, you can query any BigFix Client and get a real-time response. This can
be invaluable for analyzing trends and potential problem areas on your network.
To view the computers in your network, sorted and filtered by various properties,
follow these steps:
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Select the Computers icon in the Domain Panel navigation tree. Your
networked Client computers are shown in the List Panel, ready to be sorted
and filtered by various properties.

Click By Retrieved Properties (in the navigation tree under the Computers
icon) and open folders to filter the list.
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4 itemns in list, 1 selected.

Click the desired column headers in the resulting List Panel to sort the list.
Click again to reverse the sort order.

The folder names and column headers represent important, continuously updated
properties of your networked computers, called retrieved properties. To view the
Relevance Expressions that define the column headers:

Select Manage Properties from the Tools menu. A dialog opens, initially listing
the default properties that come predefined by IBM Endpoint Manager, such as
OS, CPU, Computer Name, and so on.

2. Click a retrieved property. In the text box underneath, you can view the

Relevance Expressions that are used to define this column.
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Evaluate every
OK Cancel

For example, the column heading CPU is generated by the following Relevance
Expression:

(significant digits 2 of (speed of main processor / mhz)) as string & "Mhz" &
family name of main processor...

That is, CPU is a concatenation of relevance expressions and strings that
produces an output like:

2800 Mhz Pentium 4

3. Each property has an evaluation period. The shorter the period, the more often
the client evaluates it. This makes the Console more up-to-date, but it might
impact client performance. Make sure long periods are allocated to
time-consuming or slowly changing Relevance evaluations.

You can quickly select which properties to display by right-clicking the column
headers of any Computer List Panel. A pop-up menu is displayed that allows you
to check or uncheck the properties you want to display. Notice that when you
delete a property from the headers, it is also removed from the navigation tree
under the Computers tab.

Grouping Computers

The BigFix Console allows you to group your computers to target them more
efficiently. You might want to group your development computers, for example, to
make sure you do not interfere with certain legacy software projects. There are
several ways to group computers, but the two most common techniques are
Manual Grouping and Automatic Grouping. Manual groups are static, but
automatic groups can change dynamically, depending on the current values of the
inclusion properties.

When grouped, you have provided yourself with a simple way to filter and
separate your networked computers. Open the Computers icon in the Domain
Panel navigation tree and select the folder named By Group. Then you can select
the group or groups you want to list. Alternatively, you can click the Computer
Groups icon and select groups under that icon as well.
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Whenever a list of computers is presented, you should find the By Group folder.
For example, when you click an Action button in a Fixlet or Task, you see the
Relevant Computers icon, listing just those computers that are affected by the
selected Fixlet. Open the By Group folder to narrow down the list of computers to
just the selected groups.

Note: A computer can belong to more than one group.

Commenting on Computers

You can attach a comment to a BigFix Client Computer, which other operators can
read.

1. Select the Computers icon in the Domain Panel navigation tree and open it if
you want to choose one of the Computer subcategories to narrow down your
list.

2. Select a computer from the List Panel on the right by clicking it.

w

From the document panel below, select the Summary tab.

4. Scroll to the bottom of the page, type your comment into the text box, and click
the Add Comment Button.

Your comment is name- and time-stamped for other operators to view it. As well
as Computers, you can attach comments to Fixlets, Tasks, Actions, and Analyses.

Creating Retrieved Properties
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You can collect information from BigFix Clients by defining various retrieved
properties. A large range of computer attributes can be monitored as retrieved
properties. There are several reasons why you might want to create some custom
retrieved properties of your own:

* When you create a retrieved property it can be used as a filter in all subsequent
computer listings, allowing you to control data sets that might otherwise be
difficult to visualize.

* Your newly-created properties are added to the column headers of computer
listings, allowing you to sort on their values.

* Retrieved properties can be used to fine-tune the targeting of Fixlet actions.
* Retrieved properties can also be used and charted in Web Reports.

BigFix includes a predefined set of retrieved properties, which are sufficient to
group computers by many frequently requested criteria. There are times, however,
when you might want even more control over how your Clients are grouped and
sorted.

To create a custom retrieved property, follow these steps:
1. Choose Tools > Manage Properties. The Manage Properties dialog is displayed.
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You can filter the properties by using the left filter panel to select a subset of
the properties to view on the right.

If you cannot find what you want in this list, create a new property: click Add
New, type in the name of your new retrieved property and create a Relevance
Expression to evaluate. This can access hardware characteristics, registry
entries, and even data in specific files on the client computers. After you define
the new property, the Clients automatically compute the value of the
corresponding relevance expression and return it to the Database.

3. Click the OK button.

Note: Some of these properties are aimed at specific operating systems and return
a blank string for other operating systems. If more than one result is retrieved for a
property, the entire list is retrieved.

Creating Client Dashboards

You can create custom BigFix Client Dashboards, similar to those in the Console.
Dashboards are HTML files with embedded Relevance clauses that can analyze the
local computer and print out the current results. Clients with a dashboard have an
extra tab to display the resulting report.

To create a Client Dashboard, you must create a new folder named __ UISupport
(note the two leading underscores) in the _ BESData folder. This is a subfolder of
the BES Client folder, so the final pathname looks like:

Program Files/BigFix Enterprise/BES Client/_ BESData/__UlSupport

Place the Dashboard file (named _dashboard.html) and any accompanying
graphics files into this folder. The next time the Client starts up, it incorporates
these files into its interface, adding a tab labeled Dashboard. When the user clicks
this tab, the Dashboard calculates the latest values of each Relevance clause and
displays them.
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The Relevance statements are embedded in the HTML inside special tags with the
form

<?relevance statement ?>

For example, to find and print the time, use the following:

<?relevance now ?>

When the Client displays the page containing this statement, it evaluates the
Relevance clause "now" and substitutes the value for the tag. The following sample
HTML prints out the word "Date:" and then the current date and time:

<html>
<body>
Date: <?relevance now ?>
</body>
</html>

To allow the user to refresh the Relevance evaluation, add this line to the file:

<html>
<body>
Date: <?relevance now ?>
<A href="cid:1oad?page=_dashboard.html1">Refresh</A>
</body>
</html>

This link, labeled Refresh, causes the page to reload. When it does, it reevaluates
the relevance clauses. It is easy to see how you would add other Relevance
expressions to this page. For example, to print out the OS and the computer name,
add these two lines:

<html>
<body>
Date: <?relevance now ?>
Operating System: <?relevance name of operating system ?>
Computer Name:<?relevance computer name ?>
<A href="cid:1oad?page=_dashboard.html"> Refresh </A>
</body>
</html>

You can use style sheets to format the output. You can even use the default
style-sheet, offer.css for some preset formatting. Here is an example of a
Dashboard with a title, a header, a refresh link, and a section of retrieved property
values:

<html>
<head>
<link type="text/css" rel="stylesheet" ref="offer.css"></1link>
<title> Dashboard Example</title>
</head>
<body>
<div class="header">
<div class="headerTitle">
<font size="6"><?relevance computer name ?></font></div>
<div class="headerCategory">
<font size="1">(Last updated: <?relevance now ?>)</font><BR>
<div>
<font size="1"><a href="cid:1oad?page=_dashboard.htm]">Refresh</a></font>
</div>
</div>
</div>
<div class="section">
<div class="sectionHeader">Computer Information</div>
<div class="subsection">
<table>
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<tr><td valign="top"> 0S: </td>
<td><?relevance operating system ?></td></tr>
<tr><td valign="top"> RAM: </td>
<td><?relevance (size of ram)/1048576 ?> MB</td></tr>
<tr><td valign="top"> DNS Name: </td>
<td><?relevance dns name ?></td></tr>
</table>
</div>
</div>
</body>
</html>

To learn more about Relevance expressions, see the Relevance Language Reference.

Locking Computers

You can change the locked status of any BigFix Client in the network. This lets
you exclude specific computers or groups of computers from the effects of Fixlet
actions. This could be useful, for example, if you want to exclude certain
development computers from any changes or updates. It also provides a powerful
technique for testing new Fixlet actions on a limited set of unlocked computers,
while keeping the rest of the network locked down. Client computers can be
locked forever (until explicitly unlocked) or for a defined period of time.

Changes are made to the locked status of a Client by sending an action. As a
consequence, the Console operator must supply correct authentication to lock or
unlock any computer. Even though a Client is locked, there is still a subset of
actions that can be accepted by the client. These include clock changes and unlock
actions as well as actions from the BES Support site.

To lock or unlock a computer, follow these steps:

1. Click the Computers icon in the Domain Panel navigation tree to open the List
Panel of networked BigFix Client computers.

2. Select the computers that you want to lock.

3. Right-click and select Edit Computer Settings from the menu, or select Edit
Computer Settings from the Edit menu. The Edit Settings dialog opens.
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4. Click the checkbox to either lock or unlock the computer.

Although the Console does not provide an explicit interface for setting an
expiration date on the lock, you can create a custom Action to do so. For more
information, see the Action Guide.

Removing Computers
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This feature allows you to remove computers that are no longer reporting in, such
as decommissioned computers. When you remove a computer from the database,
you do not need to uninstall or unsubscribe the client. If the client gets reactivated
and reports back to the Console, the computer is included in the database with its
old information intact. Until then, the client is not listed in the Console.

To remove a computer from the database, follow this procedure:

1. Click the Computers icon in the Domain Panel navigation tree to see a list of
Clients in the List Panel.

2. Right-click a Computer in the list and select Remove from Database from the
context menu (or select Remove from the Edit menu).

3. Confirm the removal in the subsequent dialog.

This computer is no longer visible in the Console unless reactivated by the BigFix
Client itself.
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Chapter 10. Computer Groups

Introducing Computer Groups

Grouping your BigFix Client computers can simplify the maintenance of large
networks. There are many ways to group computers, from simple manual selection
to more flexible automatic grouping.

A simple grouping technique is to manually select members of a group from the
listing in the Computers List Panel. For a quick look at a manual selection, click
View as Group from the right-click context menu. This opens an Ad-Hoc
Computer Group document in the Work Area where you can quickly analyze
various properties of the group. Ad-hoc groups are temporary, but you can create
persistent groups by choosing Add to Manual Group from the same context menu.
These techniques are simple, but in a network with many thousands of computers,
they can be tedious.

A more powerful technique is to define criteria for Automatic Grouping. From the
Tools menu, select Create New Automatic Computer Group.

Create Automatic Computer Group e

Group narmes

Create in site: | Master Action Site = | Create in domain: All Content - |

Include computers with the following property:
| Computer Name = | |contains x| | Acct- &

! Create | Cancel

Here you can define membership in a group based on the values of specific
computer properties. You could, for example, group computers by IP address
ranges, operating systems, applications, and thousands of other criteria using
Relevance expressions. Groups created this way have the benefit of automatic
enrollment and expulsion, so that a computer that is repurposed to a different task
or department automatically switches groups without operator intervention.

Creating Manual Computer Groups

To Manually create a computer group, follow this procedure:

1. Click the Computers icon in the Domain Panel navigation tree and in the
resulting List Panel, shift- and ctrl-click to select the computers you want to
group together.

2. Right-click the computers you choose and select Add to Manual Group from
the menu.

3. From the Select Manual Computer Group dialog, you can choose to add your
selected computers to an existing group or create a new group for them.
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Select Manual Computer Group |

Add the selected computers to the manual group selected below:

Group Mame . Computers

Nein T Group

@ Add the selected computers to a new manual group named:

e Gioud

oK | Cancel |

Select an existing group or name a new one and click OK.

This computer group is added under the Computer Group icon in the Domain
Panel navigation tree and helps you to subdivide your networked computers down
into more reasonably sized chunks.

Groups use a global scope grouping mechanism that allows any operator with
management rights on the device to edit membership. While manual groups are
shared by operators with rights over the machine, dynamic groups have their own
scope.

Creating Automatic Computer Groups

To create a group that automatically enlists computers, follow this procedure:
1. Click Tools > Create New Automatic Group.

2. From the Create New Automatic Computer Group dialog, enter the name of
your group and select the site and domain you want it to be located in.

Create Automatic Computer Group )
Group name:  Tokyo Accounting
Create in site: | Master Action Site =| Create in domain; IL!—".H Content 'J:
Include computers with |all = | of the following properties:
;-L,ncaticn | i-u.:;:Eains »| Tokyo '._i L._
i:l.:_ompu'tcr MHame z ic.untaini ™| acct | . j |
! Create {} ! | Cancel

3. Enter a property, a relation, and a value into the three boxes at the bottom of
the dialog. For example, to create a group that automatically enlists Windows
computers, select OS contains Win. Click the + button to add new properties
that you can AND (include all properties) or OR (include any properties)
together to identify group membership.

4. When you are finished, click Create to propagate the group settings.
You now have a new Automatic Computer Group that is listed under the

Computer Groups icon in the Domain Panel navigation tree and can be used to
subdivide your network into more workable chunks. Unlike Manual Groups,
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which are statically defined, Automatic Groups change their population depending
on the evaluation of the group properties.

Commenting on Computer Groups

You can attach a comment to a Computer Group, which other operators can read.

1. Open the Computer Groups icon in the Domain Panel navigation tree and
choose one of the categories under the icon to narrow down your list.

2. Select a computer group from the resulting List Panel on the right by clicking
it.

3. From the document panel below, select the Description tab.

4. Scroll to the bottom of the page, type your comment into the text box and click
the Add Comment Button.

F.ﬁ.dd Comment 'ﬁ

Add the following commaent to all currently selected itermns:

|. QK _ Cancel

Your comment is name- and time-stamped for other operators to view it. As well
as Computer Groups, you can attach comments to Fixlets, Tasks, Actions, and
Analyses.

Removing Computer Groups

To remove a computer from BigFix administration, follow this procedure:
1. Click the Computer Groups icon in the Domain Panel navigation tree.

2. Right-click a Computer Group from the resultant List Panel and select Remove
from the context menu (or select Remove Computer Group from the Edit
menu).

This computer group is deleted from the list.
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Chapter 11. Analyses

Introducing Analyses

An Analysis is a collection of property expressions that allow an Operator to view
and summarize various properties of BigFix Client computers across a network.
The collection is grouped together to be labeled, edited, and activated against
groups of computers to allow the results to be displayed together. For example,
suppose you have a custom application deployed in your network, and you want
to create an analysis to give you important information about the state of your
machines relative to that custom application. You might build an analysis with
several properties, such as:

* Is the custom application installed?
* What is the version of the custom application?
* Is the application currently running?

With an analysis composed of these properties, operators can activate the analysis
against groups of machines to get visibility into the state of the network as it
pertains to the custom application.

There are several pre-made Analyses that examine important aspects of your
networked computers, including their hardware, applications, and
Server/Relay/Client relationships.

Studying these default Analyses can be instructive when you want to make your
own or customize existing ones. Custom Analyses can help you monitor aspects of
your network that are vital to your company's operation.

The Retrieved Properties that underlie each Analysis are created using Relevance
expressions. For example, to make sure you have fully deployed the most recent
IBM Endpoint Manager Client software, you might use an expression such as
version of client. This simple expression is evaluated on every computer where
the analysis is targeted, allowing you to see explicitly which version of the IBM
Endpoint Manager Client is running on each computer, or to view a summary of
how many machines are running each version.

Analyses are targeted with yet another Relevance statement, which might be as
simple as TRUE, which would include all connected Clients. Generally, you want
to narrow the scope with a Relevance statement such as name of operating system
as lowercase starts with "win", which would limit the Analysis to Windows
computers only.

Viewing Analyses

To display an Analysis,
1. Click the Analyses icon in the Domain Panel navigation tree.
2. Click an entry in the resulting Analysis List Panel.

The body of the Analysis is shown in the Work Area below the list (click the
Description tab if not already selected).
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Analysis: BES Relay Status o O
L Activate Qs Deactivate | »# Edit |3 Export | Hide Locally Hide Globally | 3 Remove

Description | Details ! Applicable Computers (5)

Description

This analysis contains infermation about the health of the
BES Relay deployment. This information will be useful

In assessing where the BES Relays are set up properly and
whather the BES Clients are correctly reporting to them.

After activating this analysis, you will see the following
proparties:

BES Relay Installed Status
BES Client's Parent Relay
BES Relay's Parent Relay
Manual Selection Status

® Click hete lo activate this analysis

® Click here to read more information about BES Relays

The Analysis display region has several tabs:

Description: This is an HTML page providing a description of the analysis.

Details: This panel provides a property-by-property listing of the chosen
analysis, as well as the Relevance statement that is being used to target the
chosen computers. At the bottom is a text box for entering a comment that to be
attached to this analysis.

Results: This dialog lists the actual results of the analysis, which can be filtered
and sorted by the pre-assigned properties (this tab is only available if the
Analysis is activated).

Applicable Computers: This is a filter/list of all the computers where the

selected analysis is applicable. You can filter the list by selecting items from the
folders on the left, and sort the list by clicking the column headers.

Monitoring Analyses
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When an analysis is activated, BigFixr adds it to the list displayed by the Analyses
icon in the Domain Panel navigation tree. The Analysis List Panel contains entries
that can be sorted by the following column headers:

Name: The name assigned to the Analysis by the author.
Status: The activation state of the Analysis.
Site: The name of the site that is generating the relevant Analysis.

Applicable Computer Count: The number of IBM Endpoint Manager Clients in
the network currently being analyzed.

Activated By: The name of the Console operator who activated this analysis.
Time Activated: The date and time the analysis was activated.
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As with all the icons in the Domain Panel navigation tree, you can filter this list by
opening the Analyses icon and selecting any of the icons beneath it. Each icon you
click narrows down the list of Analyses on the right. Then, in the listing area itself,
you can sort the Analyses by clicking a column heading.

For example, you might filter the list by opening the Activated Analyses sub-icon,
then opening the Activated By folder and selecting a specific Operator to see the
subset of analyses that have been activated by that Operator.

Commenting on Analyses

You can attach a comment to an Analysis that other operators can read:

1. Select the Analyses icon in the Domain Panel navigation tree and choose one of
the subcategories underneath it to narrow down your list.

2. Select an Analysis from the resultant List Panel on the right by clicking it.

3. In the Work Area below, select the Details tab. Scroll to the bottom of this
dialog to the comments text box.

4. Type your comment into the text box and click the Add Comment button.

Your comment is name- and time-stamped for other operators to view it. As well
as Analyses, you can attach comments to Fixlets, Tasks, Actions, and Computers.

Creating Analyses

Analyses allow you to create and track specified properties of your managed
BigFix Clients. These properties can be extracted from any subset of your network,
which simplifies the process of managing inventory, licensing, security, and
policies. Using Web Reports, you can view a history of each analysis.

Analyses are also the only way for Non-Master Operators to create retrieved
properties, because they do not have access to the Manage Properties Dialog.

To create your own custom Analysis, follow these steps:
1. Select Tools > Create New Analysis

2. This opens the Create Analysis dialog with a text box for entering the name of
your new Analysis.

.:‘, Create Analysis =@ !@

Mame: JCustom Anahysis] Create in site: | Master Action Site |

- : Create in domain: | All Content X
Description | Properties | Relevance .

Description

<enter a descnption of the analysis here>

® Click here to activate this analysis.

4| Autornatically activate this anshysis after it is crested.

[_ oK J Cancel
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Because you can use the name for sorting and filtering, create a consistent
naming convention to make your Analyses more accessible. Enter the name and
then select the host site and domain for the Analysis from the drop-down
menus at the right. The dialog contains three tabs. Click through each tab to
define your Analysis:

* Description: In this dialog, you can enter the text that describes your
Analysis. You can choose from the text editing tools at the top of the text box
to create your custom content.

* Properties: Add the retrieved properties that form the core of your Analysis
by clicking the Add Property button, then providing a name and a Relevance
expression that is evaluated to create the returned property value.

* Relevance: Enter another Relevance expression that determines which
computers are selected for this Analysis.

Check the box at the bottom of the dialog if you want to automatically activate
the Analysis. When you are satisfied with your Analysis definitions, click OK.

Your Analysis must be propagated, so you are prompted for your private key
password. When you enter it and click OK, your Analysis is sent to all the
Clients, which evaluate it for relevance and report back their status. You can
now monitor specific properties of your networked Clients from the Console.

Editing Analyses
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To edit an Analysis, follow these steps:

1.

Open the Analyses icon in the Domain Panel navigation tree, and select My
Analyses as a filter. In the resultant List Panel, select the Analysis you want to
edit. Note that not all Analyses are editable.

Select Edit > Edit Custom Analysis (or right-click the Analysis and select Edit
from the pop-up menu).

This opens the Edit Analysis dialog.

(], Edit Analysis [l &=
Mame: Local Time Zone] Create in site:

Deseription | Progerties I PR Create in domain: _MI Content x|

Description

Retums the local time zone as a number from -12 to 12

® Click here to activate this analysis

| Automatically activate this analysis after it is created.

| QK Cancel |

Edit the Name of the Analysis and then select the hosting site and domain
from the pull-down menus. Below this, there are three tabs. Click through each
tab to customize your Analysis:

* Description: Edit the description of the Analysis, explaining the properties
that are being analyzed.

* Properties: This is the core part of the Analysis.
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] Edit Analysis
Name: Lacal Time Zone Create in site | Master Action Site
[ 1 1 | =
Description| Properties | Relevance Create in domain: !_NI Content
—
== (At Propeny ]
Local Time Zone f -
current time ‘;} | Remowve Property
Mame: Local Time Zone
Relevance: {{local time zone as string) as integer)/100 -
Evaluate every 'E\-'!Iy Report zl
| Automatically activate this analysis after it is created.
OK | Cancel |

Click Add Property or choose an existing property and the relevance box
becomes editable. If you are adding a new property, enter its name and
relevance to define it. Otherwise, edit the existing text. The Relevance clause
is evaluated to provide the retrieved property value. You can add more
properties, or click the Remove Property button to delete the highlighted
one.

Relevance: Here is where you define a Relevance statement to target specific
computers for your Analysis.

(} Edit Analysis

MName: Local Time Zone Create in site:

Create in domain: -le_unlcnt -
Dﬁcnpncnl Properties| Relevance |

This analysis will be relevant on the following computers:
All computers
Computers which match the condition below

@ Computers which match all of the relevance clauses below
1. version of client > "5.0.0.0" -1-

¥ Automatically activate this analysis after it is created.

oK [ cancel

Select All computers or enter an expression that targets a subset of your
networked Clients. Otherwise, you can set specific conditions or relevance
clauses to limit the application of the Analysis.

When you are satisfied with your edits, click OK.

Your Analysis must be propagated, so you are prompted for your private key
password. When you enter it and click OK, your edited Analysis is sent to all
the Clients.

Hiding Analyses

You can hide an Analysis with the following procedure:

1.

From any Analysis List Panel, select the Analysis you want to hide.
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2. Right-click the Analysis and select either Globally Hide Analysis or Locally
Hide Analysis from the context menu (or select these same choices from the
Edit menu).

The selected Analysis is no longer displayed in the Analysis list. If you chose to
hide the Analysis locally, it is still visible to other Console users. If you are a
master operator, you can hide an Analysis globally, to have it also hidden from all
non-master users.

Items that are hidden are still available and you can restore or unhide them at any
time. Here is how:

1. Click the Show Hidden Content icon in the Console toolbar.

2. Right-click the Analysis you want to restore and select the appropriate action
from the pop-up menu. You can unhide or switch the hiding scope between
global and local.
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Chapter 12. Baselines

Introducing Baselines

Baselines are collections of Fixlet messages and Tasks. They provide a powerful
way to deploy a group of Actions across an entire network with a single
command.

Baselines provide a way to maintain a common operating environment, making
sure that all users in any given domain have the same software, patches, and
drivers. Baselines are easy to set up, by selecting the Fixlet messages, Tasks, and
other Baselines that you want to be a part of the group. To limit the scope of a
Baseline, a Relevance expression can be used to target any subset of your network,
using IP addresses, computer names, operating systems, and many other qualifiers.

For example, you might make a Baseline named "All critical hotfixes," and
populate it with all the current critical hotfixes available in the Fixlet list. Or you
might create one named "Finance department baseline," to keep that particular
group of computers updated with the latest financial programs, financial tables,
updates, and patches.

Viewing Baselines

Baselines allow you to group Fixlet messages and Tasks into a group for simple,
one-click deployment. To display an existing Baseline, click the Baselines icon in
the Domain Panel navigation tree. From the resulting List Panel, click an item. The
body of the Baseline is shown in the Work Area below.

i) Tivoli Endpoint Manager Consale = & =
File Edit View Go Tools Help

‘= Back = B Forwerd = | % Show Hidden Content ') Show Mon-Relevant Content | &% Refresh Console

All Content « Baselines l'.--::-' ch Baselines }.-ll =

€~ | Name Site Applicable C

Mdl"“ J 1. | MyCorp Accounting Eé Master Action Site 4 /5
Zr Actions (0) 3 = ;
= Dashboard z
E ?-:Lardc: i [Bazetine WyCorp Accounting =
] Custern Content & Take Action | # Edit | Copy | v Export | Hide Locally Hide Globally | 3 Remove
5 Custom Filters E
4 5 Computers (5) Description | Details ] Compenents ] Applicable Computers {-i}l Component Ap | *
4 5] By Retrieved Pro -
=l Bv Compute ™ Description
Ey m k
This content is onented toward MyCorp's Accounting
@ All Content departmenis
@ BigFix Management
Actions
W Endpoint Protection
® Click here to deploy this action group
e BF 3% =
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The Baseline display region has several tabs:

Description: This is typically an HTML page providing a descriptive explanation
of the problem and an action to fix it.

Details: This tab lists the Baseline Properties, a section detailing the code behind
the Relevance expressions and the Baseline actions, along with other Baseline
properties. Scroll to the bottom to enter a comment as a note for yourself or
other Console operators.

Components: This tab lists the components, namely the Fixlet messages, Tasks,
and other Baselines that are grouped into this Baseline. Because Baselines make
a copy of the components, it is possible for one of these copies to get out of sync
with the underlying Fixlet or Task that spawned it. If this happens, a message is
displayed saying that the source differs from the copy and allowing you to
synchronize with the current source.

Applicable Computers: This is a filter/list of all the computers targeted by the
selected Baseline. You can filter the list by selecting items from the folders on the
left, and sort the list by clicking the column headers.

Component Applicability: This is a filter/list of the various components of the
Baseline. It displays the number of computers where the Baseline is currently
applicable and, after a slash, the number where it is not. Double-click an item in
the list to display it for inspection.

Action History: This is a filter/list of any Actions that have been deployed from
this Baseline. If the Baseline is new, there are no Actions in the list. Like the
other filter/lists in the Console, you can filter the actions using the left panel,
and sort them by clicking the column headers.

Monitoring Baselines

When Baselines become relevant somewhere in your network, the BigFix Console
adds them to the list of Baselines to be displayed under the Baselines icon in the
Domain Panel navigation tree. You can filter this list by opening the icon and
selecting one of the subsets. In the resulting List Panel on the right, you can sort
the Baselines by clicking one of the column headings, which might include the
following fields:

Name: The name assigned to the Baseline by the author.
ID: A numerical ID assigned to the Baseline by the author.
Site: The name of the site that is generating the relevant Baseline.

Applicable Computer Count: The number of BigFix Clients in the network
currently targeted by the Baseline.

Open Action Count: The number of actions open for the given Baseline.

If you do not see one of the columns listed above, right-click in the Baseline header
and select it from the pop-up menu.

Commenting on Baselines

92

You can attach a comment to a Baseline, which other operators can read.

1.

Select the Baselines icon in the Domain Panel navigation tree and open it if
you want to choose one of the Baseline subcategories to narrow down your list.

Select a Baseline from the List Panel on the right by clicking it.

From the document panel below, select the Details tab and scroll to the bottom
of the page.
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4. Type your comment into the text box and click the Add Comment Button.

Your comment is name- and time-stamped for other operators to view it. As well
as Baselines, you can attach comments to Fixlets, Actions, Computers, and
Analyses.

Creating or Customizing Baselines

Baselines allow you to gather multiple Fixlets and Tasks into groups that can be
applied immediately to any set of target computers. The name Baseline was chosen
to suggest a minimal set of conditions that could be applied across your network
to ensure compliance with corporate guidelines. To create your own custom
Baseline from scratch, follow these steps:

* In a Fixlet or Task list, highlight one or more items and select Add To New
Baseline from the context menu. You can also select Create New Baseline from
the Tools menu.

To clone off a Baseline and customize it, first select the Baseline in any list, then:

* Select Edit > Create Custom Baseline Copy (or right-click the Baseline and
select Create Custom Copy from the pop-up menu).

Either way, this opens a dialog with four tabs.

] Create Baseline of=E) @
MName: Create in site: Master Action Site -|
Createin domain: | All Content -

Description | Components | Relevance | Properties

Description

<enter a description of the baseline here>

Actions

® Click hﬂglln deploy this action group.

oK Cancel

At the top of the dialog, you can specify the name of your custom Baseline as well
as the Site and Domain that will host the Baseline. Click through each of the tabs
below to define your Baseline:

* Description: This dialog lets you describe your custom Baseline as an HTML
page. Edit the text, using the text toolbar at the top of the window.

* Components: You can add or customize the components of a Baseline. To add a
new component, click the add components to group link. From the resulting
dialog, you can select new Fixlet messages, Tasks, and other Baselines to add to
the existing Baseline group.
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In the example above, the two added components have been expanded to show
their relevance. The check box Baseline will be relevant on applicable
computers where this component is relevant is used to tell whether the related
component (Task or Fixlet) makes the baseline relevant on those computers
where that component is relevant. The default value is unchecked for Tasks and
checked for Fixlets.

Note: If the associated Action Group is relevant and is scheduled to start at a
later time, it starts even if it becomes no-relevant afterwards.

* Relevance: Enter your relevance statement here, or modify the existing relevance
statement. This allows you to further constrain your Baseline to specific
computers. By default, this Relevance statement is TRUE, which leaves the job of
targeting to the individual Fixlets and Tasks that make up the Baseline. For more
information about the relevance language, see the Inspector Libraries.

* Properties: Customize the properties of your Baseline, or accept the original
properties. Because you have customized the Baseline, update the source fields
to reflect the new authorship. There are fields here that specify the category,
download size, source information, and the CVE/SANS ID codes.

When you are satisfied with your Baseline modifications, click OK. Because your
customized Baseline must be propagated, you are prompted for your private key
password. When you enter it and click OK, your Baseline is sent to all networked
Clients, which evaluate it for relevance and report back their status. You can now
follow the deployment of your own custom Baselines from the Console.

Hiding Baselines

You can hide a Baseline with the following procedure:
1. From any Baseline List Panel, select the Baseline you want to hide.

2. Right-click the Baseline and select Globally or Locally Hide Baseline from the
pop-up menu (or from the Edit menu).
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The selected Baselines are no longer displayed in the Baseline list. If you chose to
hide the Baseline locally, it is still visible to other Console users. If you are a
Master Operator, you can hide a Baseline globally, to hide it also from all
non-master users.

Items that are hidden are still available and you can restore or unhide them at any
time. Here is how:

1. Click the Show Hidden Content button in the Console toolbar.

2. Click the Baselines icon in the Domain Panel navigation tree, which now
shows all the hidden content.

3. From the List Panel, choose a Baseline and choose Edit > Hiding >
Locally/Globally Unhide or right-click and choose the same option from the
context menu. You can also open the hidden Baseline and click the Unhide
button in the Work Area below.

Generally it is not necessary to hide Baselines, because you can simply ignore
them. The main reason for hiding a Baseline is if you think that the message is not
relevant to your network and you want to avoid viewing the Baseline every time
you launch the Console.
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Chapter 13. Relays and Servers

Understanding Relays

Relays are optional network components that can significantly improve the
performance of your installation. Downloads and patches, which are often large
files, represent by far the greatest fraction of the program's bandwidth. Relays are
designed to take over the bulk of the download burden from the BigFix Server.
Rather than downloading patches directly from a Server, Clients can instead be
instructed to download from designated Relays, significantly reducing both server
load and client/server network traffic. Relays help in the upstream direction as
well, compiling and compressing data received from the Clients before passing it
on to the Server. Any Windows 200x, Windows 7, Vista, or XP-based client can
serve as a Relay. Several other operating systems can support relays as well, such
as Solaris, and some variants of Linux. See the support site for the latest
information.

A Relay simultaneously resolves two bottlenecks:

* Relieves the Load on BigFix Servers. This Server has many duties, among them
the difficult job of distributing patches and other files. A Relay can be set up to
ease this burden, so that the Server does not need to distribute the same files to
every Client. Instead, the file is sent once to the Relay, which in turn distributes
it to several Clients. The overhead on the Server is reduced, on average, by the
ratio of relays to clients.

* Reduces Congestion on Low-Bandwidth Connections. If you have a BigFix
Server communicating with a dozen computers in a remote office over a slow
VPN, designate one of those computers as a Relay. Then, instead of sending
patches over the VPN to every BigFix Client independently, the BigFix Server
only sends a single copy to the Relay. That Relay, in turn, distributes the file to
the other computers in the remote office over its own fast LAN. This effectively
removes the VPN bottleneck for remote groups on your network.

Note: Relays also work well to reduce total network usage when used on
subnets connected through switches on your LAN. Ask IBM Software Support
for more details.

Assigning Relays is simple, and Clients can be configured to automatically
discover and link to them. The program enables the Clients to discover their
nearest relays, or they can be configured manually.

Relay requirements

A Relay takes over most of the download tasks of the BigFix Server. If several
Clients simultaneously request files from a Relay, a significant amount of the
computer's resources might be used to serve those files. Other than that, the duties
of the Relay are not too demanding. The requirements for a Relay computer vary
widely depending on three main factors:

* The number of connected Clients that are downloading files.
* The size of each download.
* The period of time allotted for the downloads.
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The Relay system requirements are similar to those for a workgroup file server. A
computer with 1 GHZ CPU, 256 MB RAM, and 5 GB of free space on the hard
drive can act as a Relay for as many as one thousand computers, if the Console
operator distributes the file downloads over an appropriate length of time. Here
are some further requirements and recommendations:

* The Relay can only be installed on computers running under Windows 200x, 7,
Vista, or XP as well as Red Hat Enterprise Linux 4/5/6/7, and Solaris 10.

* The Relay can be installed on an ordinary workstation, but if several Clients
simultaneously download files, it might slow the computer down.

* Workgroup file servers and other server-quality computers that are always
turned on are good candidates for installing a Relay.

Setting Up Relays

To set up a Relay, you must designate a Windows 200x, Windows 7, Vista, or XP
client computer to take over some server duties. When a Relay has been set up,
computers in the network can automatically find them and connect to them (or
you can manually assign BigFix Clients to point to specified relays).

This significantly reduces the client/server communication necessary for patch
application and management. Clients start to download from these designated
relays, minimizing the load on thin connections to the BigFix Server. The Clients
also upload their status information to the Relay, which compiles and compresses
it before passing it on up to the server.

To configure a client computer as a Relay, follow these steps:
1. Open Fixlets and Tasks from the Domain Panel and select Tasks Only.

2. Double-click the task labeled Install BigFix Relay. A task window opens below.
Make sure the Description tab is selected. There are three choices for where to
place the Relay installation folder:

¢ Install to a given path. This option allows you to specify a path for the Relay
installation folder.

* Install on the drive with most free space. This action lets you automatically
choose the most capacious drive for the installation folder.

* Install to the default location. This is the recommend action. It automatically
finds the optimal location for the installation folder.

After the relays have been created, Clients can be made to automatically discover
and connect to them, always seeking the Relay that is the fewest hops away.

If you need to manually configure your Clients, you must notify each computer to
use a specific relay to point to, as described in Using Relays.

Using Relays

When you have set up a Relay you must direct IBM Endpoint Manager Clients on
your network to gather from that relay, instead of from your Server. IBM Endpoint
Manager can automatically assign your relays for you. This is not without risks
(see the Administrator's Guide or visit the support site for more information), but
it can be a good idea for two reasons:

* Clients can determine which relays are the fewest number of hops away, so your
topology is optimized.
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* Your network configuration is constantly shifting as laptops dock and undock,
as computers start up or shut down, or as new hardware is added or removed.
Clients can dynamically assess your configuration to maintain the most efficient
connections as your network changes.

Note: On relay systems, do not assign as primary relay the relay that is local to
the endpoint.

Automatic Relays

Here is how you can ensure that your BigFix Client computers are automatically
signing up to the nearest relays:

1. Click the Computers icon in the Domain Panel to display a filter/list of BigFix
Client computers.

2. Select the set of computers that you want to automatically connect to the
optimal Relay.

3. Right-click the highlighted computers and select Edit Computer Settings from
the pop-up menu.

4. Check the box labeled Relay Selection Method.

5. Select the button labeled Automatically Locate Best Relay.

6. Click the OK button.

Manually Assigning Multiple Clients

You can select all the computers (or any given subset) of the local network to

gather from a specified relay. The procedure is different for setting a single

computer or multiple computers. Here is how to set multiple computers to point to

a relay:

1. Click the Computers icon in the Domain Panel to display a list of BigFix Client
computers.

2. Select the set of computers that you want to connect to the BigFix Relay. You
can use the filter panel on the left to narrow down the computer list.

3. Right-click the highlighted computers and select Edit Computer Settings from
the pop-up menu.

4. Check the box labeled Primary Relay.

5. Select the name of a Relay from the pull-down menu.

6. Click the OK button.

Manually Assigning Single Clients

Here is how to set a single computer to point to a relay:

1. Click the Computers icon in the Domain Panel to display a filter/list of BigFix
Client computers.

Right-click the single computer that you want to connect to the BigFix Relay.
Select Edit Computer Settings from the pop-up menu.

Check the box labeled Assign Relays Manually.

From the Primary Relay pull-down menu, select a Relay.

Click the OK button.

L S
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Adjusting the BigFix Server and Relays

To get the best performance from BigFix, you might need to adjust the server and
the relays. There are two important ways of adjusting the flow of data throughout
your network, throttling and caching;:

Throttling Outgoing Download Traffic
Throttling allows you to set the maximum data rate for the BigFix Server.
Here is how to change the data rate:

1. Open Fixlets and Tasks icon in the Domain Panel navigation tree and
then click Tasks Only.

2. In the find window above the Tasks List, type "throttle" to search for
the appropriate Task.

3. From the resulting list, click the task labeled Server Setting: Throttle
Outgoing Download Traffic. A task window opens below. Make sure
the Description tab is selected. There are three choices:

* Set the limit on total outgoing download traffic. This choice allows
you to directly set the maximum number of kilobytes per second you
want to grant to the server.

* Disable the setting. This option lets you open the download traffic
on the BigFix Server to full throttle.

* Get more information. This option opens a browser window with
more detailed information about bandwidth throttling.

4. If you select a throttle limit, then from the subsequent Take Action
dialog you can select a set of computers to throttle. Click OK to
propagate the task.

Download Cache Size
BigFix Servers and Relays maintain a cache of the downloads most recently
requested by Clients, helping to minimize bandwidth requirements.

1. Open Fixlets and Tasks icon in the Domain Panel navigation tree and
then click Tasks Only.

2. In the find window above the Tasks List, type "cache" to search for the
appropriate Task.

3. From the resulting list, click the task labeled Relay / Server Setting;:
Download Cache Size. A task window opens below. Make sure the
Description tab is selected. Select the link to change the download
cache size on the listed computers. This list might include Relays as
well as the BigFix Server.

4. Enter the number of megabytes to cache. The default is 1024 MB, or
one gigabyte.

5. From the subsequent Take Action dialog, select a set of computers and
click OK.

Dynamic bandwidth throttling
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When a large download becomes available, each link in your deployment might
have unique bandwidth issues. There are server-to-client, server-to-relay, and
relay-to-client links to consider, and each might require individual adjustment. As
explained elsewhere, it is possible to simply set a maximum value (throttle) for the
data rates, and for this there are broad-based policies you can follow. You might,
for example, throttle a BigFix Client to 2Kb/s if it is more than three hops from a
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Relay. However, the optimal data rates can vary significantly, depending on the
current hierarchy and the network environment.

A better technique is to use dynamic bandwidth throttling, which monitors and
analyzes overall network capacity. Whereas normal throttling simply specifies a
maximum data rate, dynamic throttling adds a “busy time” percentage. This is the
fraction of the bandwidth that you want to allocate when the network is busy. For
example, you could specify that downloads do not use any more than 10% of the
available bandwidth whenever the program detects existing network traffic.
Dynamic throttling also provides for a minimum data rate, in the case the busy
percentage is too low to be practical.

When you enable dynamic throttling for any given link, the program monitors and
analyzes the existing data throughput to establish an appropriate data rate. If there
is no competing traffic, the throughput is set to the maximum rate. In the case of
existing traffic, the program throttles the data rate to the specified percentage or
the minimum rate, whichever is higher. You must enable dynamic throttling on
both the server and the client side to have it work correctly.

You control dynamic bandwidth throttling with computer settings. There are four
basic settings for each link:

DynamicThrottleEnabled
This setting defaults to zero (disabled). Any other value enables dynamic
throttling for the given link.

DynamicThrottleMax
This setting usually defaults to the maximum unsigned integer value,
which indicates full throttle. Depending on the link, this value sets the
maximum data rate in bits or kilobits per second.

DynamicThrottleMin
This setting defaults to zero. Depending on the link, this value sets the
minimum data rate in bits or kilobits per second. This value places a lower
limit on the percentage rate given below.

DynamicThrottlePercentage
This setting defaults to 100%, which has the same effect as normal
(non-dynamic) throttling.. It represents the fraction of the maximum
bandwidth you want to use when the network is busy. It typically has a
value between five and ten percent, to prevent it from dominating existing
network traffic. (A zero for this setting is the same as 100%.).

As with any other setting, you can create or edit the dynamic bandwidth settings
by right-clicking an item (or group of items) in any computer list and choosing
Edit Computer Settings from the context menu.

The specific variable names include:

The BigFix server and relay settings:

_BESRelay HTTPServer DynamicThrottleEnabled
_BESRelay_HTTPServer_DynamicThrott1leMaxKBPS
_BESRelay_HTTPServer_DynamicThrottleMinKBPS
_BESRelay_HTTPServer_DynamicThrottlePercentage

The BigFix Client settings:

_BESClient_Download_DynamicThrottleEnabled
_BESClient_Download_DynamicThrottleMaxBytesPerSecond
_BESClient_Download DynamicThrottleMinBytesPerSecond
_BESClient_Download_DynamicThrottlePercentage
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The Gathering settings:

_BESGather_Download_DynamicThrottleEnabled
_BESGather_Download_DynamicThrottleMaxBytesPerSecond
_BESGather_Download_DynamicThrottleMinBytesPerSecond
_BESGather_Download_DynamicThrottlePercentage

Note: For any of these settings to take effect, you must restart the affected services
(Server, Relay, or Client).

If you set a Server and its connected Client to differing maximums or minimums,
the connection chooses the smaller value of the two.
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Chapter 14. Activating the license counting process

Currently, the association of the clients to one or more products is manually
performed by the IBM BigFix Inventory (*) user.

To enable the IBM BigFix Inventory scanner to automatically provide this
association, the administrator can activate the following license counting process
by:

* Optionally categorizing the metric of the clients, as described in
[the clients” on page 104

* Distributing the licensed products information to the clients, as described in
[“Distributing the site mapping file” on page 107 |

* Generating the correct license tags on each client, as described in
[the license tags” on page 108

Note: (*) The concepts and procedures described in the following sections apply to
both IBM BigFix Inventory and IBM License Metric Tool (ILMT).

The following diagram shows the license counting process.

License Counting Process flow

Tagging and
Categorization
Fixlets

License tags

(optional) BigFix Operator
overrides default license metrics i

0

BigFix Operator distributes the i ® Products are displayed with appropriate
site-to-product mapping file to the | license (for example, ClientDevice/MVS/RVU)
endpoints 3 in the BigFix Inventory user interface
BigFix Operator deploys the Bigfixt Console i Wieb Browser Dt
Fixlet to generate license tags Windows ! tagged
as a policy action | components
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‘Windows/RHEL MS SQL 2005/2008
DB2 10.x Workgroup

\(u‘ebSphareB., Lierty
@ (optional) Client setting is set with user @ Windows/RHEL
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License tags are correlated with license-
specific components in the catalog.
@ The Fixletto generate license tags 7
reviews content sites subscribed on the ’;-"ﬁ_
endpoint and uses the site-to-product
mapping to decide which tags to place on

the endpoint. Bigfiz Agents

Figure 1. License counting process

Prerequisites

Before activating the license counting process, ensure that you meet the following
requirements:
* Your BigFix server version must be 9.0 or later.

* The agent version of your subscribed computers must be 8.2 or later.
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* The ActiveX option of Internet Explorer on the computer where the console is
installed as follows:

1. Go to Tools > Internet Options > Security tab

2. Select the Internet zone.

3. Click Custom Level.

4. Locate Initialize and script ActiveX controls not marked as safe for
scripting.

5. Set it to Prompt.

This local Internet Explorer setting allows you to run the Distribute site
mapping file Fixlet.

Categorizing the clients

104

When you categorize the clients, you assign to the clients non-default metrics for
each selected product, from the licensed ones.

The result of this operation is the value of the following client setting:
_BESClient_LicenseType_productname

Based on the client operating system, the default metric for the products is rigidly
determined.

The following table displays this mapping:

Table 2. Mapping between the client platform and the product default metric

OS type OS name example Default metric

Supported UNIX Solaris, HP-UX, AIX RVU

Supported Linux SLES, RHEL, Debian, RVU

Ubuntu, Centos

Supported Microsoft Windows 2008, Windows RVU

Windows Server 2012

Supported Microsoft Windows 7, Windows 8, ClientDevice

Windows non-Server Windows 10

Supported Mac OS X Leopard, Lion, Yosemite ClientDevice, unless the
operating system name
allows to clearly distinguish
if it is a MAC server. In this
case, the default metric is
RVU.

For example, if the client is a Red Hat Enterprise Linux (RHEL), the default metric
for all its products is RVU.

The administrator can override the default metric for one or more products.
The possible values for all of the metric are: RVU, MVS, ClientDevice.
To set the metric to RVU, MVS, or ClientDevice, the administrator runs the Fixlet

Categorize RVU Clients, Categorize MVS Clients, or Categorize ClientDevice
Clients.
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To categorize the clients, you must complete these steps from the BigFix console:
1. Go to Sites > External Sites > BES Support.

2. Select Fixlets and Tasks.

3. Depending on your needs, select in the Fixlets and Tasks pane:

* Categorize ClientDevice clients to override the default license type of
selected products to ClientDevice.

* Categorize MVS clients to override the default license type of selected
products to MVS.

+ Categorize RVU clients to override the default license type of selected
products to RVU.

Example, to override to MVS the license type used by the products:
* Protection

* Compliance_Payment_Card_Industry_Add-on

* Patch

see the following panel.
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Fixlet: Categorize MVS clients

Description | Details | Applicable Computers (3)

£ Take Action | ~ Edit | Copy [#»Export | Hide Locally Hide Globally | % Remove

Action History (1)

Description

Select the products

[+/] Protection

[l Lifecycle

[+] Compliance Payment Card Industry Add-on
[¥] Patch

[l compliance

[l 1inventory

[ | Protection DLP Add-on

This task is used to override default license type to MVS of selected products

Actions

® Click here to classify license type to MVS

Figure 2. Categorize MVS clients

Displaying the current license metrics
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An analysis is a collection of property expressions that a console operator uses to

view and summarize properties of client

In this case, the License Overrides analysis displays the following information for

each client computer:
¢ Its license default metric.

* The lists of products for every overridden metric, distinguished by metric.

computers.

* The License Override Status Boolean flag.
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Analysis: License Overrides

Qi Activate QaDeactivate ‘ # Edit |# Export | Hide Locally Hide Globally | % Remaove

| Description | Details ‘ Results |Applicab|e Computers (3)|

View as list

> E@ Applicabl ComEute...
8 nc0500...
B NCos0..
fHNCos0..

DefaultMetric ClientDevice Overrides RVU Overrides MVS Overrides License Override Status
RVU Patch,Compliance Protection,Lifecycle Inventory True
ClientDevice Compliance,Patch Inventory Lifecycle Protection True
RvU Compliance Patch Inventory,Lifecycle,Protection True

Figure 3. License Overrides analysis

Distributing the site mapping file

The Distribute site mapping file Fixlet is responsible for updating the licensed

products and their related sites on the clients.

The site mapping file must be available on the clients before generating the license
tags.

To distribute this file, you must complete the following steps:

1.
2.
3.

Go to Sites > External Sites > BES Support.
Select Fixlets and Tasks.

Select Distribute site mapping file in the Fixlets and Tasks pane. This action
immediately distributes a mapping file, which maps sites and products, to the

subscribed computers. Repeat this action when you install new products.

Fixlet: Distribute site mapping file

& Take Action | # Edit | Copy = Export | Hide Locally Hide Globally | 2 Remove

Description | Details | Applicable Computers (1) | Action History (0)

Description

This task distributes to clients the map of sites and products.

Distribute

Figure 4. Distribute site mapping file fixlet
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Generating the license tags

* Run the Distribute site mapping file Fixlet before generating the license tags.

The Generate BigFix license tags Fixlet is responsible for updating the license tag
of the product for each site to which the clients are subscribed.

If the client has no site subscription, then it will store tags for all licensed products.

Each tag reflects the product name, the metric (default or overridden by the user)
and the agent version. It is located in the appropriate directory. The previously
installed client tags, related to the platform agent, are kept hidden when the Fixlet
completes successfully and are no longer displayed by the IBM BigFix Inventory
console.

To generate the license tags, you must complete the following steps:
1. Go to Sites > External Sites > BES Support.
2. Select Fixlets and Tasks.

3. Select Generate BigFix license tags in the Fixlets and Tasks pane. This action
creates the license tags on the subscribed computers.

Note: The Fixlet Generate BigFix license tags must be run manually the first time;
then it is scheduled to run daily.

Fixlet: Generate BigFix license tags

47 Take Action | # Edit | Copy = Export | Hide Locally Hide Globally | 2 Remove

Description

Details | Applicable Computers (12) | Action History (4)

Description

It creates or updates license tag files daily

Actions

® Click here to deploy this action.

Figure 5. Generate BigFix license tags Fixlet

Troubleshooting

108

If IBM BigFix Inventory misinterprets the license tags that were specified on the
BigFix client computer, the endpoint is not correctly classified and the manual
classification is required in IBM BigFix Inventory.

The following figure shows what you see in the IBM BigFix Inventory console.
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The presence of the third row indicates that an incorrect license classification

occurred.

In this case, contact the IBM Software Support team.

=~ |BM BigFix Inventary 9.2 (3)

e NC912811120 Mo other bundling
IBM BigFix Inventory RVU 9.2 1 options available.
Sy NCa12811121 Mo other bundling
IBM BigFix Inventory Server9.2 (¥ 1 options available.
Based on: the
IBM Endpoint Manager Platform MC912811121 i software co-location,

Agent 9.1

1

the relation in the
software catalog.

]
TLM_VM_42369
1b3-e971-84f5-
a059-52725a43
0849

Win2008R2
6.1.7601

Linux Red Hat
Enterprise
Server 6.4
(2.6.32-358 el
6.x86_64)

Linux Red Hat
Enterprize
Server 6.4
(2.6.32-358.¢l
6.xB6_64)

Figure 6. Incorrect license classification

Limitations

If running a BigFix server version 9.2 or earlier versions, the product names
displayed by the License Overview dashboard are different from the names

displayed by the LCP tool.

This mismatch does not occur on a BigFix server version 9.5.

The names used by the LCP tool are those used by the IBM BigFix Inventory and

comply with the rebranding initiative.

Refer to the right column of the following table for the names displayed by the

LCP tool.

Table 3. Names displayed if running a BigFix server version 9.2 or earlier

Name in the License Overview dashboard

Name in the LCP tool

Patch_Management Patch
Lifecycle_Management Lifecycle
Power_Management Lifecycle
Server_Automation Lifecycle
Tivoli_Remote_Control Lifecycle
Software_Use_Analysis Inventory
Security_and_Compliance Compliance

PCI_DSS_Security_and_Compliance

Compliance_Payment_Card_Industry_Add-
on

Core_Protection_Module_(Trend)

Protection

Trend_Micro_Data_Protection

Protection_DLP_Add-on

Starter_Kit_for_Lifecycle_Management

Starter_Kit_for_Lifecycle

The products not mentioned in the table will be ignored.
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Chapter 15. Client-Relay-Server Authentication

Client Authentication

Client Authentication (introduced in version 9) extends the security model used by
BigFix to encompass trusted client reports and private messages. This feature is not
backward-compatible, and clients prior to version 9.0 will not be able to
communicate with an authenticating relay or server.

Note: Some of the security options of the Client Authentication feature, can also be
defined by setting the minimumSupportedClient service as described in

Additional administration commands| for Windows system, or [Running the BigFix|

Administration Tool| for Linux systems.

The original security model has two central capabilities:

* Clients trust content from server. All commands and questions that clients
receive are signed by a key that is verified against a public key installed on the
client.

* Clients can submit private reports to server. The client can choose to encrypt
reports that it sends up to the server, so that no attacker can interpret what is
contained in the report. This feature is disabled by default, and is switched on
with a setting.

Client Authentication extends the security model to provide the mirror image of
these two capabilities:

* Server can trust reports from clients (non-repudiation). Clients sign every
report that they submit to the server, which is able to verify that the report does
not come from an attacker.

* Server can send private data to clients (mailboxing). The server can encrypt
data that it sends to an individual client, so that no attacker can interpret the
data.

Communication using an authenticated relay is a two-way trusted and private
communication channel that uses SSL to encrypt all communications. However,
communication between a non-authenticating relay and its children is not
encrypted unless it is an encrypted report or a mailboxed action or file.

This level of security is useful for many purposes. Your company may have
security policies that require authenticating relays on your internet-facing nodes, in
your DMZ, or any network connection that you do not totally trust. With
authentication, you can prevent clients that haven’t yet joined your deployment
from getting any information about the deployment.

Authenticating

relays

Relays can be configured as authenticating relays to authenticate agents. This way,
only trusted agents can gather site content or post reports. Use authenticating relay
configuration for an internet-facing relay in the DMZ.
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A relay configured to authenticate agents only performs SSL communication with
child agents or relays that present an SSL certificate issued and are signed by the
server during a key exchange.

To configure an authenticating relay, set the client setting
_BESRelay_Comm_Authenticating to 1 or use the related task in the BES Support
site. To configure an open relay again, set _BESReTay_Comm_Authenticating to 0 or
use the related task in the BES Support site. The default value is (0), open relay.

Handling the key exchange

When an agent tries to register and does not have a key and certificate, it
automatically tries to perform a key exchange with its selected relay. If the relay is
a non-authenticating relay, it forwards the request up the relay chain to the server,
which signs a certificate for the agent. This certificate can later be used by the
agent when connecting to an authenticating relay.

Authenticating relays deny these automatic key exchange operations. The
following is a typical scenario:

When you deploy a new BigFix 9.2 environment or upgrade an existing BigFix
environment to 9.2 all agents automatically perform the key exchange with their
relays. If the administrator configures the internet facing relay as an authenticating
relay, the existing agents already have the certificate and work correctly. No further
action is required. When you connect new agents to the authenticating relay they
do not work, until the jmanual key exchange procedure is run on them.

Manual key exchange

If an agent does not have a certificate and can only reach an authenticating relay
on the network, connected through the internet, you can manually run the
following command on the agent so it can perform the key exchange with an
authenticating relay:

BESClient -register <password> [http://<relay>:52311]

The client includes the password in its key exchange with the authenticating relay,
which verifies it before forwarding the key exchange to its parent.

You can configure the password as:

* A single password in the client setting BESRelay_Comm_KeyExchangePassword on
the relay.

* A newline-delimited list of one-time passwords stored in a file named

KeyExchangePasswords in the relay storage directory (value StoragePath of
HKLM\Software\WOW6432Node\BigFix\Enterprise Server\BESReports).

Revoking Client Certificates
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After a client authenticates, you can revoke its certificate if you have any reason to
doubt its validity. When you do, that client is no longer authenticated for trusted
communication. It is removed from the console and a revocation list is updated
and collected by all relays, so that the client’s key can no longer be used to
communicate with authenticating relays.

To revoke a computer:

IBM BigFix: Console Operator’s Guide



1. Right-click a computer in any list of computers.

B 1BM BigFix Console

File Edit ‘Wiew Go Tools Help|

i Back - »Fnrward - | 5 Show Hidden Caontent ‘ﬁﬁhuw Mon-Relevant Content | Q'-:}'Rel‘resh L

Ll Compukers

+-f3y Fixlets and Tasks (1,134)

—E Baselines (0)

[J—E Analyses (12) Open
= : Copy Texk
g Actions {0} _
Copy Text with Headers

HHE Dashboards fen
HHE Wizards .
E_‘.—ﬁ Cuskomn Conkent J— Edit Computer Setkings. ..

7} Custom Filters - [Modify Euston Site Subscrptions. ..
[H?E Computers (1) e &dd Comment, ..
i Computer Groups {0) Mbase- o

Z}, Unmanaged Assets (0) 3w =voke Certificat :

—iZ} Operators (1) Yiew as Group
i Sites (2) &dd To Manual Group,..

_FF LDAP Directaries oy

Er

—@ Roles {0} :

Send Refresh

2. From the pop-up menu, click Revoke Certificate.

3. From the confirmation dialog click OK if you are sure you want to remove the
computer certificate.

This sends revocations down to the relays. After revoked, that client can no longer
use its private key to gather content from the authenticating relays. The revoked
client disappears from the computer list in the console.

Re-registering a revoked client

The client revoke procedure removes a client from the console and updates a client
certificate revocation list.

Clients can automatically get a new certificate if they can connect to any non
authenticating relay.

If such a relay is unavailable you must complete the following manual cleanup to
register the client again:

1. Stop the client.

2. Delete the KeyStorage client directory and the client computer ID.
3. Complete the manual key exchange procedure.

4. Start the client.

At the end of this procedure the client gets a fresh certificate and a new client
computer ID.
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Mailboxing

With Client Mailboxing you can send an encrypted action to any given client,

instead of broadcasting it to all clients. This improves efficiency, since the client

doesn’t need to qualify every action, and it minimizes network traffic. As a

consequence,

* Clients are only interrupted when they are targeted.

* Clients don't have to process actions that are not relevant to them for reporting,
evaluating, gathering, and action processing.

Privacy is assured because the message is encrypted specifically for each recipient;
only the targeted client can decrypt it.

A client's mailbox is implemented as a specialized action site, and each client is
automatically subscribed to it. The client knows to scan for actions in this site as
well as the master site and operator sites.

To send an encrypted action directly to a client mailbox, follow these steps:

1. Open the Take Action dialog (available from the Tools menu and various other
dialogs).

¥ Take Action

[IEES I S Cliank Setting: Enable Auko Relsy Selection Create in domain: |.0.I Content ﬂ

Presek: IoefaLi[ 3 [~ show anly persanal pressts SEVE Fress | I

Target | Execution | Users | Messages | Offer | Post-action | Applicabiity | Success Criteria | Action Script |
Target:
1 Select devices

" Drynamically target by property
" Enter device names

o) -i] Applicable Computers (2) Computer Hame I 05 CPU
BB G-WTSPLNG4-1 Wing 6.1.7601 2400
B G-WTEPLRBE-1 Win7 6.1.7801 1900
KT I—| i

Ers

2. Click the Target tab.

3. Click Select devices or Enter device names. Mail-boxing is only available when
you specify a static list of clients. Dynamically targeted computers will not be
encrypted and will instead be sent in the open to the master site or a specific
operator site. If you select target clients with versions prior to 9.0, the action
will also go into the master or operator site.

4. Click OK. Actions targeted by computer ID or name will now be encrypted
and sent to the client mailbox.

The identifier of the operator who deploys the action is included with the action.
Before a client takes the action, it first determines if it is currently administered by
that operator. If not, it refuses to run the action.
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Chapter 16. Displays and Reports

Web Reports

The Web Reports program can monitor, print, or archive the status of the local
database. It allows you to get an overview of your relevant Fixlet messages and
any subsequent remediation efforts. You can create charts summarizing the number
of administered computers in your network and your overall vulnerability status.
In addition, you find comprehensive statistics and a list of the most common issues
detected. You can drill down into these commonly relevant Fixlet messages at any
time to see them in greater detail.

Web Reports also has the ability to read the databases of other BigFix Servers and
aggregate the data. This offers you a top-level view of a large or far-flung
enterprise with multiple database servers. Aggregation servers allow you to view
information from multiple networks with hundreds of thousands of computers.

You can view the data in the database from several different points of view and
save or print the output. You might also export the output to Excel for further
manipulation. These features are provided by the BigFix Web Reports program,
which can be run at any time from the desktop by selecting Tools > Launch Web
Reports. You must supply your credentials to log in. When you do, you are shown
the introductory panel:

Web Reports _EI |

J 1 . Preferences & Logout
| Explore Data | ReportList | Administration |

ChDDSE d categary to 1'u"'fl‘.‘."‘n-"*»«" reports: g
Starred

My favorite reports

* My Authored
Reports that ['ve created

There are three main links at the top of the panel.

* Explore Data: Click this link to look at a group of predefined reports and charts
that you can easily filter and customize. This section provides you with an
instant overview of the most basic data managed by BigFix, including
Computers, Actions, Operators, and more.

* Report List: Click this link to get a look at basic reports organized around your
Fixlet content. Create and customize reports with a simple, intuitive interface.
Some commonly-requested reports are built-in, such as Operating System
Distribution and Vulnerability Trends. Select them for display by clicking their
titles in the list. You can create your own custom reports and save them as either
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public or private (viewable only by you). Your public reports are added to the
reports list; your private reports are only available when you log in with a
correct password.

* Administration: Click this link to gain access to various administrative
functions, including scheduling activities, managing filters, operators, database
settings, and users.

In addition, there are two report categories to get you started.
* Starred: This link takes you directly to favorite reports that you have flagged as
starred.

* My Authored: This link takes you to a list of those reports you personally
created.

Depending on your configuration, there might be more categories available from
this startup panel.

Here is a snippet of a typical report, summarizing the computers in your network
by their properties. To produce this report, simply click Report List then select
Computer Properties List.

ugh :: Preferences :: Logout

Web Reports

(ST ETEE Report List | Administration

Computers | Content | Actions | Operators | Unmanaged Assets | Custom |
Computer PI’OpBI’tiBS List Export to CSV - Printable Version 2 | Save Report | | Save Report As
[=] Filter Save Filter - Load Filter - Cleg
Results match all conditions
Computer = +
[ pply Filter | |
|@ Chants Add Chay
[=] Computers
Edit Columns = Sort ~ |
| Computer Name f\ BIOS CPU Free Space on System Drive 05
BEA 03/30/07 2400 MHz Core 2 146548 MB WinVista 6.0.6001
BIGDOG 02/24/09 3000 MHz Core 2 Duo 138311 MB Win7 6.1.7600
BLAKE 11/05/07 2200 MHz Core 2 Duo 43309 MB WinVista 6.0.6002
FINANCE 10/11/04 3400 MHz Pentium 4 81571 MB WinXP Media Center E
| TESTING 12/09/06 1000 MHz AMD Athlon{tm) 64 X2 Dual Core Processor 5000+ = 11315 M8 Win? 6.1.7600

Showing items 1-5of 5

Web Reports can be viewed at any time from the Console under Tools > Launch
Web Reports.

Any Web Report server can be set up to aggregate data from the other BigFix
Servers. Talk to your Site Administrator about setting up an aggregation server.
Refer them to the Administrator's Guide for further information.

The Web Reports interface is very rich and its complete documentation is beyond
the scope of this guide. For more in-depth information, see the Web Reports Guide.
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Viewing Dashboards

Dashboards are list of reports that update in real time and provide you with
high-level views of your BigFix network.

Click the All Content domain to see all dashboards that are available in your
environment in the Domain Panel navigation tree under Dashboards. If you select
a specific content site, you see only the dashboards available with that content site.
These reports access the database to provide you with timely and compact views
of your network.

To run a dashboard, select it from the Dashboards icon in the Domain Panel
navigation tree. The dashboard is shown in the Work Area on the right.

When you install the BigFix Console, you get the following set of dashboards:

+ |“Baseline Synchronization Dashboard”)

* |“Deployment Health Checks Dashboard and Deployment Overview Dashboard”|

on page 119|

+ [“License Overview Dashboard” on page 121|

+ [“Maintenance Windows Dashboard” on page 122

Baseline Synchronization Dashboard

Use the Baseline Synchronization dashboard to make sure that your baselines,
source Fixlets, and actions are in sync. Ensuring that your baseline components are
in sync with the source Fixlets prevents issues when you deploy actions across an
entire network.

This sample scenario shows how strategic the use of this dashboard can be.
Assume, for example, that you created and tested a new set of baselines when a
vendor reports that there was an error with some of their patches. For this reason
new Fixlets, replacing those containing the patches in error, are released by BigFix.
It can be time consuming to check which of your baselines were affected. By using
the Baseline Synchronization Dashboard, you can, with just a few clicks, view
which of your baselines are out-of-sync and automatically update their content if
necessary.

Note: This dashboard also displays all the actions that are from an out-of-sync
baseline, giving you the option to close them and issue them again.

Run the following steps to access the Baseline Synchronization Dashboard:
1. Click the All Content domain in the Domain Panel.

2. Select the Dashboards icon in the Domain Panel navigation tree.

3. Select BES Support.

4. Click Baseline Synchronization Dashboard. The dashboard opens.

Chapter 16. Displays and Reports 117



=

Baseline Synchronization Dashboard

Last Update: 19:32:01 Tue, 09 Jul 2013

All Baselines

Sync Baselines Filter Baselines _JJ

Ll o Baseline Hame Site Hame Open Actions Components Sync Status

L 338 Windows Patches - 2012 August - English - Office/Apps  Local Windowes Patches 0 1 in-sync

Ll 338 Remove Old Shockwave 11.2x and Install New version  ActionSite 1 ] out-of-symc
Ll 340 Windows Patches - 2009 March, May - English - 0S5 Local Windovws Patches 0 3 in C

L 3 Custom Baseline - MS13-051 ActionSite o 1 in. C

L] 342 Test Baseline LocalWindows Patches 0 12 in c

Ll 343 Windows Patches - 2012 May - English - 0S Local Windovwes Patches 0 4 in C

The dashboard shows the following information for each baseline:

« ID

* Baseline name

* Site name

* Number of open actions

* Number of baseline components

* Synchronization status

The exclamation mark icon in the components column highlights that the baseline,
even though in sync, might have a misconfiguration within its members. Such
misconfiguration might cause problems if not corrected. Hovering over the icon

you see the detail of the misconfiguration. For example, these might be causes of
misconfiguration:

* Some component relevance is out-of-sync.

* Some components do not have source Fixlets.

* Some component actions do not have any source actions.
* No components exist in the baseline.

* This baseline contains components that have no action selected.

From this dashboard you can:

Search for a specific baseline
You can search for a specific baseline by specifying its ID, name, or site
name in the Search field.

Filter baselines to limit the out-of-sync baselines in the dashboard
You can filter the baselines that you want to display in the dashboard by
clicking Filter Baselines. You can select any of the following conditions:

* Relevance is out-of-sync.
* Action out-of-sync.
* Source Fixlet ID or name.

The baselines can match either any or all of the conditions that you
selected. After selecting the conditions, click Apply.

Reset the out-of-synch baseline filter
You can view all the baselines, without any filtering, by clicking Reset
Filter.
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View the synchronization status of the baseline components
To know which Fixlets have parts that are out-of-sync with respect to the
source Fixlet, click Sync Status beside each out-of-sync baseline.

The Baseline Components List dialog displays the sync status of each
component in detail.

11.xx and Instal

gﬂ’Take Action | »# Edit | Copy = Export | Hide: Locally  Hide Globally ‘ 9 Remove

Description I Details Components |App\icah\e Computers () | Companent Applicability I Action History (1) I

! Warning: This baseline containg components that have no action selected. Action groups taken from this baseline are
L8 likely to fail.

Component Group 1

» Restart Needed lm
go to source

» BES Server Does Not Meet Recommended Requirements Mo Action Celocted B
go to source

+  Updated Windows Client - Tivoli Endpoint Manager version 8.2.1310.0 Now
Available! Action1 (Default) hd
go to source

» Custom Fixletl
source fixlet differs [go to source

» Install Filesets for NIM Master No &ction Solocted B
go to source

Synchronize baselines
A baseline is out-of-sync when the baseline component's relevance or
action is different from that of the source Fixlet. To synchronize a baseline
means to update the baseline components to match the source Fixlets’
relevance.

In the Baseline Synchronization Dashboard, select the out-of-sync baselines
and click Sync Baselines.

Deployment Health Checks Dashboard and Deployment
Overview Dashboard

Use the Deployment Health Checks Dashboard and the Deployment Overview
Dashboard to manage and monitor the health of your BigFix environment.

The dashboards track important health indicators for Relay Health, Console
Health, Server Health, Client Health, and Deployment Optimization. For each of
these checks you see:

* A description

* Specific deployment details
 Severity of High, Medium, or Low
* Status of Passed, Warning, or Failed
* Remediation steps

BigFix Console administrators should regularly review this dashboard and
remediate any failure as described in the check.

Run the following steps to access the Deployment Health Checks Dashboard:
1. Click the All Content domain in the Domain Panel.

2. Select the Dashboards icon in the Domain Panel navigation tree.

3. Select BES Support.

4. Click Deployment Health Checks Dashboard. The dashboard opens.

Chapter 16. Displays and Reports 119



120

BigFix Deployment Health Checks & &

Last Update: Wed, Jul 24 2013 at 10:57:17 PM

Please activate the BES Health Checks Analysis in the BES Support site to enable additional health

[x]
=
2
=
i

B Deployment Information

Use the buttons below to copy the deployment information to your clipboard. Press the 'Collect
Deployment Information' button first to gather and view your deployment information and enable
the 'Copy to Clipboard' button. Next, press the 'Copy to Clipboard' button fo copy the information to
your clipboard.

Collect Deployment Information Copy to Clipboard

BES Relay Health

BES Console Health

BES Server Health

BES Client Health

Deployment Optimization

Wake-on-LAN

[

Run the following steps to access the Deployment Overview Dashboard:

1.

2.
3.
4

Click the All Content domain in the Domain Panel.

Select the Dashboards icon in the Domain Panel navigation tree.
Select BES Support.

Click Deployment Overview Dashboard. The dashboard opens.
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BigFix Deployment Overview Q&

Last Updste: Wed, Jul 24 2013 at 10:55:47 PM

‘ Bl Deployment Information Bl BES Relay Statistics

BES BES Relays Reported in
Agents 2 the Last Day:
Deployed:

0 (0%)

Average Number of BES
BES Clients per Relay:

Rel 0
[:-zpaﬂ;:ed; Average Distance to BES

Relay:

0

BES

Consoles Analysis Activation Required
Installed:

BES BES Relay Selection
Agents Method
Reported 2 (100%) 3
in the
Last Day:

Wake-on-
LAN Enabled (Disable)
Status:

B Automatic (0)
W Manual (2}

Use the License Overview dashboard for
license information.

Operator Information Distance To BES Relays

BES Usage Statistics

BES Content

Number of Computers

o000 00 00D

O - o o< waga4 g |V|
2 & o

License Overview Dashboard

Use the License Overview dashboard to subscribe to content sites.

When you add subscriptions to content sites, content automatically flows from
these sites into your environment and is evaluated for relevance on all computers
running the BigFix Client.

The list of available content sites that you see in this dashboard is strictly related to
the license of BigFix that you purchased. When you buy BigFix, you receive a
license number that defines which products in the BigFix suite you purchased. This
information is used by the product to populate, at installation time, the License
Overview Dashboard with the subscriptions to only the products in the suite that
you purchased.

With the exception of the content related to the BigFix platform, for which you are
automatically subscribed at installation time, you must manually add subscriptions
from the License Overview Dashboard to the other content sites covered by your

license. This means that even though your license includes, for example, the BigFix
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for Patch product, you still need to access the License Overview Dashboard and
add subscriptions to the Patch content sites available to start using the BigFix for
Patch functions.

Run the following steps to access the License Overview Dashboard:
1. Click the BigFix Management domain in the Domain Panel.
2. Click License Overview Dashboard. The dashboard opens.

File Edit View Go Tools Help

& Back ~ = Forward ~ | % Show Hidden Content ' Show Non-Relevant Content | £ # Refresh Console
BigFix Management « License Overview [y
| Deployment Ovenview sllal -
Deployment Health Checks |
[ Ticense Overview BigFix License Overview

Warnings (2)

BES Deployment Upgrade (1) =

BES Component Management (33 For questions about the products \Jsteq on your license or their expiration dates please email TEM@dkibm.com. You can also manage
your license at the TEM License Key Center.

Maintenance Window Manageme

Manage Wake-on-LAN (2)

‘ » BES Platform |

> [@e Actions @)
> (5 Custom Content

) Custom Filters
> (2] Computer Management
iZ), Unmanaged Assets (1)
) Operators (1)
=l Manage Sites (8)

‘ b Lifecycle Management |

» Patch Management

This license contains the following entitl: for Patch M

Licensed for: 5 (Client Device)

Expiration Date: 30M2/2021

() Ancontent

@ BigFix Management

Enabled Sites Subscribed Computers

BES Asset Discovery

[ENERTS

Patches for RHEL 5

3. Scroll down the dashboard to review the content sites that you already
subscribed to and those that are available but for which you have not yet
added subscriptions.

For more information about how to use the License Overview Dashboard and
the information it contains, see Post-installation steps in the Installation Guide.

Maintenance Windows Dashboard

Use the Maintenance Window dashboard to define time periods during which
BigFix can run actions; mainly maintenance activities.

Client locking allows computers or groups of computers to be excluded from
running actions. Client locking can be useful, for example, if specific development
computers must be excluded from changes or updates. It also provides a technique
for testing new actions on a limited set of unlocked computers, while keeping the
network locked down.

With the Maintenance Window dashboard, you can set and enforce maintenance

windows for BigFix Clients. You can use the Maintenance Window dashboard and
tasks to change or remove the maintenance window. You can use the Maintenance
Window Analysis also to see the current maintenance window for your computers.

Run the following steps to enforce a maintenance window on a computer or on a
group of computers:

1. Click the All Content domain in the Domain Panel.

2. Select the Dashboards icon in the Domain Panel navigation tree.
3. Select BES Support.

4. Click Maintenance Windows Dashboard. The dashboard opens.
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5.

=

Maintenance Window Dashboard

This wizard creates and manages Maintenance Window Tasks. Run as a policy action, these tasks will unlock
selected computers during the specified maintenance windows. The computers will be locked during all other times.

Use the "Maintenance Window Analysis" to view additional maintenance window information.
By default, the Maintenance Window is informational and is not enforced within Bigfix. Use the "Enforce Maintenance

Window with Client Locking” task to tie a computer's maintenance window to its locked state. Please read KB Article
#1736 to fully understand all implications of client locking.

Maintenance Tasks

;. n]n Create New Maintenance _window. | po

Tasks Window Computer(s) with

Click Create New Maintenance Window to set a new Maintenance Window.
After you create a maintenance window, you can see it under Maintenance
Tasks.

r Bl

Create New Maintenance Window

Mame: [i=v)

Window Size: &0 |i| Minute(s)

Start Time: 10 : 39 : 68 PM Client Local Time

Schedule Task: [ Once YJ

Run on: | 0712412013 [

E Create Task

Use the "Enforce Maintenance Window with Client Locking" task to set a
maintenance window on a computer. The computer is unlocked when it is in
the maintenance window and locked for the remainder of the time. Each
computer can have only one active maintenance window at any time. The
"Enforce Maintenance Window with Client Locking" task overrides a previous
locking or unlocking action for the selected computers. Similarly, any locking or
unlocking action that is taken on the selected computers later overrides the
effects of a previous "Enforce Maintenance Window with Client Locking" task
run.

Chapter 16. Displays and Reports 123



Note: Alternatively you can lock or unlock a computer, by running the
following steps:

a. Right-clicking on the computer.
b. Selecting Edit Computer Settings
c. Clicking the check mark to lock or unlock the computer.
7. Click the maintenance tasks to apply the maintenance window to computers.

8. After a maintenance window is set on a computer, it returns true or false in the
"Maintenance Window" property.

Visualizing Data

124

The Visualization Tool allows you to view and manipulate data across your entire
managed network. It lets you visualize various hierarchical relationships in your
network, using an interactive 3D sphere to map the data.

The Visualization Tool makes it possible to view a real-time graphical network
map showing Fixlet relevance, Action status, and Retrieved Properties.

) Tiveli Endpoint Manager Network Visuslization Teal = e ]

=

File Edit View Mavigation

Contrals

Tivoli Endpoint Manager
Deployment

Descendants:

5 Win7 6.1.7600

1 [ ide) Winvista 6.0.6002

1 . . WinXP Media Center

Edition.2600
WinVista 6.0.6001

As an example, you could view all computers that are currently unpatched for
MS04-011 across an enterprise network, displayed as an Active Directory hierarchy.
Then you could watch the clients change from red to green as they get patched in
real-time across your network. As another example, you could view all Clients that
are currently using Microsoft Office, colored according to version.

Or you can create your own hierarchy. You could assign settings on all your
machines named 'city’, 'building’, and 'floor". You could then create a dynamic
setting called 'location' that concatenates these properties:

IBM BigFix: Console Operator’s Guide



set setting location = (value of setting 'city' & ;' & value of setting 'building’ & ;' &
value of setting 'floor’)

Specify a semi-colon as the delimiter of this setting to visualize your computers as
a location-based hierarchy, from each networked city down to the floor of every
building.

To create your own custom view of the data, follow these steps:

1.
2.

Select Tools > Launch Visualization Tool...
There are three tabs in the Visualization Parameters dialog:

* General: Specify the desired display hierarchy from among Relays, Active
Directory, IP Address, or Retrieved Property.

* Colorization: Indicate how you want to color-code the client nodes. You can
base your color scheme on Fixlet Relevance, Baseline Relevance, Retrieved
Properties, Action Status, or a custom Relevance clause.

* Computers: Limit the computers you want to display, using Active Directory
and Retrieved Properties as filters. To show all the computers under IBM
Endpoint management, click Show all computers.

Click OK to generate your customized visualization of your network.

A graph of your network, mapped onto a 3D sphere, is displayed. You can now
use the Controls listed in the upper right corner to change your view of the
data.

Double-click a computer node to bring it to the forefront. Drag the elements in
the graph to tweak the viewpoint.

You can continuously rotate the model by selecting View > Spin Mode.

Use the Navigation menu to move through the hierarchy, from each selected
computer to its sibling, parent or child.
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Chapter 17. Menus

File Menu

The File Menu offers the following commands:

Import

Import .bes files, which can be default Tasks,
Actions, Baselines, or other content that you
might have created or customized.

Export

Export a Task, Action, Fixlet, Baseline, and
so on. that you or another Console user can
subsequently import. Exporting provides a
useful mechanism for creating customized
content. Simply export the content, edit it
with any text editor, and then import the
customized version.

Preferences...

Set refresh, BigFix Client heartbeat,
colorizing, caching, and other persistent
Console preferences.

Change Database Password...

Change the sign-in password for the
currently connected user.

Exit

Quit the program.

Edit Menu

The Edit Menu offers the following commands:

Table 4. Edit menu

Command Description

Cut Cut text and put in clipboard. This
command is for use in the various text
boxes that the Console uses for data input.

Copy Text Copy text and put it in the clipboard.

Copy Text with Headers

Copy text, including any associated headers,
and put it in the clipboard.

Paste Insert the contents of the clipboard. This
option is only activated when there is an
editable text box on the panel.

Select All Select all items in the current window.

Depending on the window, this can be text
from the Work Area or items in the List
Panel.
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Table 4. Edit menu (continued)

Command

Description

Hiding >

Remove the selected objects, Fixlets, Tasks,
Baselines, or Analyses, from the List Panel.
The object itself is not actually deleted, and
can be retrieved by clicking Show Hidden
Content in the Console Toolbar. These
options only become available when you
click objects in the List Panel. Alternatively,
you can right-click the objects and select
hiding options from the context menu.
There are four options

Globally Hide: This hides the object across
all Consoles.

Globally Unhide: Relist the selected objects
(either Fixlets, Tasks, Baselines, or
Analyses). To find the object, click the Show
Hidden Content button.

Locally Hide: Hide the object on the current
Console only; other Consoles still display
the object. The object itself is not actually
deleted, and can be retrieved by clicking the
Show Hidden Content button and selecting
it from the navigation tree.

Locally Unhide: After clicking the Show
Hidden Content button, you can choose to
unhide locally hidden content with this
command.

Create Custom Object Copy...

Create a customized clone of the currently
selected object (Fixlet, Task, Baseline,
Computer Group, or Analysis). For each
copy, you can create a header name and
compose a message to describe the
associated actions. You can also customize
or add relevance expressions to refine the
targeting of the Fixlet or Task.

Remove...

Remove a customized object (including a
Fixlet, Task, Baseline, Computer Group,
Analysis or Site File) from its list.
Confirming this choice permanently
removes the customized object from the list.

Edit Custom Obiject...

Edit the Message, Action, Relevance, and
Properties of a customized object (Fixlet,
Task, Baseline, Computer Group, or
Analysis).
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Table 4. Edit menu (continued)

Command

Description

Groups >

Manage groups of computers. This item
expands to include:

View as Group: Create an ad-hoc group
from a selected set of computers. You can
then view the Fixlets, Tasks, Baselines,
Actions, and Analyses that pertain to this
particular group.

Add to Manual Group...: Add the selected
computers to a named group. You can either
attach the computer to an existing group or
create a new named group. You must
supply a password to propagate the new
group name to the selected clients.

Remove From Manual Group: Remove a
computer from the specified group. First,
select the group from the navigation tree on
the left, then select a computer from the list.
You must supply a password to propagate
the change.

Stop Action

Stop the selected actions.

Assign User Management Rights...

Opens a display that lets you grant and
revoke management rights on a
computer-by-computer basis.

Find...

Opens a dialog that prompts you for a
search field and search string. You can
search for fields that either contain or do
not contain the search string. In addition,
for objects that can be hidden, such as
Fixlets, Tasks, Baselines, or Analyses, you
can search based on visibility.

View Menu

The View Menu offers the following commands:

Show Hidden Content

Allow hidden content, including Fixlet
messages, Tasks, Analyses, and so on. to be
viewed. Content can be hidden locally (on
this Console only) or globally (on all
Consoles). To view this content, select this
item or click the button in the Console
Toolbar with the same name. From the
navigation tree, all content becomes visible
and you can select hidden items to unhide
them if you choose.
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Show Non-Relevant Content

Allow non-relevant content, such as Fixlet
messages and Tasks, to be viewed. Typically
the BigFix operates by displaying only those
items that are relevant to your network.
Thus, out of the thousands of available
Fixlets, for example, only a few are brought
to your attention for remediation. When an
item has been remediated across your entire
network, it is no longer relevant and is no
longer shown. This menu item allows you to
examine these items, which can be useful if
you want to clone or repurpose one for your
own uses.

Show Status Bar

Display the number of relevant messages
and the connected database in the status bar
at the bottom of the Console window. Select
this menu item to toggle its state.

Refresh

Fetch the latest information from the BigFix
database. Typically, your information is
updated automatically based on a schedule
determined by your administrator (and by
your choice in the Preferences dialog).
Because refreshing causes a database access,
use it with restraint.

Go Menu
The Go Menu allows you to quickly select Domains and to change the focus area
of the Console. It offers the following commands:
All Content Open the top-level Domain that contains a
combination of all Domains.
Other Domain Names Open the specified Domain. The next few
entries in this menu include the various
Domains you created, depending on the
specific Fixlet sites you are subscribed to.
Current List Move the focus of the Console to the List
Panel at the top right of the Console.
Current Document Move the focus of the Console to the current
document in the Work Area at the bottom
right of the Console.
Tools Menu

The Tools Menu offers the following commands:

Take Custom Action...

Run a custom command, targeted to any
subset of BigFix Client computers.

Create New Fixlet...

Create a custom Fixlet message, complete
with targeting and actions.
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Create New Task...

Create a custom Task, similar to a Fixlet
message, but used by the Console operator
to install software, update settings, or
establish other local policies.

Create New Baseline...

Create a custom Baseline, allowing you to
establish a grouping of Tasks, Fixlet
messages, and other Baselines that can be
applied with a single click to any grouping
of computers.

Create New Analysis...

Create a custom analysis, based on the
specified properties of the BigFix Client
computers.

Create New Automatic Computer Group...

Create an automatically defined grouping of
computers, based on various client
properties, such as name, CPU, IP Address,
and so on.

Create New Manual Computer Group...

Manually create a computer group which
you can populate from any computer list.

Add External Site Masthead...

Start a new Subscription to a Fixlet site. This
command opens a browser window for you
to select a masthead file, typically with an
extension of .efxm.

Add Files to Site...

Add text, utility, domain, or dashboard files
to the sites you author.

Add LDAP Directory...

Add an existing Lightweight Directory
Access Protocol (LDAP) or Active Directory
(AD) domain to the Console.

Create Custom Site...

Create a custom site containing your own
content. You can create custom Fixlets,
Tasks, Analyses, and so on.

Create Operator...

Create a local operator with password
protection.

Add LDAP Operator...

Add a Console operator from the list of
users on your existing LDAP Server.

Create Role...

Create a Role with associated permissions
over computers and sites. Roles can also
include LDAP Groups, allowing you to add
multiple potential users at once.

Create Custom Filter...

Create a named filter that allows you to find
specific custom content, based on various
properties. The objects available to filter
include Fixlet messages, Tasks, Analyses,
Computers, and more.

Manage Properties...

Create and manage properties to retrieve
from your Clients, using Relevance clauses.
These properties are included in the column
headers on client listings. There is a default
set of properties, but you can add or delete
them. Properties are used to filter or select
subsets of Clients for Fixlet action
deployment.
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View Recent Comments

View the list of comments made by the
Console operators, sorted from most recent
to oldest. This list includes all comments,
regardless of the underlying object.

Launch Web Reports...

Provide access to data reports, which are
collected from various BigFix Servers and
aggregated into a set of HTML reports
summarizing the history and status of Fixlet
messages and actions across extended
networks of computers.

Launch Visualization Tool...

Run a tool to visualize the hierarchy of your
installation, from the servers down through
the relays to the client computers.

Help Menu

132

The Help Menu offers the following commands:

Contents

Provide integrated help.

Visit support.bigfix.com

Launch a browser to view the support site.

Customer Feedback Options

Allow us to learn from your experience.
Click the button to participate in an
anonymous survey to help us learn more
about how people use the program. This
information is used to improve your
experience.

About IBM Endpoint Manager Console...

Display the version number of the program,
along with a URL for support.
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Chapter 18. The Dialogs

About the BigFix Console

The About dialog displays the version of the BigFix Console. It also includes a
URL for technical support.

About IBM BigFix Console

BigFix

Console version 9.2.6.94

Licensed Materials - Property of IBEM Corp, & Copyright IEM
Corp, 2001, 2015, All Rights Reserved. IEM, the IBEM logo, and
BigFix are trademarks or registered trademarks of IEM
Corporation in the United States, other countries, or both. This
software includes code written by third parties, and in some
cases modified by IBM. Such code includes woecompat
[Copyright € 2001-2005 Essemer Pty Ltd). Use of wcecompat
is coverad by the GNU Lesser General Public License v 2.1,
Additionzl details regarding such third party code, including
maodifications made by IBM, availability of source code, and the
applicable copyright, legal and licensing notices, are available
in the NOTICES file(s) for this software.

For support, visit:
http:/www.ibm.com/software/tivoli/support

OK

This dialog is available by selecting:
* Help > About IBM BigFix Console
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Action: Computers

134

The Computers tab of the Action document shows the number of computers
affected by the specified action along with the current status of each.

= O
@ Stop  Copy |5 Bxport | X
| Summary | Computers (1) | Target| ] ) _
E TE_E Computers (1) Status Compu... 0s CPU Last Report ... | Locke
%Completed nc926028.ro...  Linux Red Ha... 1900 MHz Xe... 08/07/2013... No
B >

To view this information for a specific action:
1. Click the Action icon in the navigation tree.

2. Select that specific action in the List Panel. Information about the action is
displayed in the Work Area.

3. Select the Computers tab in the Work Area.

In the Computers tab there is a navigation tree on the left where you see the
number of computers affected by the specified action and you can filter list by
narrowing down for easier analysis. A filtered list shows the computers targeted by
the action, along with the current status of each. The list can be sorted by clicking
the appropriate header. You can view more detailed information about a targeted
computer by double-clicking the computer in the list.

The Targets tab shows the set of computers that was originally targeted by the
action, the Computers tab, instead, shows:

* The status of the action on each of the selected targets, regardless of whether
they responded or not, if the action was originally targeted to specific
computers.

* The status of the action on the target that actually responded, if the action was
originally targeted by properties.

Note: The Computers tab is renamed Reported Computers tab if the targeting
method selected in the Target tab of the Take Action dialog was set to
Dynamically targeted by properties.

The deployed action progresses through a series of well-defined stages on a given
computer. These are the statuses of the action on a computers across the various
stages:

Cancelled
The user has canceled the action.
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Constrained
The action has been constrained by a Relevance statement set in the
Execution tab of the Take Action dialog.

Download Failed
The action failed to complete the download.

Error The action has resulted in an error.

Evaluating
The action is still evaluating its relevance.

Expired
The action has passed its expiration date.

Failed The action has failed to run correctly.
Fixed The action has completed, resolving the issue.

Invalid Signature
The action cannot run due to an invalid signature.

Locked
The computer is locked and cannot run the action.

Not Relevant
The action is not relevant on this client.

Not Reported
The action has not reported its success or failure.

Offers Disabled
Offers cannot be presented on the specified client, so the action will never
run.

Pending Downloads
The action is waiting for downloads.

Pending Login
The action is waiting for the user to log in for a user-assisted action.

Pending Message
The action is waiting for the user to accept the action message.

Pending Offer Acceptance
The action is waiting for the user to accept the offer.

Pending Restart
The action is waiting for a client computer restart.

Postponed
The action has been postponed by the client.

Running
The action is currently running.

Waiting
The action is waiting for a user response.

Chapter 18. The Dialogs 135



Action History Tab

136

The Action History tab lists the deployment history of the actions associated with

the selected Fixlet, Task, or Baseline document.

Fixlet: Missing Office Web Components - BES Console - OWC 2003 e O

;’Takehctiﬂnv | # Edit Copy :::>Export| Hide Locally Hide Globallj.r| 2 Remove

| Description | Details | Applicable Computers (1) | Action History (1) |

@ Action History (1)| | Time Issued ~ State % Complete
5/6,/2010 9:50:20 AM Open 0.00% (0/1)
< 1 N

To see something in this dialog, you must have issued an Action. The Action
History list can be sorted by clicking the headers, which include the ID, Time
Issued, State, % Complete (based on the number of Clients reporting success),
Name, Site, Issued By, and Type.

This dialog is available by selecting a Fixlet, Task, or Baseline icon from the
Domain Panel navigation tree, clicking an item from the List Panel, and clicking
the Action History tab in the Work Area below the list.
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Action List and Document

This is the main panel about actions. It displays in the List Panel all the actions
that were deployed in the content site and shows in the Work Area the Action
document containing the details of the action highlighted in the list.

File Edit View Go Tools Help

4= Back ~ W ) Show Hidden Content}ﬁ Showe Non-Relevant Content| £%Refresh Console

« : £ o
Fixlets and Tasks (810) Time Issued State % Complete Hame Site
All (810) 24/07/2013 17.21.56 Open 100,00% (1/1)  Accept License for Software Use Analysis Master Operator Site

Fixlets Only (556) 24/07/2013 17.21.25 Open 100,00% (1/1) Accept License for Server Automation Master Operator Site
Tasks Only (254) 24/07/2013 17.21.05 Open 100,00% (1/1) Accept License for Security and Compliance  Master Operator Site
Baselines (0) 24/07/2013 17.20.31 Open 100,009 (1/1) Accept License for Power Management Master Operator Site
) Analyses (87) 24/07/2013 17.20.13 Open 100,00% (1/1) Accept License for Patch Management Master Operator Site
@-[f> Actions (6) 24/07/2013 16.17.08 Open 100,009 (1/1) Accept License for Lifecycle Management Master Operator Site
#-[5] Dashboards
+-F5 Wizards
@[] Custom Content
5] Custom Filters
Computers (2)
Computer Groups (0) |
Unmanaged Assets (0) || [ | [
& Operators (1) 5 = = 0
2 Sites (9) =
=1 LDAF Directories (4) | 8 stop | Copy \“»Export | X
& Roles (0) Summary | Reported Computers (1) || Target |
o]
 Status
100,00% Completed (1 of 1 applicable computers)
Status Count = Percentage
Completed 1 100.00%
= Behavior
o . Messages
ARGontent Mo user interface will be shown before running this action
@ BigFix Management Mo message will be shown while running this action.
a2 Users :_":

At the top of the Action document you find a description of the action. Below that
is a toolbar presenting you with options to Stop, Copy, Export, or Remove the
action. For more information about these commands, see [“Running commands on|
lactions” on page 32

There are three tabs in an Action document. They are:

* Summary: An HTML display of various action attributes, including Status,
Behavior (Message, Users, Execution, Post-Action), Relevance, Success Criteria,
and Action Script. At the bottom of the page is a text box for entering a
comment. For more information about this tab and its content, see
[Summary” on page 143

* Computers: It shows the number and the list of relevant computers affected by
the specified action along with the current status of the action on each of them.
A filter in the left panel allows you to narrow down the list of computers in the
right panel. For more information about this tab and its content, see
[Computers” on page 134

* Target: Shows what subset of computers was originally targeted by the action.
For more information about this tab and its content, see [“Action: Target” on|
_e 145.
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Action Parameter

This dialog box makes a request for extra information required by certain Actions
or group of Actions before execution. Typically there is a prompt with a text box
for you to supply a parameter.

L |

Action Parameter @

Please enter the service you would like to restart: -

<Enter Service Name>

| QK | | Cancel

Click OK to continue the Action deployment. This typically opens the Take Action
dialog, where you can further specify deployment options.

An Action Parameter dialog is opened only when you click an Action link in a
Fixlet that requires extra information before final targeting.

Action Progress Report

This dialog box shows the progress of an action as it is applied across the Fixlet
network.

-

Sending to Clients @

Status:  Exporting action site for operator '‘Bob’...

Cancel

First, it shows the progress of any downloads (patches, updates, and so on.). If
there are files to download, it displays the name of the downloaded file, the total
number of bytes, the current amount downloaded, the transfer rate, and the
estimated time to completion.
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The Actions can go through several states as they are collected, evaluated, and run
by the clients. These states include:

Running: The Action is currently running.

Evaluating: The Action is still evaluating its relevance.

Failed: The Action has failed to run correctly.

Cancelled: The user has canceled the Action.

Download Failed: The Action failed to complete the download.
Locked: The computer is locked and cannot run the action.

Offers Disabled: Offers cannot be presented on the specified client, so the
Action will never run.

Waiting: The Action is waiting for a user response.
Pending Downloads: The Action is waiting for downloads.
Pending Restart: The Action is waiting for a restart from the Client computer.

Pending Message: The Action is waiting for the user to accept the Action
message.

Pending Login: The Action is waiting for the user to log in for a user-assisted
Action.

Pending Offer Acceptance: The Action is waiting for the user to accept the offer.

Constrained: The Action has been constrained by a Relevance statement set in
the Execution tab of the Take Action Dialog.

Expired: The Action has passed its expiration date.

Postponed: The Action has been postponed by the Client.

Invalid Signature: The Action cannot run due to an invalid signature.
Not Relevant: The Action is not relevant on this Client.

Not Reported: The Action has not reported its success or failure.
Error: The Action has resulted in an error.

Fixed: The Action has completed, resolving the issue.

Action Script Tab

In general you are recommended to use the action script provided with the Fixlet
or task, however, sometime it might be useful to align the action script to your
environment and business needs. The Action Script tab of the Take Action dialog
allows you to modify the action script.
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¢ Take Action

Mame: | BES Relay/Server Setting: Enable /Disable Dynamic Throttiing Create in domain: EAII Content

Preset: Efault- \T] |:| Show only personal presets

| Target | Execution | Users | Messages | Offer | Post-Action | Applicabiity | Success Criteria | Acton Script |

{®) Use the action script from the original Fixlet or Task Message.,
() Use the following action script:

Action Script Type:

Action Script:
1: setting " BESRelay HITPServer DynamicThrottleEnabled"="1" on ”{pa:ar.’.etiai
5 L)
3; setting " BESGather Download DynamicThrottleEnabled"="1" on "{paramete
5
5 =
6 =
7
8 dos net stop BESEelay
g dos net start BESEelay

10 elseif {exiszts main gather servicel

11 dos net stop BESRootServer

12 dos met start BESRootServer

13

14 n-starts with "ATX"™}

15 }

16 wait Jete/roc.d/rc2.d/KBESEelayd =top

17 wait Jetc/rc.d/rc2.df5BESRelayd start skipclientrestart ;
18 endif - (2]
£ | i

QK ] ’ Cancel

To access this tab:

1. Select a Fixlet message or a task from any list.

2. Click an action button.

3. In the Take Action dialog, select the Action Script tab.

There are two buttons in this dialog:

Use the action script from the original Fixlet or task message
This is the default for most Fixlet actions, and is the recommended option.

Use the following action script
You can select one of the following options and either modify the existing
script or enter a new script in the text area. Select the type of action script
that you want to use for this script:

BigFix Action Script
This is the BigFix standard scripting language for actions. For more
information about the action language, see [Introducing the action|
-lanuae

AppleScript
This is Apple's scripting language for controlling computer
resources.

sh The action is a shell script to be run by a Linux or a UNIX or a bsd
shell.

Note: By default, actions cannot be undone. Make sure to test your action on a
small scale before you deploy it in your entire network.
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Action Settings

The Action Settings dialog lets you apply lockable Action Settings to a new or
customized Fixlet message, Task, or Baseline.

0 Action Settings = E M’
Mame: Actionl
Presett | Default L Show only personal presets
Bxecution | Users | Messages | Offer | Post-Action|
Constraints
[~ Starts on 5/ & at  1208:52 PM | cloent local time = ]
[+ Ends an 5/ 8/2010 B at 12:08:52 Ppd — chent local time &
[ Run between D000 AM and 25300 AM client local time -';
I~ Run only on E] i Tue || Wed F [E] chient local time -';
rPNnoﬂbr-;,hgn wetive Directory Path miatches S
Behavior
[~ On failure, retry 3 times 15
& Wait hoiur s
 Wait until computer has rebaoted ﬁ
[ Reapply this action
& whenever it becomes relevant agair S
™ while relevant, waitin =
'_ Lirmit te s
I [~ Start client downloads before constraints are satisfied S
I_ Stuggrr action start times ower 3 rmunutes to reduce netwiork load '(_;
S |
t
oK [ Cance

Using the lock icons to the right of the screen, you can lock the individual items
under each of the tabs of this dialog to force the action to be run with the selected
constraints.

* At the top of this dialog is the Name of the Action. Depending on the context it
might be editable, if you want to rename it or add extra information to it.

Below the Name box are some buttons that allow you to save or re-use your
Action values:

* Preset: This is a pull-down menu with the names of your existing presets, if any.
Click one to automatically fill out your Action settings.

* Show only personal presets: Check this box to limit the presets to your own
personal presets.

* Save Preset: After creating custom settings for an Action, you can save them for
later re-use.

* Delete Preset: Select a preset and then click this button to delete it.

This body of the dialog contains several tabs, including:

* Execution: This tab allows you to set constraints on the Action, including
starting and ending dates and run windows. You can also set up retry counts (in
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case the Action fails or reverts) and allow the deployment to be distributed over
a period of time to minimize the network load.

+ Users: Allows you to specify whether or not you require a logged-on user (or
specified group of users) to be present before running the Action.

* Messages: Specify informative messages to be displayed on the targeted Clients,
along with options for user interaction.

* Offer: This tab allows you to convert this Action into an Offer, which triggers
the display of an HTML user interface on select Clients. The user has the option
to select these Offers from a list.

* Post-Action: Specify a follow-up behavior for the Action, such as a restart or
shutdown, including appropriate warning messages.

To lock or unlock any of the items under these tabs, simply click the lock icons to
the right.

When you have finished specifying your Action settings, click OK. Before the
Console can issue the Action, you must enter your password . When you do, a
progress dialog opens to keep you informed about the deployment.

This dialog is available when you create or customize a Fixlet message, Task, or
Baseline. For Tasks and Fixlet messages, select the Actions tab, check the box next
to Include action settings locks, and click the Edit button to see this dialog. When
creating or customizing a Baseline, click the Components tab, check the box next
to Use custom action settings, and click the set action settings link.

Action Site Signing Key
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This dialog allows you to manage the location of your private key (.pvk), or to
change the password for your Action signing key.

Action Site Signing Key ey N R - - i.i

In order o sign messages sent ta BigFix Enterprise Chients, the BigFix Enterprize Console needs to
know the location of your signeng key. You will be prompted for your privabe key password in

order to venfy this signing key,
Private key (publsher,pvi)
ChUsers  Scott\ Credentials) hoense pvk :. Browse

 Change Password... | —— R S —

The Console operator must obtain a private key (publisher.pvk or license.pvk) from
the Site Administrator, who must first create it using the BigFix Administrator

Tool. When these keys have been created, the Site Administrator gives them to
authorized personnel, who can then propagate Actions. To sign an action, the
authorized Console operator must browse to the appropriate private key (typically
stored on a removable disk or memory stick) and provide a password.

You can see this dialog by selecting Tools > Manage Signing Key.
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Action: Summary

The Summary tab of the Action document shows various attributes of the selected
action. These settings were created when the action was initially specified.

= O
@ stop  Copy |#:Export 3¢

| summery | Computers (1) | Terget|

» Status

100,00% Completed (1 of 1 applicable computers)

Status Count | Percentage

Completed 1 100.00%

* Source

This action's source is the Task "TROUBLESHOOTIMNG: Run BES Client Diagnostics (Linux/UNIX/Mac)" in the "BES
Support” site.

~ Behavior

Messages
Mo user interface will be shown before running this action.
Mo message will be shown while running this action.

Users
This action will run independently of user presence.
User interface will be shown to all users.

Execution

This action ends 10/07/2013 13.13.00 client local time.

It will run at any time of day, on any day of the week.

If the action becomes relevant after it has successfully executed. the action will not be reapplied.
If the action fails, it will not be retried.

Post-Action
Mo operations will occur after the action completes. |VI:

To view this information for a specific action:
1. Click the Action icon in the navigation tree.

2. Select that specific action from the List Panel. Information about the action is
displayed in the Work Area.

3. In the Work Area, click the Summary tab.
In the Summary tab you see the following information:

Status It shows the number of applicable targets grouped by completion status of
the action. This status can be not reported, or are Waiting, or Running, or
Completed.

Source
If this action was originated by a Fixlet, this section contains a link to the
Fixlet and the name of the content site involved.

Behavior
It displays action settings including:

Messages

Describes any messages to be displayed either before or during the
execution of the specified action.
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Users Lists the requirements for user intervention in the action. Allows a
user interface to be presented to select user groups.

Execution
Contains information about the execution of the action, including
ending time, reapplication, and what happens if the action fails.

Post-Action
Provides information about what happens, including restarting or
shutting down after the application of the action.

Details
This section displays information about the action run and the relevance
expressions and the action scripts it used:

ID The ID of the action. This is the unique identifier for that action
run.

Domain
The name of the domain hosting this action.

Type Either single or multiple action, depending on how the action was
issued. For more details, see [“Taking actions” on page 24

State The overall state of the action as it deploys. These are the possible
states:

open The action is active on one or more computers. It remains
open until its expiration date elapses, or an operator stops
it.

stopped
The action was stopped by an operator. It remains stopped
until its expiration date elapses or it is removed.

expired
The expiration date for the action expired. An action
expired cannot be removed.

Issued The date of issuance and the operator who issued the action.

Relevance
This is a full listing of the relevance statement that determines the
targeting of this action. For information about the Relevance
language, see [Introducing the Relevance languagethe IBM BigFix:
Relevance Language Guide.

Action Script
This is a listing of the script that is run if this action is relevant to
the client computer. For information about the action language, see
[Introducing the action languagethe IBM BigFix: Action Guide.

Success Criteria
The criteria used to determine the successful conclusion of the
action.

Comments
This is a text box that allows you to view or attach a comment to the
action. This messages can be seen by all operators having access to the
content site that the action belongs to.
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Action: Target

The Target tab of the Action document presents a read-only display of the
computers targeted by the specified action.

= 0
[ ] Copy = Export = 3 Remove
| Summary || Computers (1) Target
Target:
[ % Selected Computers (1) Compu... 0s CFU Last Report ... | Locked
%nc%ﬁﬂ?_s.r... Linux Red Ha... 1900 MHz Xe... 08/07/2013 ... HNo
< B

To view this information for a specific action:
1. Click the Action icon in the navigation tree.

2. Select that specific action in the List Panel. Information about the action is
displayed in the Work Area.

3. Select the Targets tab in the Work Area.

The dialog shows which computers are currently targeted by the Action. The
original targeting was set when the action was deployed in the Target tab of the
[“Take action” on page 240 dialog. Depending on the targeting method, indicated
by three read-only radio buttons at the top of this dialog, the this list of computers
can be static or dynamic.

Selected devices
If this option was specified, the computers in the list are those relevant to
the action, those that satisfied the relevance expression set in the
Applicability tab of the [“Take action” on page 240| dialog. This is the
default behavior.

Dynamically targeted by properties
If this option was specified, the action selects any BigFix Client computer
with the retrieved property specified, for example any computer with
Linux Red Hat Enterprise Server 6.1 installed.
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¢” Take Action g

Mame: | BES Client Setting: Enable Debug Logging Create in domain: EAII Content | v i

Preset: |Defau|t iq [[]show only personal presets

Target iExecuh'on | Users | Messages | Offer | Post-Action | Applicability || Success Criteria | Action Script

Target:
O select devices
(&) Dynamically target by property
() Enter device names

= All Computers (1) ,\A!
=3 By Retrieved Properties
+-E5 By Computer Name
j L This action will be targeted at all computers
iLinux Red Hat Enterprise Server 6.1 with the retrieved property values selected on
=1 By CPU the left. There are currently 1 computers with
[ 1900 MHz Xeon (1) the selected property values.
#-f5 By Last Report Time =
e Any computers that change to match the
®-E5 By Locked et | e T
5] By BES Relay Selection Method i PIODCIY Yaltics Wihils U atioless
5 open will be targeted as well.
®-E5 By Relay
-5 By User Name This action will end 10/07/2013 15.12.20,
#-] By RAM client local time. See the Execution tab for
-5 By Free Space on System Drive maore details.
®-E5 By Total Size of System Drive [
#-E5 By Subnet Address [v]
<] m | [>]
[ Ok ] [ Cancel ]

This search runs when the Take action is triggered, then it is evaluated
again on timely basis until the action expires. The action expiration time
was set in the Execution tab when the Take action was triggered. If new
computers satisfying the property are found, they are added to the list of
targets and the action is run on them too. when this targeting method is
selected, The Computers tab is renamed Reported Computers.

Enter device names

If this option was specified, you see a list of computers that were manually
selected for this action when the Take action was triggered.

Add Comment

The Add Comment dialog lets you attach an explanatory comment to Fixlet
messages, Tasks, Baselines, Actions, Computers, Computer Groups, and Analyses.

o

Add Comment - M
Add the following comment to all currently selected items:

| P

I:_E_?F.___\ Cancel
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The comment you enter here is displayed in the Description or Summary tab when
you open one of the associated items in the workspace.

This dialog is available by right-clicking an item from the List Panel and selecting
Add Comment from the context menu.

Add Custom Setting

This dialog box lets you create a custom Name/Value setting that applies to the
selected computer.

Add Custom Setting l—ﬁ?_]

Setting Mame;  Lecation o

Setting Value:  Italy

0K | ’ Cancel

Type a name for the variable in the first input box, and type the value of the
variable in the second box. This can be useful for naming or otherwise attaching
text or numeric values to a computer or set of computers.

This dialog is available from the Edit Computer Settings dialog. Right-click a
computer from any listing, select Edit Computer Settings from the pop-up menu,
and then click the Add button.

Add Files to Site

This dialog lets you add files to any site that you can author. These can be
anything from simple text files to functional dashboards.

Add Files to Site (23w

Add to site: lMaster Action Site "]
Files to add: []Sendto clients @
Marme - Size

Choose files to add to the site.

Add files ][ Cancel
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Select a site from the Add to site pulldown, Browse for the files to add, and then
click Add files.

To distribute the files to every client, click the Send to clients box.
For more information, see Adding Files to Sites.

This dialog is available by selecting Tools > Add Files to Site...

Add LDAP User

LDAP users can be added through the Console.

F ™
Add LDAP User e
Search LDAP ol Search
@ Contains Starts with
Mame Distinguished ... ~ LDAP Server =
JutaaWNMO cn=JutaaNMO... My LDAP Server
lucal en=lucal,ou=... My LDAP Server '
lucal cn=lucad,ou=... My LDAP Server ‘
luca3d en=lucad,ou=... My LDAP Server =
fraGenericl cn=fraGeneric... My LDAP Server
fraGeneric2 cn=fraGeneric... My LDAP Server ‘
danyl cn=danyl,ou.. My LDAP Server
danyl en=dany2,ou. .. Iy LDVAP Server
i Fabio (fabio) cn=Fabig,ou=... My LDAP Server |
Francesca (fran... cn=Francy,ou... My LDAP Server
Larenzo (lory) cn=Loryou=t.. My LDAP Server N
Add | Cancel
|

Select or search for the user's name. Click Add.

This dialog is presented when you select Tools > Add LDAP Operator.

Add User

Local users can be added through the Console with password protection.

-

Ldd User
Username: James Baud
Paﬁwurd: Tl
Verify password: I
[ OK ] | Cancel

Enter the user's name and password plus verification. Click OK.

This dialog is presented when you select Tools > Create Operator.
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Analysis List and Document

A list of Analyses is displayed when you click Analyses, or any of its child nodes,
from the Domain Panel navigation tree.

File Edit View Go Tools Help
%= Back = B Forward ~ | ¥ Show Hidden Content  #* Show MNon-Relevant Content eﬁefresh C"

All Content « Analyses |Srzarch Analyses J
[ | Status Mame ’
Mot Activated BES Component Versions
b B Sites (14) Activated Globally BES Relay Status '
o Mot Activated Management Rights
b M Wizands Not Activated Banchwidth Throttling Stat
Dalaboards 0 ivate andwi rottling Status

An Analysis document is displayed in the Work Area of the Console when you
click an item from this list.

fnalysis: BES Component Versions e &

q'_iﬁ.cti\rall.l Qg Dreactivate | # Edit = Export | Hide ¥ Femove

Description | Details | Applicable Computers (5)

- Description
This analysis contains information about the different BES

component versions. This information is particularly useful after
performing BES upgrades.

after activating this analysis, you will see the following properties:

m

BES Client Version

BES Relay Version

BES Console Version

BES Server Version

BES AP] Version

BES Web Reports Version

& & & & @

® Click here to activate this analysis.

At the top of the Analysis document is the name of the analysis. There is a toolbar
at the top of the window, with the following choices:

* Activate: Start the specified Analysis. This option is only available if the
Analysis is currently deactivated.

* Deactivate: Stop the specified Analysis. This option is only available if the
Analysis is currently activated.
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* Edit: Make changes to this Analysis. This option is only available if this is a
custom Analysis.

* Export: Save a copy of this Analysis to import it into a different Console or
deployment or to edit it in an external editor.

* Hide Globally: Hide this Analysis from all Consoles.
* Hide Locally: Hide this Analysis from the local Console only.
* Remove: Delete the Analysis. This option is only available for custom Analyses.

There are several tabs in an Analysis document. They include:

* Description: An HTML page describing the Analysis, along with a link to
activate or deactivate the Analysis.

* Details: An HTML page listing the various Analysis attributes, including
Properties and Relevance. At the bottom of the page is a text box for entering a
Comment attached to the Analysis.

* Results: A dialog displaying the results of the Analysis. This tab is only visible
for an activated Analysis.

* Applicable Computers: A list of the Clients where this Analysis is applicable.
This is a typical filter/list panel for computers; click a filter in the left panel to
narrow down the list of computers in the right panel.

To display an Analysis list, click the Analyses icon (or any of its child nodes) in
the Domain Panel navigation tree.

An Analysis document is opened whenever you open an item in an Analysis list.

Applicable Computers Tab

150

The Applicable Computers tab displays all the networked computers that are
affected by the currently selected Fixlet, Task, Analysis, or Baseline object.

Fixlet: BES Quick Reference - Production = B

&7 Take Action - | # Edit Copy :::)Export| Hide Locally Hide Gluballj,.r| 2 Remove

| Description | Details | Applicable Computers (1) | Action History (0] |

4 T; Applicable Computers (1] » cﬂmpateer o5 P

4 3 By Retrieved Propertic || qrepye Win7 6176.. 1000 MHz AM...
- 2 By Computer Nan

» 3l By 05

. £ By CPU

- 2] By Last Report Tinl
- i By Locked

> [l By BES Relay Selec
> 2] By Relay

i = By User Mame 2 -
4 1 b 4 1 P

n

This is a /list view with a filter panel on the left, allowing you to narrow down
the displayed list of computers. To do this, open a retrieved property or group
from the left panel and select a value to filter the list.

IBM BigFix: Console Operator’s Guide



Like other lists in the Console, you can sort it by clicking the column headers. You
can add or remove header properties by right-clicking in the header row.

This dialog is available by opening a Fixlet, Task, Analysis, or Baseline from the
List Panel and clicking the Applicable Computers tab in the Work Area below.

Applicability tab

In the Applicability tab you can specify the criteria to use to judge the relevance
of a Fixlet action.

& Take Action 7

Mame: | BES Relay/Server Setting; EnableDisable Dynamic Throtting Create in domain: | Al Content w

Preset: | [Custom] Default v [C]shaw only personal presets
| Terget | Execution | Users | Messages | Offer | Post-action | Applcabilty |Success Criteria | Action Seipt|
Run this action on computers for whom. ..

() ,..the relevance clause from the original Fixlet or Task Message evaluates to true.,

() .. .the following relevance dause evaluates to true,

{exi=ts relay service OR exXists main gather service) AND (version of client
5= n7.0m)

[ OK ] ’ Cancel ]

This tab is available from several different dialogs:

* [“Take action” on page 240|

* [“Take multiple actions” on page 242|

+ [“Edit Computer Settings” on page 197

It is strongly recommended that you use the original Relevance expression, but
you might want to customize it to better suit your needs. Select:

...the relevance clause from the original Fixlet or Task Message evaluates to true.
To confirm the relevance expression set in the default action.

..the following relevance clause evaluates to true.
To modify the existing relevance expression or to specify a new relevance
expression to suite your needs. For more information about the Relevance
language, see [Introducing the Relevance languagel
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Assign User Management Rights

152

The Assign User Management Rights dialog lets you choose which computers an
operator can manage.

Azsign User Management Rights E ﬁ

;I Al Computers

This user has management rights on all computers that have the retrieved property
values shown on the left. This user does NOT have management nghts on any
computers that do NOT have the retnieved property values shown on the left.

This user will automatically be granted management rights on (or will have
management nghts removed on) any computers that change to match (or to not
match) the reineved property values shown on the left.

—re— Delete oK Cancel

This dialog displays the current set of computers that can be managed by the
selected Console operator and lets you add or delete computers from that set.
There are two buttons in this dialog:

* Add: Add new computers to the set of computers that the operator can manage.
This opens a standard filter/list box of the computers on your network. Use the
values of the retrieved properties to filter down the group of computers for this
operator. The use of retrieved properties, including custom properties, makes it
simple to group computers. For example, you might want to group computers
by their operating system or cpu type. Or you might create a special computer
setting, like department or location, and use that to group management rights to
the selected operator. Or there might be computers using particular applications
that you want to assign to specialists in your organization.

* Delete: This button lets you remove computers from the set of computers that
the operator can manage. It opens a dialog that lets you choose which retrieved
property filters you want to delete. (If a single filter was defining the rights,
when you select Delete, it does so without opening this dialog.)

This dialog is available by selecting Operators from the Domain Panel navigation
tree, right-clicking any operator in the List Panel, and choosing Assign User
Management Rights from the context menu (or choose Assign User Management
Rights from the Edit menu). You must have logged in with Administrator rights to
view this tab.
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Baseline Component Applicability Tab

The Baseline Component Applicability tab of the Computer document displays a
list of Baseline Components that are applicable to the selected computer.

Computer: TESTING of O
Edit Settings 3 Remove From Database & Send Refrech

[ Summary | Relevant Ficlet Messages (2) | Applicable Tasks (30) Relevant Baselines (1)| Baseline Companent Applicability ||+ [ + |

Select a Relevant Baseline:

heeaunting Baseline -

l& All Baseline Companents (] Mumber Component Name Nurnber

Mizsing Office Web Compe

':Ompﬂ!'!:f“‘ Mames
1 Missing Office Wt mpes

Component Group
Applicability

LS E L AL

The components are listed by their number as defined in the Baseline, the name of
the component, the group it is associated with, and whether or not it is relevant to
the specified computer. Right-click the header to see what fields are available to
display and sort by.

This dialog is available by selecting Computers from the Domain Panel navigation
tree, clicking a computer from the List Panel, and clicking the Baseline
Component Applicability tab.

Baseline List and Document

A list of Baselines is displayed when you click Baselines, or any of its child nodes,
from the Domain Panel navigation tree.

File Edit View Go Tools Help

vl Back - Forward = |!ﬁ5how Hidden Centent | ¢ Show Mon-Relevant Content q(? Refresh Cun)
All Content < Baselines |Eearch Baselines p| ;
[ Mon-Master Operator | » = Site

MName Applicable Co...

H= 7]

D@B

er Operator |

me— BigCorp Accounting Base... Master Action Site 3 /3

A Baseline document is displayed in the Work Area of the Console when you click
an item from this list.
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Baseline: MyCorp Accounting |
47 Take Action | # Edit | Copy = Export | Hide Locally Hide Globally | 3 Remove

Description | Details | Components | Applicable Computers (5) | Component Applicability | Actson History (0)

Description

This content is oriented toward MyCorp's Accounting departments

Actions

® Click here to deplay this action group

At the top of the Baseline document you find the Baseline name and a toolbar
containing several tools:

* Take Action: Click this button to run the default Actions in this Baseline Group.
* Edit: Open the Edit Baseline dialog to make changes to this Baseline.
* Copy: Open the Create Baseline dialog to make and edit a copy of this Baseline.

* Export: Save this Baseline to import into another Console or deployment or to
edit it in an external editor.

* Hide Locally: Hide this Baseline from the Local Console.

* Hide Globally: Hide this Baseline from all Consoles. It can be retrieved later by
clicking the Show Hidden Content button on the Console toolbar.

* Remove: Delete this Baseline from the database.

There are several tabs in a Baseline document. They include:

* Description: An HTML page describing the Baseline and a set of Actions
(implemented as links) that are designed to address the problem described.

* Details: An HTML page describing the Properties and Relevance clauses behind
the Baseline. At the bottom of the page is a text box to enter a comment to
attach to the Baseline.

* Components: Lists the Fixlet messages and Tasks that have been grouped into
this Baseline.

* Applicable Computers: Shows which subset of computer components this
Baseline targets. This tab also indicates the current count of Applicable
Computers for instant viewing.

* Component Applicability: Lists the numbered components of the Baseline. In
the Applicable Computer column, displays the number of computers where the
Baseline component is applicable and following the slash, the total number of
computers where the Baseline is applicable.

* Action History: Shows the history of any Actions that have been invoked by this
Baseline. This tab also indicates the current count of executed Actions for easy
viewing.

To display a Baseline list, click the Baseline icon (or any of its child nodes) in the
Domain Panel navigation tree.

A Baseline document opens whenever you click an item in a Baseline list.
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Change Password

The BigFix Console allows you to change the password if you have the correct
authorization. Enter the current password, then enter and validate the new
password.

Note: This dialog is not available if you are using NT Authentication.

This dialog is available when you select File > Change Password.

Change Private Key Password

The BigFix Console allows you to change your private key password.

Change Private Key Password I.-E—E_J

Old Passwaord: ssseee

Mew Passwaord: (TTITTT]

Confirm Password: "‘""l

oK | | Cancel

Enter your current password, then enter and validate the new password.

The value assigned to the password is encrypted, if the server is a Windows
system, or obfuscated, if the server is a Linux system, immediately after you click
the OK button.

This dialog is available when you select Tools > Manage Signing Key > Change
Password.

Comments

BigFix Console Operators can make comments on most of the BigFix objects,
including Fixlets, Tasks, Actions, Computers, and so on. These comments can be
created whenever an object like a Fixlet is selected and displayed in the main
window. Here is how to create a comment for a Fixlet message:

1. Click the Fixlets and Tasks icon in the Domain Panel navigation tree.
2. Right-click a Fixlet and select Add Comment.
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File Edit View Go Tools Help
4l Back ¥ Q Forward = | #" Show Hidden Content +" Show Non-Relevant Content aReﬁEsh Console
All Content #+ Fixlets am‘j Tasls Search Fixlets and Tasks ,D| O
» g Firlets and Tasks (1977 | Name = Applicable Co...  Open Action C... Category Download = =
@ 4 3 : 071029: Update for Windows Autorun Func... 1 = “y Advis... TEGMmelzl
> Ml Analpe O3) 976749: Update for Internet Explorer 7 - Wi... 1 ben 241 ME
[ @- Actions (90) Copy Text
» & Dashboards =|| Adobe Flash Player - Disable Flash Player U... 3 PY uration <no downl
> & Wizards Adobe Flash Player Required - BES Console 1 Copy Text with Headers t <no downl
» E5 Custom Content Adobe Reader 11.0.08 Available - Adabe. Re.. 1 Select All Update 2,31 MB
5 Custom Filters Adobe Shockwave Player 12.1.2153 Availa.. 1 e —— 11,56 MB
A @ Computers (7) Automatically Restart Stopped BES Clients ... 4 v i <no downl
» [ Computer Groups (3) BES Client Setting: BESClientUl Enable Made 4 Globally Unhide Ent Sett..  <no downl
b ﬁ Unmanaged Assets (20) BES Client Setting: Client Ul Balloon Mode .. 4 Locally Hide ent Sett..  <no downh
4 @ Operators (8) BES Client Setting: Client Ul Enable/Disable... 4 Locally Unhide ent Sett..  <no downl
i £ By Operator Type BES Client Setting: Client UI Minimum Anal... 7 . ent Sett...  <no downh
I £ By LDAP Server o = Take Default Action... i
[ By Master O it Add C t...
2l ¥ WastecOperston Fixlet: 971029: Update for Windows Autorun Funci i = 0
1> 5] By Custom Content - =
] 1 | 47 Take Action - | 7 Edit ‘ Copy [ Export | i
......... Remove
<) All Content Description | Details | Applicable Computers (1 Greste Clbtom Conye
@‘ BigFix Management Export Fl
Description z [ =
'1. Patch Management : A Add To New Baseline...
Microsoft has released an update Add To Edsting Baseline... v § AutoPlay
@ Systems Lifecycle from waorking with USB media.
Create New Fixlet...
2 AutoRun entries were populated f Create Mew Tak... and had a i
1.977 items in list, 1 selected, Create New Baseline... h'a; user 'Gabriella’

3. Type your comment into the dialog box that opens.

er Comment T — M-‘

£dd the following comment ta all currently selected itermns:

| -

| | —T—( Ry —
L '

4. Alternatively, you can double-click a Fixlet message, select the Details tab, and
enter your comment at the bottom of the page.

Similarly, you can attach comments to Tasks, Actions, Computers, and Analyses.
These comments can include keywords or operating notes. You might want to have
special information about certain computers, or usage pointers for special Tasks.
This is a free-form field, so you can make up your own rules for commenting.

To view an aggregated list of all comments, select View Recent Comments from
the Tools menu.

Recent Comments (=]
Object Commeant Console Operator Time Enterad
Automatically R Refer to new Admin Policy joe 111672011 3:02:48 PM
BES Client Sett Made part of Chent package joe 111672011 3.01:56 PM

Run on all Tokyo systems - 1/15/11 joe 11672011 3:00:22 PM
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This dialog lists all the comments created to date, sorted by time-stamp, with the
most recent comments at the top. The name of the Console Operator responsible
for the comment is listed next to the description. Each comment contains a link
that opens the original object in the main window, allowing you to view the
description and other aspects of the object.

Component Applicability Tab

The Component Applicability tab of the Baseline document displays a list of how
many computers have been targeted by the specific component.

Computer: TESTING o O

Edit Settings 3 Remove From Database & Send Refresh
Summary | Relevant Ficlet Messages (2) Applicable Tasks (30) | Relevant Baselines (1) | Baseline Component Applicability | «

Select a Relevant Baseline

hecownting Baseline » |
& All Baseline Components (2} Mumber  Component Name pry [T jue
¥  Component Name -
|
v Component Group
v Applicability

The components are numbered, corresponding to their order under the
Components tab.

Following the number is the name of the component and then the Applicable
Computer Count. This column is composed of multiple numbers in a form like
'35/50 (4 unknown)'. The first number is the count of computers where the
component is applicable, the second is the total number of computers targeted by
the Baseline.

This dialog is available by choosing the Baseline icon in the Domain Panel

navigation tree, opening an item from the resulting List Panel, and clicking the
Component Applicability tab.
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Components Tab

158

The Components tab of the Baseline document displays a list of all the component
Fixlet messages and Tasks that have been grouped into this particular Baseline.

Baseline: Default Client Baseline =
&7 Take Action | »# Edit | Copy : Export | Hide Locally Hide Globally | 3¢ Remove

| Description | Details Components :Appiir_ahle Computers {EI]_I Component Applicability [_.ﬁ -

Component Group 1

+ BES Client Setting: Enable Auto
Relay Selection Action (Defaulf)

S I

¢ BES Client Setting: Lock
Computer Action] (Defaull)

L°L L L

¢ BES Client Setting: Enable
Command Polling Action3 (Defaulf)

4 aUUILE ]

Find... 3 components in baseline

Click the links beneath each component to view the source Fixlet or Task, or to see
the actual code behind the Relevance statements and Action scripts.

The components of a Baseline are copies of the original Fixlet or Task, not pointers.
As such, if the underlying Fixlet or Task changes, the Baseline might become out of
sync with the original. If this happens, the message Source Fixlet differs is shown
in the component listing.

This dialog is available by choosing the Baseline icon in the Domain Panel
navigation tree, opening an item from the resulting List Panel, and clicking the
Components tab.
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Computer: Action History

The Action History tab provides a listing of all the actions that have been
deployed on the specified computer.

Computer TESTING =o' O
Edit Settings 3¢ Rernove From Dastabase & Send Refresh

j Summarny l Relevant Fixlet Messages (2) | Applicable Tasks (30) [ Relevant Baselines (1) | Baseline Component Applicability | Action History (2) | 4

4% Action History (2) Time lssued State Status Mame
E_l :3': 55:;' 5/6/2010 1:14:43 PM Open Completed Change Multiple Settings
& By Status 56,2010 9:50:20 AM Open Waiting Missing Office Web Components - BES Console -
& & By Site

(B> BES Support 1)

E’ Master Operator Site (1)
E5 By lssued By
ES By Type

Note that unlike the general action list for all computers available from the main
Actions Tab, this list contains only actions targeted to the selected computer.

The Action History list has options similar to any Action List Panel.

To view more information about a particular action, double-click it. This opens the
corresponding Action document in the Work Area.

This dialog is available by choosing the Computers icon from the Domain Panel
navigation tree and then clicking a computer from the list. Then click the Action
History tab in the Computer document window.

Computer: Applicable Tasks

The Applicable Tasks tab of the Computer document lists all the Tasks that are
relevant to the selected computer.

Computer TESTING of O
Edit Settings 3 Rermove From Database & Send Refresh

| Summary | Relevant Fixlet Messages (2) | Applicable Tasks (30) l Relevant Baselines (1) | Baseline Component Applicability | Ac * | *

4 54 Applicable Tasks (30) *  Name Category Site
E! ::" ;“'5”'}' Start Service Common Tasks  BES Support
« & ,f EtEEE.S @) Restart Service Commion Tasks  BES Support
+ S B_”E:’ || Switch BES Client Action Site Masthead - BES7 Suppert BES Suppert
& By i Force BES Clients to Run kela:( Autozelection Support BES Support

= By Source Severrt
% <Unspecified:
i Low (3)
£S5 By Source
B By Source Release _

'l m 3 4 n "

TROUBLESHOOTING: Restart the BES Clent Service Troubleshooti..  BES Support

This filter list is updated in real-time, refreshing its display as Tasks are
reevaluated. You can filter the list by clicking items in the left pane, and sort the
tasks by clicking the appropriate headers.
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This dialog has the same options as any Task List Panel.

This dialog is available by clicking the Computers icon in the Domain Panel
navigation tree and then clicking a computer from the resulting List Panel. Then
click the Applicable Tasks tab in the Computer document window.

Computer Group: Action History

160

The Action History tab of the Computer Group document provides a historical
listing of all the actions that target any member of the specified computer group.

Computer Group: Finance test group = B8
# Edit Copy fnExport | 36 Remove
Relevant Fixlet Messages (4) l Applicable Tasks (33) ] Relevant Baselines (3)  Action History (6] | Applicable Analyse *
4 (@b Action History (6) Time Issued State % Complete Mame b
4 & By State -
PR e — 1/16/2011 2:08:08 PM Open Windows Firewall is |
4> Open (4] ey » owic
b S By Site 1/16/2011 2:07:38 PM Open Windows Firewall is |
Ef El 1 4B 1/16/2011 2:06:51 PM Open 100.00% (1/1) Windeows Firewall is |
SSUE
9 Sy ssuedBy 1/16/2011 1:31:53 PM Dpen 100.00% (1/1)  BESRelay / BES Serve
B By Type
& Expired (2)
B By Site
E5 By lssued By
B3 By Type
Ll 12} *

This dialog has the same options as any Action History List Panel, but contains
only those Actions that are targeted to the selected Computer Group.

To view more information about a particular Action, double-click it. This opens the
corresponding Action document in the bottom panel.

This dialog is available by clicking the Computer Groups icon in the Domain

Panel navigation tree and clicking a Computer Group from the resulting List Panel.
Then click the Action History tab in the Computer Group Work Area.
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Computer Group: Applicable Analyses

The Applicable Analyses tab of the Computer Group document provides a listing
of all the Analyses applicable to this group and allows you to filter them.

Computer Group: Finance test group 5 = B8
# Edit Copy (s Expon | 3¢ Remove
Applicable Tasks (39) | Relevant Baselines (3) | Action History (6) | Applicable Analyses (7) "
4 @) Applicable Analyses (7) Status : Mame Site
&8 By
«aa E"' S:at!ﬁ i Not Actrvated Bandwadth Throttling Status BES Support
} Nq':\: :d g r; [';_"' ' Mot Activated BES Component Versions BE5 Support
i e oted B). | e EES Health Checks Analysis EES Support
Not Activated BES Management Rights BES Support
& Master Action Site (. Not Activated BES Relay Cache Infarmation BES Support
[S By Activated By Not Activated BES Relay Status BES Support
i mm [ 4 mr [

This dialog has the same options as any Analyses List Panel.

To view more information about a particular Analysis, click it. This opens the
corresponding Applicable Analyses document in the bottom panel.

This dialog is available by clicking the Computer Groups icon in the Domain
Panel navigation tree and clicking a Computer Group from the resulting List Panel.
Then click the Applicable Analyses tab in the Computer Group document
window.

Computer Group: Relevant Baselines

The Relevant Baselines tab of the Computer Group document provides a listing
of all the Baselines that have been deployed on the specified Computer Group.

Computer Group: Finance test group = B8
# Edit Copy =pExport | 36 Remove

Applicable Tasks (39) Relevant Baselines (3] | Action History (6) l Applicable Analyses (7) +& '

Pl TH Relevant Baselines (3) Mame Site
B By S
4% '£}S;EM&3 MyCorp Accounting Master
[ Ninsher Action e &) Client Baseline Master &
Diefault Client Baseline Master &

This dialog has the same options as any Baseline List Panel, but contains only
Baselines targeted to the selected Computer Group.

To view more information about a particular Baseline, double-click it. This opens
the corresponding Relevant Baseline document in the Work Area.
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This dialog is available by clicking the Computer Groups icon in the Domain
Panel navigation tree and clicking a Computer Group from the List Panel. Then
click the Relevant Baselines tab in the Computer Group Work Area.

Computer Group: Computers

162

The Computers tab of the Computer Group document provides a listing of all the
computers that have been manually selected to be a part of the specified Computer
Group.

Computer Group: Finance test group = O

# Edit Copy | “nExport | 3§ Remove

De:criptian. Computers (1) | Relevant Fistet Messages (4] | Applicable Tasks (39) | Relevant Baselines *
+ @ Computers (2) ComputerNa.. 0S5 CPU Last Report
ek TESTING Win7 617600 1000 MHz AM... 1/17/2011 ¢
# 5 By Group A YD hh] 400 Bk Pran e

W Bucket Group (0) ¥ g e
q Finance test group (2)| L;;
E'.!'; Legacy Group (1)
q: Tekyo Accounting (0]

“ Win 7 Gruup 1) " T i

This dialog is displayed only for Manual Computer Groups. It has options similar to
other Computer lists, but contains only computers belonging to the selected
Manual Computer Group. Note that the number of reporting computers is
available in the tab itself, for viewing at a glance.

To view more information about a particular Computer, double-click it. This opens
the corresponding Computer document in the bottom panel.

This dialog is available by clicking the Computer Groups icon in the Domain
Panel navigation tree and clicking a Manual Computer Group from the List Panel.
Then click the Computers tab in the Computer Group Work Area.
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Computer Group: Description

The Description tab of the Computer Group document provides information
about a selected Computer Group. Below is the dialog for an Automatic Computer
Group.

Computer Group: Tokyo Accounting =0
# Edit Copy “Export | 3 Remowve

Description .Reponjng Computers (0) | Relevant Fidet Messages (0) | Applicable Tasks (0] Relevant Baselines (0) | Action *

* Details
Type Automatic
Group IO DO-53
Sig aster Actien Site

This group includes computers with all of the following properties

Location contains “Tokyo™
Computer Name  contains "acct-"
Relevance
=
[version aof client >= "£.0.0.0") AMD | (exi=zts crue whose (if ctruse then

(exiate (((local time zZone as 3 g) a2 integer) /100 + 12) whose (it

as atring as lowercase contains kyo™ as lowercase)) elae falae))
AND (exists true whose (if true 1 (exists (computer name) whose (it
a5 string as lowercase contains "acot-" a3 lowercase)) else false)))

* Commenis

Console Operator  Time Entered -

It contains different information depending on whether the group is Automatic or
Manual:

Automatic Computer Groups contain several sections:

* Group Definition: This is a listing of the properties that specify the inclusion of
a computer into the group. Each is a clause of the form <property>
<relationship> <value>. For example, OS contains "win", creates an Automatic
Computer Group consisting of Windows machines.

* Targeting Relevance: This is the full Relevance expression that implements the
property evaluation described above. Click show indented relevance to see a
formatted version of the expression.

* Comments: This is a text box to enter a comment that is attached to the
Computer Group for other operators to view.

Manual Computer Groups only contain a Comment box. The information you
enter here is attached to this Computer Group and become available to other
Console operators.

This dialog is available by clicking the Computer Groups icon in the Domain

Panel navigation tree and clicking a Computer Group from the List Panel. Then
click the Description tab in the Computer Group document window.
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Computer Group: Relevant Fixlet Messages

The Relevant Fixlets tab of the Computer Group document provides a listing of
all the Fixlet messages that have been targeted to the specified Computer Group.

Computer Group: Finance test group o B8
7 Edit Copy ‘nExport | 3 Remove

Description | Computers (2)  Relevant Fidet Meszages (4] | Applicable Tasks (39) | Relevant Baselines (3} | Action History °

 [34 Relevant Messages (4) Mame Applicable Co... Ope.. Category
E By S.ource Severily BES Quick Reference - Evaluation 172 0 Support
- "—‘:E:" — - Evaluation im Restricted Mode 272 0 Licensing
Lli = C:i::f:‘m @) oFFICE: Office 2003 Deployment Control - Init... 1/2 0 Setting
r Versien of Dbmslpen.dil May Cause Handle Lea.. 1/2 ] Suppert
& By Source

E‘E By Source Release Dat

This dialog has the same options as any Fixlet List Panel, but contains only those
Fixlet messages targeted to the selected Computer Group.

To view more information about a particular Fixlet message, double-click it. This
opens the corresponding Relevant Fixlet message document in the Work Area.

This dialog is available by clicking the Computer Groups icon in the Domain
Panel navigation tree and clicking a Computer Group from the List Panel. Then
click the Relevant Fixlets tab in the Computer Group Work Area.

Computer Group List and Document

A list of Computer Groups is displayed when you click Computer Groups, or any
of its child nodes, from the Domain Panel navigation tree.

File Edit View Go Tools Help

@ Back ~ B Forward « | %" Show Hidden Content ¥ Show Mon-Relevant Content ,&E*i' Refresh Consﬁ
All Content 4 Computer Groups  |Search Computer Groups E

§ @ Baselines (1) “ | Mame Type Site l

+ [g» Actions (5)

s il OTTTOILE

<

external group Manual &
— | Win group ; _ Automatic ~ Master A{
> T

:| M grou Automatic Master Actiog
Y =| graup

| :
b ? Capsole O ) | 4| Ggroup Automatic . MasterAf

Computer Groups (4)
iy gc ]

A Computer Group document is displayed in the Work Area of the Console when
you click any item from this list.
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Computer Group: Tokyo Accounting = O

o Edit Copy | Export | x@

Description Reperting Computers (0] | Relevant Fidet Messages (0) | Applicable Tasks (0] | Relevant Baselines (0) | Acties * | °

* Details
ype Automatic
Group ID  DQ-53
Site Master Action Site
Definition

This group includes computers with all of the following properties

Location contains "Tokyo™
Computer Name  contains “acct-"
Relevance
+=
[(varzion aof clieant >= "& .0.0") AND | ([existcz crue whoze (1f ctrue chen

(exiata ({(local time zon
as string as lowercase co

as string) as integer) /100 + 13) wh

ins * “ as lowercase)) elass

AND (exists true whose (if true {exists [(computer name) 0
as string as lowercase containa "acot-" as lowercase)) else false)))

At the top of the Computer Group document is the name of the group. Under that
is the Computer Group toolbar. It includes:

* Edit: Open up a dialog that allows you to edit the criteria for this group.
* Copy: Create a copy of this group and edit it.

* Export: Save this group for editing by an external editor.

* Remove: Delete this group from the list.

There are several tabs in a Computer Group document, and they might differ
according to the group type. They include:

* Description: For an Automatic group, this tab displays the Group Definition (as
a list of property-associated Relevance expressions), the Targeting Relevance
clause that implements the group definition, and a comment box. For a Manual
group, this tab displays a comment box only.

* Reporting Computers: Only displayed for Automatic groups, this tab is a list of
the computers that are currently considered members of the group, based on
properties and Relevance. This is a filter/list panel, allowing you to narrow
down the list by selecting from the filtering folders on the left side.

* Computers: Only displayed for Manual groups, this tab is a list of the
computers that have been manually selected to be members of the group. This is
a filter/list panel, allowing you to narrow down the list by selecting from the
filtering folders on the left side.

* Relevant Fixlet Messages: Lists all the Fixlet messages that apply to this
Computer Group.

* Applicable Tasks: Lists all the Tasks that apply to this Computer Group.

* Relevant Baselines: Lists all the Baselines that apply to this Computer Group.

* Action History: Lists all the Actions that target any member of this computer
group.

* Applicable Analyses: Lists all the Analyses and allows you to filter them by
Computer Group.
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To display a Computer Group list, click the Computer Groups icon (or any of its
child nodes) in the Domain Panel navigation tree.

A Computer Group document is opened whenever you click an item in a
Computer Group list.

Computer Group: Reporting Computers

166

The Reporting Computers tab of the Computer Group document provides a
listing of all the computers that have been automatically chosen to be a part of the
specified Computer Group because of their property values.

Computer Group: Bucket Group [ lm|
# Edit Copy “:Export | 3 Remove

Description | Reporting Computers (1) [ Relevant Fislet Messages (2) | Applicable Tasks (33) | Relevant Baselines (3) | Action History [0) * | *

4 [ By Retrieved Properties 4 ComputerMa.. |05 l} CPU Last Report Ti...  Locked
- :" ;';’“p”“’”“’“e BIGDOG Win7 617600 " 3000 MHz Cor...  1/17/20115:35.. Mo
4 &l by U

W Win7 6.1.7600 (1)

By CPU

By Last Report Time

By Locked

By BES Relay Selection Method
By Relay

By User Name

bib

p] 1] 1 1101

This dialog is displayed only for Automatic Computer Groups. It has the same
options as any Computer List Panel, but contains only computers reporting to the
selected Computer Group.

To view more information about a particular Reporting Computer, double-click it.
This opens the corresponding Computer document in the Work Area.

This dialog is available by clicking the Computer Groups icon in the Domain
Panel navigation tree and clicking an Automatic Computer Group from the List
Panel. Then click the Reporting Computers tab in the Computer Group Work
Area.
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Computer Group: Applicable Tasks

The Applicable Tasks tab of the Computer Group document provides a listing of
all the Tasks that are applicable to one or more computers in the specified
Computer Group.

Computer Group: Bucket Group o 0
# Edit Copy |“:Export | 3¢ Remove

Relevant Fixdet Messages (2) | Applicable Tasks (33) | Relevant Baselines (3) | Action History (0) | Applicable Analyses (5 *

o -?:'l Applicable Tasks (33) * Name Category Site *
4@ ByCategoy BES Client Setting: Relay Selection Controls BES Client Seft... BES _
\Eifgy BES Client Setting (19) y -

= ¢ Tocke (3 BES Client Setting: Enable Debug Logging BES Client Sett... BES

-I,': 5:mron:rl|5ll gz - & BES Clent Setting: Communication Method BES Client Sett... BES

-.1_—" L = BES Client Setting: Download Throttling BES Client Sett... BES

iz Troubleshooting (5) - : : A

?— Upgrade (1) BES Client Setting: CPU Usage BES Client Sett...  BES

5 By Site BES Client Setting: Client Ul Balloon Mode Selection BES Client Sett... BES

B By Source Severity Enable BigFx Client Interacting with Desktop BES Client Sett... BES
o = 3 T RFS Client Settine: Frcnnted Renortc RFS Client Sett_.  RFS 7

4 m ¥ Ll L] b

This dialog has the same options as any Task list. Click any header to sort the list.

To view more information about a particular Task, double-click it. This opens the
corresponding Task document in the Work Area.

This dialog is available by clicking the Computer Groups icon in the Domain
Panel navigation tree and clicking a Computer Group from the List Panel. Then
click the Applicable Tasks tab in the Computer Group Work Area.

Computer List and Document

A list of Computers is displayed when you click Computers, or any of its child
nodes, from the Domain Panel navigation tree.

File Edit View Go Tools Help
gl Back ~ By Forward = | % Show Hidden Content 4" Show Mon-Relevant Content eﬂeﬁesh Conso

All Content « Computers Search Computers Pl
4 [ Computers (3) (4] | computerN... 05 cPU Last F‘.eportTi..’
foperties  FTESTING Win7 6.1.76... 2400 MHz AM...  5/22/2010 4:10... &
4 @@ By Group | : MOMMA WinXP Med.. 3400 MHz Pen..  5/21/2010 8:40..X

% edernal group () BIGDOG inVista6... 3000 MHz Cor...  5/22/2010 4:12...

% G group (2]
SN N L PP T Y Y VN

A Computer document is displayed in the bottom window of the Console when
you click any item from this list. Click the Summary tab to see essential
information about this computer.
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Computer: TESTING

e B

Edit Settings 3 Remove From Database & Send Refresh

Summary | Relevant Fixlet Messages (2) | Applicable Tasks (35) | Relevant Baselines (3] | Baseline Component Applicability | - [

Core Properties
Actrve Directory Path
)5
CPU
DNS Name
P Addrass

Puls Address

Last Reported

* Computer Properties

-

WinT 6.1.7600

1000 MHz AMD Athlon{tm) 64 X2 Dual Core Processor 5000+
Testing

192.168.1.5

2002 2264:1468:0:9917-2bal de59 Becf

2002 -8e64-1468:0-54c8-6e87-e8f 2eel
fed0:0:0:0:9817-2bal:-de59:Becf

11772011 7:37:23 PM

Mo

Custom Properties
12/09/06
e on System Drive 8292 MB

Here you find the name, information about the processor, and operating system.
Scroll down to see more information, including how many Fixlet messages are
relevant to this computer and how many actions are open.

There are several tabs in a Computer document. They include:

* Summary: Displays a list of properties that are being retrieved from this
computer, as well as the Client Relay Status, Group Memberships, Custom Sites,
Settings, and Comments.

* Relevant Fixlet Messages: A list of the Fixlet messages that are currently
relevant on this computer. These can be narrowed down using the filter tree in
the left panel, then sorted by clicking the column headers. The current number
of relevant messages is indicated in the tab itself, so you can see it at a glance.

* Applicable Tasks: Lists the Tasks that apply to this computer. The current
number of tasks is indicated in the tab.

* Relevant Baselines: Lists the Baseline items (Fixlets and Tasks) that have been
assigned to this computer. The current number of baselines is indicated in the
tab.

* Baseline Component Applicability: Shows which components of specified
Baselines are applicable to this computer.

* Action History: Shows which Actions have been applied to this computer. The
current number of Actions is indicated in the tab.

* Management Rights: Displays the names of the authorized operators for this
computer. The current number of operators is indicated in the tab.

A computer list is displayed when you click the Computers icon (or any of its
child nodes) in the Domain Panel navigation tree.
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A Computer document is opened whenever you click an item in any list of
Computers.

Computer: Management Rights

The Management Rights tab of the Computer dialog lists the operators who are
currently granted management rights to apply actions to the specified computer.

Computer: BIGDOG e O

Edit Settings 3¢ Remove From Database » " Send Refresh

| Baseline Component Applicability | Action History (0] | Management Rights (5]

4 E Users Granted Ma| pame Master Operator Last Login Time =
" SI:EY ’:a"‘te’ OP' Joe Ves 1/16/2011 2:34:15 PM
% Y” %1:') Kat Yes 12/1/2010 9:26:56 PM |
R Sue Ves 12/1/2010 9:36:20 PM
P P—T— v |4 8 T - n b

You can filter this list by using the filter tree in the left panel. The list has three

headers that you can use to sort the list:

* Name: The name of the Console operator who has been granted rights.

* Master Operator: A Yes or No flag that indicates if the rights manager is also a
Master Operator.

* Last Login Time: The last time this operator logged in to the BigFix System

This dialog is available by clicking the Computers icon in the Domain Panel
navigation tree and then clicking a computer in the resulting List Panel. Then click
the Management Rights tab in the Work Area below.

Computer: Relevant Baselines

The Relevant Baselines tab of the Computer document lists all the Baselines that
are applicable to the selected computer.

Computer MOMMA = 0

Edit Settings 3¢ Remove From Database & " Send Refresh

| Summary | Relevant Fixlet Messages (1) | Applicable Tasks (33) | Relevant Baselines (1) || ¢+ | *
TE] Relevant Baselines (1) | pame Site Applicai&le

BigCorp Accounting Base... Master Action 5ite 3/3

This filter/list is updated in real-time, refreshing its display as Baselines are
reevaluated. The number of Baselines that are currently relevant is listed in the tab
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itself for easy viewing. Because Baselines contain content such as Fixlets that are
targeted to computers based on relevance, different Baselines might apply to
different computers, depending on current applicability.

This dialog has the same options as any Baseline List Panel, and can be sorted by
the same headers. You can open and view individual Baselines by double-clicking
them from this list.

This dialog is available by clicking an item in any Computer list. Then click the
Relevant Baselines tab in the Computer Work Area.

Computer: Relevant Fixlet Messages

170

The Relevant Fixlet Messages tab of the Computer document lists all the Fixlet
messages that are relevant to the selected computer.

Computer: BIGDOG .|

Edit Settings  J{ Rermove From Database 7 Send Refresh

[ Summary Relevant Fixlet Messa ges M) : Applu:ahlg Tasks (32] Felevant Baselines (1)) | Baseline {.ompnnqﬂl‘ Appli:ahlld}r ! nE.

4 Gk Relevant Messages (4) * | MName Caurce Sl-werity Site
IE! :’ ;cum: Severity Administratree Login Meeded Impertant BES Support
4 W By e ‘Windows Firewall is Blocking BES Traffic - Win... Important BES Support

a T_‘ BES Support {4) -
E5 By Source Severity
E&l By Category
4 & By Source
A BigFix (4)
B Bv Source Release Date

Restart Needed Muoderate BES Support
Rectart Needed - Mot Triggered by a BES Action  Moderate BES Suppert

- £l M '

This filter list is updated in real-time, refreshing its display as Fixlet messages are
reevaluated. The number of Baselines that are currently relevant is listed in the tab
itself for easy viewing.

This dialog has the same options as any Fixlet List Panel and can be sorted by the
same headers.

This dialog is available by clicking the Computers icon in the Domain Panel
navigation tree and clicking a computer from the List Panel. Then click the
Relevant Fixlet Messages tab in the Computer Work Area.
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Computer Subscriptions Tab

The Computer Subscriptions tab of the Sites document lets you establish criteria
for subscribing Clients to the specified site.

External Site: BES Asset Discovery o O

Hﬂave Changes Discard Changes| Gather 3¢ Remove

Details | Computer Subscriptions |Operator Permissinns|

The following computers will be subscribed to this site:
() All computers

(") Mo computers

i@ Computers which match |any ¥ | of the conditions below

[GS v] [cu:rntains v] Win [j
[anation v] [cnntains v] Ttaly B

There are three buttons available for external sites.
* All computers. Subscribe all available clients to the specified site.
* No computers. Do not subscribe any clients to the site.

¢ Computers which match... Set criteria for subscription based on client
properties. This is a flexible technique to subscribe only those computers that
satisfy the properties you specify in a property / operator / value trio. You can
select any or all from the pull-down menu to OR or AND the criteria together.
Use the plus button to add another criterion and the minus button to delete one.

For custom sites, there is another button.

* Computers subscribed via ad-hoc custom site subscription actions. With this
option all computers start out unsubscribed. To subsequently subscribe a
computer, you must display the list of computers (click Computers from the
Domain Panel navigation tree) and then right-click the set of computers you
want. From the context menu, select Modify Custom Site Subscriptions.
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File Edit View Go Tools Help
4wl Back ~ W Forward ~ | # Show Hidden Content ¥ Show Non-Relevant Content

All Content « Computers Search Computers

> R Fixletsand Tasks ( » | computer N... 0S CPU Last Report Ti...

> @ Baselines (1) ]

[ i —trtTTTEth Open

4 [Ty Computers (3 et
B G Buters o || BIGDOG v
Pt < P Copy Text with Headers
i £ By Group e e

3 Select All

[» @ Computer Groups| | Computer: TESTIN

> @ Analyses (12) Edit Settings ¢ F Edit Computer Settings... /

» [F4 Console Operator
3 % . g Modify Custom 5ite Subscriptions...
4 [ Sites (14) Summary | Rele

B Custom(2) | Add Comment...

[+
~ e[ 5 External (12) Remove From Database..,
i g el & bt P g gt A ah,

From the resulting dialog, select sites to subscribe or unsubscribe.

'l '
Modify Custom Site Subscriptions e

@ Subscribe selected computers to site:

| BigCorp Dev Site = |

) Unsubscribe selected computers from site:

I BigCorp Dev Site I

O Cancel

LS

Only those sites where the ad-hoc option has been set are available for
subscription in the pull-down menu. Note that this dialog also allows you to
unsubscribe computers from an ad-hoc grouping.

This dialog is available by clicking the Sites icon in the Domain Panel navigation
tree, clicking an item from the resulting List Panel, and then clicking the Computer

Subscriptions tab.

172  IBM BigFix: Console Operator’s Guide



Computer: Summary

The Computer Summary tab lists several items of interest, including Properties,
Relay status, Grouping, Custom Sites, Settings, and more.

Computer: TESTING o' 0

Edit Settings ¥ Remove From Datsbase & Send Refresh

Summary Relevant Fudet Messages (2] | Apphcable Tasks (35) | Relevant Baselines (3) | Basehine Component A * |

* Computer Properties

Core Properties
Actmwe Directory Path

0S5 WinT 6.1.TE00

CPU 1000 MHz AMD Athlon(tm) &4 X2 Dual Core Processor 5000+
DHNS Hame Testing

P Address 192.168.1.5

Pyl Address 2002-ae64:1458:0:9917 2bal de59:Bacl

2002:aehbd: 14680 54cB 6e8T ebf Zeal
fed0:0:0:0:9917:2bal - deb9-Gecf

Last Repared 1MT/2011 T:52-30 PM

Lockead o

Custom Properties

BIOS 1210906
Free Space on System Dnve 8287 MB
Location T

FLAM 2048 MB
Subnet Address 192.168.1.0
Total Size of Systemn Dirve 142250 MB
User Name Scott

« Client Relay Status
i nm ¥

The Properties section of the Summary lists various properties of the given
computer, derived from Relevance Expressions. These properties help you define
subsets, sorting fields, reports, and grouping criteria for the various client
computers under your administration.

The default properties include, but are not limited to:

Core Properties
* Active Directory Path: The position of the BigFix Client within the Active
Directory hierarchy.

* OS: The operating system of the given computer.
¢ CPU: The speed and type of CPU.
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DNS Name: The name of the computer.

IP Address: The current IP Address of the computer.

IPv6 Address: The version 6 IP Addresses of the computer
Last Reported: The time that the computer last reported.
Locked: The locked status (Yes or No) of each computer.

Custom Properties

BIOS: The version and date of the Basic Input/Output System.

Free Space on System Drive: How much space is available on drive C of the
given computer.

RAM: The amount of RAM in the given computer.
Subnet Address: The subnet IP Address of the given computer.

Total Size of System Drive: The total size of the drive containing the operating
system on the given computer.

User Name: The name of the BigFix Client user.

You can find out more about these predefined properties in the sections on
computer properties and Relevance Expressions.

Scroll down to see the other sections of the Computer Summary.

Computer: TESTIMG [l

Edit Settings 2 Rermove From Detabase » ° Send Refresh

Summary | Relevant Fislet Messages (2) | Applicable Tasks (25) | Relevant Baselines (3] | *

* Client Relay Status

This computer iz a Tvoll Endpoint Manager root senser

* Computer Group Memberships

Manual Group  Finance test group

Manual Group  Win 7 Group

w Subscribed Sites

BES Asset Discovery
BES Inventory and License -

] mr k

Client Relay Status identifies the status of the chosen computer as a Server,
Relay, or Client.

Computer Group Membership lists any groups, automatic or manual, that this
computer is a member of.

Subscribed Sites lists any Sites that this computer is subscribed to, including
external sites, operator sites, and custom sites.
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The following sections contain a list of Settings for this computer, including Client,
Relay, Server, Gather, and WebReport settings and the versions of the BigFix
software running on this computer.

Computer: TESTING [l =]

Edit Settings € Remove From Database & " Send Refresh

Summary | Relevant Fislet Messages (2) | Applicable Tasks (35) | Relevant Baselines 3) | Baseline Companent Applicability | Action Histor * |

» Client Settings |

_BESClhent_LastShutdown_Reason Senice manager shutdown request

C-\Program Files (x86]\BigFi Enterpise\BES

BESCH dManager_BufferDirectory iy
_BESChent_UploadManager_BufferDirectony Client\ BESData\, Globalpload

BESGather_ Comm_UseDownloadSenice 1 =
_BESGather_Comm_UseUrdMoniker 1 .
_BESGather_Download_CacheLimitMB 1024
_BESGather_Download_CheckinternetFlag 1
_BESGather_Download_CheckParentFlag 0 |

‘ nr v

At the bottom of the page is a text box where you can enter comments that to be
attached to this computer for future reference.

This dialog is available by clicking the Computers icon in the Domain Panel
navigation tree and clicking a computer from the right-hand List Panel. Then click
the Summary tab in the Computer Work Area.

Connect to Database

The Connect to Database dialog opens when you start the BigFix Console.

+) Connect To Databa
H = i o

Database: | bfenterprise -

Username:  joe

Password: MT Authentication

QK i | Cancel

It lets you select which Database you want to manage.

Database: Select a database from the pull-down menu.
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Username: Enter the user name that allows you to access the database. The set of
allowed users is maintained by the BigFix Site Administrator using the BigFix
Administration Tool.

Password: Enter the password that corresponds to the user name above. In some
cases, NT will authenticate for the user. If this is the case, the password box is

grayed out.

This dialog is available when launching the BigFix Console.

Console Operator: Assigned Roles Tab

176

The Assigned Roles tab of the Operators window allows you to associate roles
with the specified Console operator.

File Edit View Go Tools Help

=l Back - Forward = | ) Show Hidden Content " Show Non-Relevant Content | 5 ¥ Refresh Console

All Content « Operators Search Operators P‘ [m|
o rmeuras

- 5 Custom Content * | Name Last Login Time Operator Type .A_

E5 Custom Filters IEMAdmin 08/09/2014 17:02:48 Local |

> E Computers (7] 26/08/2014 15:44:59 Local

| Fabig
3 E Computer Groups (3) 19/08/2014 15:48:09 Local -
amageg A | [ "X_?rf ] L3

Operators (8)

- E. Console Operator: Winpatch = 0
3 By-OpErator Type |
> [ By LDAP Server BSEVE Changes Discard Changes | Reset Password 3¢ Remove
> £2) By Master Operator | -
| etails ministered Computers ssued Actions ssigned Roles ites omputer Assignments
» £ By Custom Content Details | Admi d Comp ) | Issued Actions (0) | A: d Roles (2) | Sites (3) | Computer Assig
5 By Computers
g Bi Sitesp Assign Role Remaove Role
> Gl By Login Permission . % Assigned Roles (2) | Name Master... Unmanaged.. Custom.. Sites Computers Operator:
Sites (22
LDAP(DiJre(tnnes M TestRole Mo Show Mone Yes 0 ] 1
Ralec (71 - TestRole2 Mo Show Mone Yes 0 ] a

< 1 Jd
() Al Conten
@ BigFix Management
‘1. Patch Management

@: Systems Lifecycle

¥

Click Assign Role to bring up a dialog with your currently unassigned roles listed
for selection. You can also delete roles from this operator by selecting them from
the list and clicking Remove Role.

Make sure to click Save Changes before you dismiss this window.
This dialog is presented when you select someone from the Operator list or when

you create an operator from scratch with one of the Operator creation commands
available in the Tools menu.
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Console Operator: Details Tab

The Details tab of the Operators window lets you define the permissions for each
operator in your purview. Select an operator from a list and then click the Details

tab.

"= O

Cheger  Discard Chenge: | Roevet Pasesord 3 Bewmove

Deeteils | udminkstered Computess [0} | kuued dctions @) | Assigreed Fcles 1) | Sites (1) | Compuies Assigniments

From this interface, you can grant a user Master Operator permissions. You can

Cvarview

usert- B0 T
nar Type Local Console Dpesmion
5L Lorge T Hurerw
) Adways allows Shes upes T log in
s et Crniby sl Ehis umer 1o o bn whin thany ane o mamis s of o least sne male
Desable RS 5ar"s logen

Formissicne

Aasler Cperat Mo |~ Ha
v ey Dipeeiors’ Actions Mo =] Yes
You ] Vs
Yas [~ Yan
Bt pily. Tt Y’Ds:'": Yas
L Comment Mo [~] Vaa
manmged Ansets Show Hone o | Showr Nore
Rostm amd Shatdosn | 2]
. Efsctive Pan
Lt Eshire Adow Fostan sand Shitdown [w] Al R stan and St
5 Adcw Fasdan and snmmwn;v_| Allcar Fe stad and Sl diown
Infarace Login Privilegos
—
= Yaos \'J aci
5T AR Yﬂi:‘ Yau

also determine whether or not you want to show this operator the issued actions

of other operators, whether you want this operator to run actions or reboot on
computers, create custom content, and see unmanaged assets. You can also set
permissions to access the BigFix Console and REST APL

Make sure to click Save Changes before you dismiss this window.

This dialog is presented when you select someone from the Operator list or when
you create an operator from scratch with one of the Operator creation commands
available in the Tools menu.
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Create Role

This dialog allow you to add Roles to the Console that can then be shared by other
Operators. To start specifying a role, select Tools > Create Role and enter a name
for the role.

P )

Create Role

Please enter the name of the role:

Finance Group|

[ Ok ] | Cancel

The rest of the definition happens through a tabbed document interface.

Ficle: NMORole2
B35 ange 5 ¥ Remaove
Desails | Computer dssgnments | Operators (3) | LW Geoups (1) | Sites i)
fiszali

NMORa1

MO = B3 - CuUsLon CONLERT = Yes - Show Other = Yes - Urmanaged = Show Mone

M ]
Yes [v|
s [v]
s ]
s Yes[v|
os [v|
Show Mane  [w]
Huatan and Shindows | 7 ]

Aderm Restart and Shuldown _\-*_
Acris Reztait s Shidown %]

lsliace Legin Friviliges
Yo

Yos:

Set the basic permissions for the role through the Details tab. Decide which
computers will be associated with this role using the Computer Assignments tab.
You can select specific users who will assume this role through the Operators tab.
You can also add entire groups of users with the LDAP Groups tab. Finally, you
can assign specific sites to be the purview of this role with the Sites tab.

This dialog is presented when you select Tools > Create Role.
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Help for the BigFix Console

Show the help files for the BigFix Console. These online files provide a tutorial, a
description of the program, and a full-text search capacity. To get started, click

This dialog is available by selecting:
* Help > Contents

Console Operator: Administered Computers

The Administered Computers tab of the Console Operator document displays a
filter/list of all the computers administered by the selected operator.

Console Operator: Joe Blough ﬂ E|
Bl sove Changes Discerd Changes | Reset Password 3¢ Remaove

Details | Administered Computers (3) | lssued Actions (0) | Assigned Roles (3) | Sites 17)

S Ad ITI:I'I.:.EEQ;I-EE-En;;ﬂ}l.;t;-r;.ﬁ] Cumpu{ﬂ Na.. | 05 CPU
B ANDERSSC Win7 6.1.7601 1600 MHz Cor...
(K BIGDOG WinT 6.1.7601 3000 MHz Cor...
(R TESTING Win7 6.1.7600 2600 MHz Athl...

Note that the number of computers is displayed in the tab itself for viewing at a
glance. As with any Computer List Panel, you can filter and sort it by retrieved
properties and groups. This means you can use your own custom-created
properties or groupings to parcel out administrative rights. You might use a
retrieved property, for example, to match up specific applications to experts in
your organization. Or you could connect departmental IT managers to their own
domains, automatically.

This list is similar to other computer lists in the Console, but it is specific to the
selected operator, letting you focus on one person at a time.

This dialog is available by clicking an operator from any Console Operator list and
selecting the Administered Computers tab.
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Console Operator: Issued Actions

The Issued Actions tab of the Console Operator document displays a filter/list of
all the Actions that have been deployed by the selected operator.

Console Operatorn: EvaluationUser =0
H"-..'.— Changes  Discard Changes I Reset Password 26 Remowve

| Details | Administered Computers @) | Issued Actions (3) |A55|gnad Roles (L) | Sites [.1?]'

3" Issued Actions (3) Tirme lasued State % Complete Mame
10/11/2011 11:54:12 AM Cpen 0.00% 10/1) Maozila Fi
10/11/2011 11:53:09 AN Open 0u00% [0/1) MS0E-041
10/11/2011 11:52:39 AM Open 0.00% /1) Adobe R

At the top of the dialog is the name of the operator. As with any Action list, you
can filter and sort it by various properties, including State (open, expired) and Site.
The current number of issued actions for this operator is displayed in the tab itself
for easy viewing.

This list is similar to other Action lists in the Console, but it is specific to the
selected operator, letting you focus on one person at a time. This interface also
allows you to stop an action if it hasn't completed. Right-click the action you want
to stop and select Stop Action from the pop-up menu.

This dialog is available by clicking an operator from any Console Operator list and
selecting the Issued Actions tab.

Console Operator List and Document

A list of Operators is displayed when you click Console Operators, or any of its
child nodes, from the Domain Panel navigation tree.

File Edit View Go Tools Help

‘! Back = Forward = | ® Show Hidden Content ¥ Show Non-Relevant Content

All Conten « Console Operaturiiear-:h Console Operators

=

A48

a3 Console Operators (3) Mame Master Operator  Last Login Time

By Master Ope don No 5/18/2010 9:45:04 PM
> g Siees (19) [ joe Ves 5/19/2010 6:55:49 PM
a2 & Wizards

‘ ken 5/9/2010 3:10:03 PM

|
Anti-Virus Definitior|
Ui“*mgw__r ‘}l‘ MHWBHX

A Console Operator document is displayed in the Work Area of the Console when
you click any item from this list.

-
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[ ievn Chimges Dincard Chunger | Beset Paswword 3¢ Bemeve

Deeteils | udminkstered Computess [0} | kuued dctions @) | Assigreed Fcles 1) | Siaes (L) | Computes Assignments

Cvarview

usert-IA0 S
Local Conaole Dpeimtor
1 Losgns Thw Hewn
) Adways allows Shes upes T log in
by sl this umer Ao losgi i whan thany are a mambs s of o least sna rals
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Mo~ Mo
Mo -u Yo
s -';-r: Yau
Yas [~ Yeu
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ho [~ Vea
Show Homa o | Showr Hore
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s [w] Vs
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At the top of the Console Operator document is the name of the operator. The tabs
underneath display at a glance how many computers are being administered by
this operator and how many actions this operator has issued.

The tabs in a Console Operator document include:

Details: A window outlining the permissions for this operator, including master
operator, showing other operator actions, permissions to create action, to lock
computers, to send refreshes to computers, to manage custom content and list
unmanaged assets.

You also decide to influence the ability of the operator to trigger restart and
shutdown as Post-Action or to include them in BigFix Action Scripts. Depending
on the configuration that you set for a specific operator for shutdown and
restart, the radio button in the Take action panel might be disabled for that
operator. This configuration has no effect on actions with type other than BigFix
Action Script.

You can also set permissions to access the BigFix Console and REST APL

Administered Computers: A typical filter/list window containing all the
computers under this operator's administration.

Issued Actions: Shows what Fixlet actions have been applied by this Console
Operator.

Assigned Roles: Lists those roles associated with this operator.
Sites: Lists those sites that can be administered by this operator.

To display this Console Operator list, click the Console Operators icon (or any of
its child nodes) in the Domain Panel navigation tree, then select an operator to
view. After making any changes, make sure to click the Save Changes button.
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Create Analysis

The Create Analysis dialog lets you deploy your own custom Analyses to monitor
and audit properties across your managed network. You can create an Analysis
from scratch or you can edit an existing custom Analysis by selecting it from the
list and choosing Edit > Edit Custom Analysis.

To create an original Analysis, choose Tools > Create New Analysis. The Create
Analysis dialog opens.

3y Creste Anslysis =N BN =<
MName: [Custom Analysis] Create insite: | Master Action Site -
Create in domain: | All Content -

Description | Properties | Relevance

Description

<enter a descrption of the analysis here>

® Click here to activate this analysis

¥ Automatically activate this analysis after it is created.

OK . Cancel

There are three items at the top to help you identify your Analysis:
* Name: Enter the name of your custom Analysis.

* Create in site: From the pull-down menu, select a site (typically the Master
Action Site) to host the Analysis.

* Create in domain: From the pull-down menu, select the Domain you want to
house the Analysis.

Beneath these data fields, there are three tabs:

* Description: Create a user-readable title and message to accompany the Analysis
you want to run. This is an HTML page, and you can use the text editing tools
at the top to adjust the look of your Analysis.

* Properties: Specify retrieved client properties for your Analysis. Click the Add
Property button, enter a name and a relevance clause. You can also specify an
evaluation period for this property.

* Relevance: Specify the target client computers for your custom Analysis using a
Relevance clause. The Analysis is applied to all computers where the Relevance
clause evaluates to TRUE.

At the bottom of this dialog is a check box:

* Automatically activate this analysis after it is created: Check this box if you
want to immediately propagate this Analysis when clicking the OK button.
Leaving this blank lets you describe your Analysis without actually activating it.
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You can create a new Analysis by selecting Tools > Create New Analysis, or by
right-clicking in the Analysis window and selecting Create New Analysis from the
context menu.

You can edit your existing custom Analyses by right-clicking on them and selecting
Edit from the pop-up menu.

Create Analysis Description Tab

The Description tab of the Create Analysis dialog lets you define the html page
for your custom Analysis.

4 Create Analysis ===
MName: [Custerm Anahysis] Create in site: | Master Action Site -
Creste in domain: | All Content -

Description | Properties [ Relevance

Description

<enter a descrption of the analysis here>

® Click here to activate this analysis

J Automatically activate this analyzis after it is created.

OK ._ Cancel

Enter the description of your custom Analysis in the first box. You can customize
the second box as well, but the existing text is quite standard.

You can create a new Analysis by selecting Tools > Create New Analysis, or you
can edit a custom Analysis by right-clicking it and selecting Edit Custom Analysis
from the context menu. To clone and edit an existing Analysis, first right-click it,
select Export from the context menu to save it, then select File > Import to bring it
back in for editing.
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Create Analysis Properties Tab

184

The Properties tab of the Create Analysis dialog lets you define the properties you
want to analyze.

,:] Edit Analysis
MNarme Custorn Analbysis Create in site:

Description | Properties | Relevance Create in domain: | Al Content |
Hame |  Add Property
IrtelCPU TS ———

| Remove Property
Name IntedCPLI
Relevance: axizcs cpu whose [manufacturer of it contains "Intel"™
Evaluate every |Every Report =
[¥] Automatically activate this analysis after it is created.
| oK | Cancel

This is the customized heart of the Analysis, and is not the same as the Properties
tab of the Fixlet, Task, or Baseline dialogs.

There are two buttons in the Property tab:

* Add Property. Click this button to add a new property to the Analysis. When
you do, the text areas below becomes editable and you can define the property.

* Remove Property. Highlight a retrieved property from this list to the left and
click Remove Property to delete this item from the Analysis.

After clicking the Add Property button, you must enter a Name for the property
and a Relevance statement to retrieve the information. For example, you might
want to retrieve the names of the administrators for each client. You might name
the property "Client Admins" and use a Relevance expression like "names of
administrators of client".

You can also set the schedule for the analysis from the Evaluate every pull-down
menu. The default is to update the property value whenever a report is requested.
But you can also set it to any regular period between 5 minutes and 30 days.

You can create a new Analysis by selecting Tools > Create New Analysis, or you
can edit a custom Analysis by right-clicking it and selecting Edit Custom Analysis
from the pop-up menu or from the Edit menu.
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Create Analysis Relevance Tab

The Relevance tab of the Create Analysis dialog lets you define a relevance clause
to determine the applicability of your custom Analysis to specific computers.

Mame BigFix Components Creste in site: | Master Action Site
Create in domain: | All Content -
Description | Froperties Relevance ——— =
This anahysis will be relevant on the following computers:
All computers
Computers which match the condibion below
@ Computers which match all of the relevance clauses below
1. version of client »>= "§.0" = -
2. true -| = .
| Autematically activate this analysic after it is created.
| |
1 Ok | Cancel

You can choose from three relevance options:

* All computers: This is the default choice and analyzes the properties you specify
on all of the IBM Endpoint Manager Clients in your network.

* Computers which match the condition below: When you select this choice, you
can select from several pre-defined properties to identify a subset of Clients for
analysis.

¢ Computers with match all of the relevance clauses below: This choice lets you
specify a computer with a custom relevance statement. This is the most powerful
of the available choices, and lets you easily narrow down the computers to
analyze.

You can create a new Analysis by selecting Tools > Create New Analysis, or you
can edit a custom Analysis by right-clicking it and selecting Edit Custom Analysis
from the context menu. To clone and edit an existing Analysis, first right-click it,
select Export from the context menu to save it, then select File > Import to bring it
back in for editing.
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Create Automatic Computer Group

186

This dialog allows you to create rules that automatically enlist specific computers

in a group.

-

Create Automatic Computer Group

==

Group name:  Tokyo Accounting

Create in sibe: | Master Action Site

Include computers with | all

| Create in domain: All Content

= | of the following properties:

?anatic-n

| Computer Mame

- lcnntains -

] acc.ﬂ

f._ [.curltains |

Tekyeo

o] |

It has the following parts:

* Computer Group Name: This is a text box to enter the name of your group.
This is listed in the name column of any computer group listing.

* Create in site: This is a pull-down menu listing the site you want to host the

computer group.

* Create in domain: This is a pull-down menu listing the domain you want to
host the computer group.

* Include computers with [any/all of] the following property: This option lets
you specify a condition that must evaluate to true before the computer becomes
a member of the group. If there is more than one condition, this option includes
a pull-down menu allowing you to use any or all of the conditions listed. Three
fields are used to define a condition:

— The retrieved property: select a property from the pull-down list containing
dozens of pre-defined retrieved properties. Note that there are two other
options at the top of this list.

- Select Relevance Expression from the top of the list, select is true or is
false from the relationship pulldown and then click the Edit Relevance
button to define a custom relevance expression to base your group on.

- Select Group Membership from the property list, select the desired
membership option, and then select a manual group from the pull-down

list to the right.

— The relationship: Select from the four available comparison operators:
contains, equals, does not contain, and does not equal. Depending on the
particular retrieved property, there might be other relationships available.

— The value: Enter a value to be compared to the value of the retrieved
property. If the comparison is true, the Baseline becomes relevant on the
specified computer. For example, to create a group that automatically enlists
Windows computers, enter OS contains Win.

There are two buttons used to edit the list of conditions:

— Plus (+): Click this button to add a new condition to the list. When there are
two or more conditions, notice that the radio button above includes a
pull-down menu allowing you to trigger on any or all of the conditions in the

list.
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— Minus (-): Click this button to delete the condition associated with it.

Click OK and enter your password to propagate the new Automatic Computer
Group to be listed in the Computer Groups tab.

This dialog is available by clicking Create New Automatic Group from right-click
context menu in the Computer Groups tab or select Tools > Create New
Automatic Group.

Create Custom Site

This dialog lets you name your own Custom Site.

N !
Create Custom Site n— lﬂ]

Please choose a name for the new Custom Site. Custom
Site names cannot be changed after they have been
created.

BigCorp Policy Site

QK | | Cancel

Enter the name of your site and click OK. This opens the Custom Site dialog,
where you can finish defining your site.

To create a custom site, select Tools > Create Custom Site.
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Create Fixlet or Task

188

The Create Fixlet and Create Task dialogs are similar and allow you to create or
customize a Fixlet or Task.

: Create Fidet == _'—|Fl @

Nome: | [EETTIEID Createin site: | Master Action Site -

: = Create in domain: | All Content -]
Description | Actions | Relevancel Properties | L

Description

<enter a description of the problem and the camrective action here>

Actions

© cnck'f.h:t!.cha deploy this action.

QK Cancel

There are several tabs to help you define or edit your Fixlet or Task.

* Description: Enter your descriptive text in this box. You can use the text

manipulation toolbar at the top of the dialog to enhance the formatting.

Actions: Define your action in this dialog. Use the buttons at the right to add,
delete, or change the position of the action. Below that is an area to customize
the properties of the action. Choose the Script Type from the drop-down menu.
Below that is a text box where you can enter a new action script or modify the
original. There are three check boxes you can use to modify the action:

— This action is the default action. Click this box to create a default action.

— Include action settings locks. Click the Edit box to the right of this check box
to customize the action setting locks, including start time, end time, day
exclusions, and more. This panel also includes failure and reapplication
behaviors.

— Include custom success criteria, which allows you to specify the conditions
that define the success of the action.

Relevance: Leave the default of applying to All computers, or click a different
button and enter a condition or a relevance statement in the dialog below. This
is how you target your Fixlet or Task to relevant computers. For more
information about the relevance language, see the Inspector Libraries.

Properties: Set the properties of your Fixlet or Task, including the category,
download size, date, severity, and more. You can also include the SANS
(SysAdmin, Audit, Network, Security) or CVE (Common Vulnerabilities and
Exposures) ID numbers.

You can create a custom Fixlet or Task by selecting Tools > Create New Fixlet or
Task, or you can edit an existing Fixlet or Task by right-clicking it from the List
Panel and then selecting Create Custom Copy from the context menu.
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Description Tab

The Description tab provides an English-language description of the selected
Fixlet, Task, Analysis, or Baseline.

Analysis BES Component Versions e B
ql..ﬂuﬂ'nralt ‘:hcl-f:-*.r Livate | # Edit ---,-E:l;pnl't Hide x:':l-'lll VE

Description | Details | Applicable Computers (5) |

Description
This analysis contains information about the different BES

component versions. This information is particularly useful after
performing BES upgrades.

after activating this analysis, you will see the following properties:

m

BES Client Version

BES Relay Version

BES Console Vearsion

BES Server Version

BES API Version

BES Web Reports Version

L I I B ]

® Click here to activate this analysis.

It typically provides one or more actions (in the form of links) that can be run to
install a patch, change a registry, update an application, run an analysis, and so on.

Click the link to deploy the action or analysis across your network. For Fixlet
messages, when an Action completes, the initiating Fixlet usually disappears
because the problem no longer pertains. Tasks, Baselines, and Analyses, on the
other hand, continue to stay activated until you terminate them.

This dialog is available by clicking a Fixlet, Task, Analysis, or Baseline icon in the

Domain Panel navigation tree, selecting an item from the List Panel, and clicking
the Description tab.
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Details Tab

190

The Details tab shows you the mechanics behind the selected Fixlet, Task,
Analysis, or Baseline object.

Task: Restart Service (g™
& Take Action~ | » Edit | Copy uExport | Hide Locally Hide Globally | 3¢ Remove

Description| Details | Applicable Computers (5) | Action History (0)

* Properties .
[ 447

Sita BES Suppornt

Catagory Common Tasks

Download Size =no download=

Source BigFix

Source D <Lnspecified>

Source Severty Low

It includes several sections describing various aspects of the Fixlet message:

* Properties: As seen above, this section lists various properties of the Fixlet, Task,
or Baseline, including Category, Download Size, Severity, and more. These
properties are defined manually when the object is created.

* Relevance: This section displays the Relevance expressions that are used to
determine the relevance of an individual Fixlet message or Task.
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Description  Details | Applicable Computers (&) Action History ()

| + Relevance

Relavance 1

=
version of client »= "5 1%

Relevance 2

* =
name of operating system does not
contain "Win%" AND name of operating ayvstem

- "HinME"™

Relevance 3

-
name of coperating system as lowercase Starts

wich "win™

This example has multiple statements that must all be true for the item to be
considered Relevant to any particular BigFix Client. For a Baseline, this is an
‘envelope’ expression that determines the overall relevance of the group. Only if
the group is applicable is the relevance of the constituent Tasks and Fixlets
analyzed. This is the core information for an Analysis, which evaluates the
Relevance expression and retrieves that value.

Actions: This section displays the code to be run if an action is deployed from
either a Fixlet or a Task.
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Description | Details | Applicable Computers (6) | Action History (D)

- Actions

Action1
Script Type BigFix Action 3cript

accion paramecer gquery "ServiceName™ with
deacription "Flease enter the service you would
like to reatart:" With default "<Enter Service
Hams>"

concinue if {existe service who=ze (Service name
of it am lowercase = (parameter ®Servicelame®
of action as lowercase) OR display name of it
as lowsrcass = [(parametcer "Servicelams" of
accion as lowercase))}

delete  appendfile
delece netguiec.bat

n

waithidden "{pachname of cliznc folder of
gice "BESSupporc®™ & "\Aun{uiet.exe™}"
netguiet.bat stop "{parameter "ServiceHame® of
action}™

delete netguiet.bat

Success Criteria

This action will be considered successful when all lines of the action
scrpt have completed successfully -

* Comment: This section lets you attach comments to the Fixlet, Task, or Baseline.

Description | Details | Applicable Computers (6) | Action History (0)

* Commenis
Comment Console Operator  Time Entered

Mo comments

n

Add Comment
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This dialog is available by clicking a Fixlet, Task, Analysis, or Baseline icon in the
Domain Panel navigation tree, selecting an item from the resulting List Panel, and

clicking the Details tab.

Edit Actions Tab

The Actions tab of the Creation/Edit dialogs lets you create Actions for your new

or customized Fixlet or Task object.

-
Y Creste Tazk e EP Y -

Narne: BES Server Setting: Throtile Outgeing Download Traffic

Descrption | Actions | Relevance Froperties |

Content ID Script Type Default Action
Action]l BigFix Action Scnpt
Action BigFix Action Script
Link3 URL
P il
Action Properties
Action Name  Actionl
Seript Type: BigFix Action Script -
Action Script:

s met stocp BESRootServer
BESRocotServer

o8 net ITArT

g

———
Createin site: | Master Action Site b
Create in domain: | All Content -
Custorn Settings Custarm Sucee Add
Delete
v Mave Down
This sction is the default saction
Include action settings locks
Include custom success criteria
__'L'!'.‘::‘. tleKBF5" with description “Flease

Cancel

The Actions you create here become the clickable links in the finished Task or
Fixlet, and they are deployed on the appropriate computers of your network. The
Actions are listed in their display order at the top of the dialog. To the right of the

list is a set of buttons:

* Add: Click this button to create a new Action. It creates a new numbered entry

in the top list and opens a blank text box for you to write your Action script.
* Delete: Select an item from the list and click this button to Delete it.

* Move Up: Moves the selected Action up in the list, meaning that it is displayed

earlier.

* Move Down: Moves the selected Action down in the list, meaning that it is

displayed later.

For each Action, you can edit the type, certain settings, and the script itself.
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Action Properties

Action Mame:  Action3 [#] This acticn is the default action

Seript Type: BigFix Action Script 2 [#] Include action settings locks
BigFix Action Script
Action Script: ﬁ;::lpleScrlpt |
- | sl
. // entqiURL |

DIncIude custom success criteria Edit...

Select an Action Script Type from the pull-down menu. Among the choices are:

* BigFix Action Script: This is a cross-platform scripting language, and is the
default scripting type.

* AppleScript: This is the scripting language of choice for managing Macintosh
computers.

* sh: This is shell script as used by a UNIX system.

* URL: This is a URL pointing to an appropriate script or informational web page.
When an Action is created as a URL, it is listed as a numbered Link.

There are some more properties you can use to modify any Action.

Action Properties

Action Mame:  Action3 [#] This action is the default action

Script Type: BigFix Action Script - [#]Include action settings locks

BigFix Action Script
AppleScript |
ch

[ Include custem success criteria Edit...

Action Script:

_ /{ entelyrL |

Check one or more of the following boxes to customize each action:

* This Action is the default Action: Check this box to make the selected Action
the default for this group of Actions. Default Actions must be failsafe and
simple, making it reasonable to launch them unattended or to group them for
simultaneous deployment.

* Include Action Settings Locks: Check this box to use custom settings and locks,
including display messages, users, execution behavior, and post-actions. Click
the Edit button to open the Action Settings dialog with a lock next to each item.
Click the locks to keep these values from being changed.

* Include Custom Success Criteria: Typically a Fixlet is designed so that
completing an Action makes it fail the initial Relevance test. Because this test is
typically triggered by a vulnerability, its failure indicates successful remediation,
therefore causing the Fixlet to disappear from the Console. However, you can
select other criteria to establish success by checking this box. Click the Edit
button to open the Action Success Criteria dialog and key in your alternative
criteria.

In the bottom text box, enter the actual text of the Action Script. The style varies
depending on the script type you chose in the previous section. Because they can
be potentially distributed to hundreds of thousands of computers, it is always
advisable to test and test again.
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This dialog is available by clicking the Fixlet, Task, or Baseline icon in the Domain
Panel navigation tree. Right-click an item in the resulting List Panel and select
Create Custom Copy from the context menu.

Alternatively, select the Create item you want from the Tools menu.

Edit Baseline

The Edit Baseline dialog. Baselines are groups of Fixlet messages, Tasks, and other
Baselines that you want to run with a single mouse-click.

] Edit Baseline = ==

AL C orp Accounting Createin site | Master Action Site

| T - Create in domain: | All Content -
Description Components | Relevance | Properties o

Description

This content is anented toward MyCorp's Accounting depatments I

Actions

L CEickL&L&'lm deploy this action group. |

-. CI_K [ Cancel

For example, a Baseline might be created to group all your application patches or
security issues together to ensure a common operating environment. You can create
a Baseline from scratch, or clone or edit an existing Baseline.

When you select this interface, you are presented with a dialog with three input
items at the top:

* Name: Enter the name of your Baseline.
* Create in site: From the pull-down menu, select a host site.

* Create in domain: From the pull-down menu, select a host domain.

Beneath these data fields, there are four tabs:

* Description: Create a user-readable title and description for the Baseline you
want to deploy.

* Components: Specify the components, namely the Fixlet messages, Tasks, and
other Baselines, that you want to group into this Baseline.

* Relevance: Create a relevance clause to target this Baseline to just the subset of
computers you want. Because each component of your Baseline has its own
Relevance clause, the default Relevance is set to TRUE.

* Properties: Specify certain properties for your Baseline, including category,
source, severity, and date.

To create a new Baseline from scratch, select the following:
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* Tools > Create New Baseline

You can also customize an existing Baseline by selecting it from any Baseline list
and then choosing:

* Edit > Create Custom Copy

Alternatively, right-click in a Baseline list and select Create Custom Copy or
Create New Baseline from the context menu. Similarly, you can edit an existing
custom Baseline by selecting Edit Custom Baseline from the right-click context
menu.

Edit Components Tab

196

The Components tab of the Edit Baseline dialog lets you specify a group of Fixlet
messages and Tasks that you want to add to your Baseline.

_] Edit Baseline ==

Name: Client Baseline Creste in site | Master Action Site

= ~ Create in domain: | All Content -
Description Components | Relevance | Properties .

Component Group 1 [edit na

3 B.Es Cll!.l'll- _Semng: Relay Selection Controls Mo Achion Selecied = o

» BES Client Setting: Enable Debug Logging

Mo Action Selected [x]

ba ab a

b - 2
E-E.S Cllel'lt. Setting: Communication Method No Action Selected  ~ e
& RER Nliant CGattinn: | nrk NMamnutar - i
Find... ] v L 1B components in baseline
. OK [ Cancel

Click the link to add components to group and then select Fixlets, Tasks, and other
Baselines to place into your group. Use the edit name link to name the group. You
can place all your components into a single group or click the add new component
group link to add structure to your Baseline. Click the red X to delete the
associated component, and use the up (*) and down (v) arrows to change the
order of the components in the list.

Check the box next to Use custom action settings if you want to modify the
Baseline Action settings. Click the set action settings link to open the Action
Settings dialog.

The components of a Baseline are copies of the original Fixlet or Task, not pointers.
As such, if the underlying Fixlet or Task changes, the Baseline might become out of
sync with the original. If this happens, the message Source Fixlet differs is shown
in the component listing.

At the bottom of this dialog, there is a Find command that opens a dialog for you
to enter a search string and options such as match whole word, match case, and
search direction. It allows you to easily search through the components of your
Baseline.
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There is also a Sync All Components button. This forces all of your Baseline
components to sync up with the latest versions of their sources, in case they have
changed.

To create a new Baseline from scratch, select the following:
* Tools > Create New Baseline

You can also customize an existing Baseline by selecting it from any Baseline list
and then selecting:

* Edit > Create Custom Copy

Alternatively, right-click in a Baseline list and select Create Custom Copy or
Create New Baseline from the context menu.

Edit Computer Settings

The Edit Computer Settings dialog allows BigFix Console operators to change
certain computer attributes on a single or specified set of computers, including
locking, making the client a Relay, pointing to Relays, and creating custom settings.

Note: If you select multiple targets, then you select their settings, and modify the
value of the password in some of their fields, for each target the product will
manage the modification according to what is supported by the level of the Client.

Edit Computer Settings E
Settings | Target [ Execution | Users :Mes;agﬂ

Change the following settings:

Locking Status

Tiwoli Endpeoint Manager Relay 5

Primary Tivoli Endpoint Manag:

I I anag

Secondary Trvoli Endpoint Man
anager Serve

Cusbom Setting

i. oK l Cancel

There are five tabbed dialogs on this panel to target and customize the settings for
a selected group of Clients:

* Settings: Displays a group of controls to edit computer settings, such as the
locked status, relays, and custom variables.

* Target: Displays a filter/list of computers that can be edited, filtered, sorted, and
grouped for specifically targeted settings.

* Execution: As with other Actions, you can limit the activation of the settings to
any schedule, keeping in mind that the Action might take some time to deploy.
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When applied, the settings remain until removed. You can also specify certain
user interactions and add extra targeting based on the contents of retrieved
properties.

* Users: Allows you to specify whether or not you want a user to be logged on
before activating the settings.

* Messages: Allows you to issue a message to the BigFix Client before activating
the settings.

When multiple computers are selected, this dialog is available by right-clicking and
selecting Edit Computer Settings from the context menu (or select Edit Computer
Settings from the Edit menu).

Edit Description Tab

The Description tab of the Creation/Edit dialogs lets you describe your new or
customized Fixlet, Task, Analysis, or Baseline object.

* Enter a custom Description for the body of your descriptive message. Click the
description in the HTML page to modify it.

* Below the Description box is the text describing the Actions you can attach to
this Fixlet, Task, or Baseline. The Action is a clickable link in the Description
page. Click the text to modify it, although the default text is usually sufficient.

Note: For an Analysis, this link activates the retrieval of the specified
Properties. Activation involves the running of an Action, but in the case of an
Analysis, it is a benign Action that creates a property that can be read by the
Console.

This dialog is available by clicking the Fixlet, Task, or Baseline icon in the Domain
Panel navigation tree. Right-click an item in the resulting List Panel and select the

appropriate Create option from the context menu.

Alternatively, select the Create item from the Tools menu.

Edit Fixlet Message

198

The Edit Fixlet Message dialog allows you to create your own custom Fixlet
messages. You can create a Fixlet message from scratch or clone an existing one
and customize it. To create an original Fixlet, choose Tools > Create New Fixlet.
You are presented with a dialog with three text boxes at the top:

* Name: Enter the name of your custom Fixlet message.

* Create in site: From the pull-down menu, select the BigFix site you want to host
it.

* Create in domain: From the pull-down menu, select the Domain you want to
host this Task.

Beneath these data fields, there are four tabs:

* Description: Create a user-readable title and description for the Fixlet you want
to deploy. If you are cloning an existing Fixlet, the original title and description
is the default. This is an HTML page, and you can use the toolbar at the top to
alter fonts and formatting.

* Actions: Specify the actions for your custom Fixlet to run.
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* Relevance: Create a relevance clause to target this Fixlet to a subset of
computers you choose. For a cloned Fixlet, the original relevance clause is the
default. You can replace or modify the relevance clause to suit your network
needs.

* Properties: Specify certain properties for your Fixlet, including Category,
Download Size, Source, Severity, and Date.

To create a new Fixlet message from scratch, select the following:
* Tools > Create New Fixlet

You can also customize an existing Fixlet message by selecting it from any Fixlet
list and then selecting:

* Edit > Create Custom Copy

Alternatively, right-click in a Fixlet list and select Create Custom Copy or Create
New Fixlet Message from the pop-up menu.

Edit Processing Instruction

The Edit Processing Instruction dialog lets you write a Relevance Expression that
can be embedded into the text portion of a Fixlet, Task, Analysis, or Baseline.

' i’
Edit Processing Instruction

concatenation ”, " of (names of bes filters) -

(0] l [ Cancel

You can enter the expression as straight text, HTML, or Presentation (XML) style.

This dialog is available whenever you create a new or custom Fixlet, Task,
Baseline, or Analysis. In the description tag, enter your text, and then from the
toolbar at the top, click the magic wand . This opens the Edit Processing
Instruction dialog.
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Edit Properties Tab

200

The Properties tab of the Creation/Edit dialogs lets you assign certain important
properties to your new or customized Fixlet, Task, or Baseline object.

| Create Task Y e
MName: TROUBLESHOOTING: Restart the BES Client Service Createin site: | Master Action Site =
T T C d ARG 13 -
Description | Actions | Relevance  Properties sl CfEED
Categony: Troubleshooting
Download Size: a
Source BigFix
Source |0 <Unspecified=
Source Release Date: 1071975004
Source Severity: Low
CVEID: |
SANE ID: I
i ok ] Cancel

There are a series of text fields that you can use to describe the various possible

properties:

» Category: There are many categories you can file your Fixlet, Task, or Baseline
objects under, including the standard ones such as Setting, Update, Support, and
more. If you want, you can create new settings also for your particular
installation.

* Download Size: If a download is associated with your Fixlet, Task, or Baseline,
you can enter the size here. This allows you to sort, filter, and keep track of the
bandwidth requirements of your various custom-designed objects.

* Source: This is the source of the Fixlet, Task, or Baseline. For a custom object,
this is typically a name chosen by the BigFix Administrator, usually Internal.

¢ Source ID: This is an ID associated with the source described above. For an
Internal source, the ID is typically blank.

¢ Source Release Date: Enter the release date of this Fixlet, Task, or Baseline to
manage these objects by age.

* Source Severity: Enter the severity of the Fixlet, Task, or Baseline, typically from
a list including Low, Moderate, Important, and Critical.

* CVE ID: Enter the ID for the Common Vulnerabilities and Exposures standard,
if any.

* SANS ID: Enter the ID for the System Administration, Networking, and
Security standard, if any.

This dialog is available by clicking the Fixlet, Task, or Baseline icon in the Domain
Panel navigation tree. Right-click an item in the resulting List Panel and select

Create Custom Copy from the context menu.

Alternatively, select the Create item from the Tools menu.
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Edit Relevance Tab

The Relevance tab of the Creation/Edit dialogs lets you create a relevance
expression to fine-tune the deployment of your custom Fixlet, Task, Analysis, or
Baseline object.

o ——— ==
Create Task . R _ M ——— S i
Hame: TROUBLESHOOTING: Restart the BES Client Senvice Createin site: | Master Action Site -|
- t Create in domainc | All Content |
Descrption | Actions | Relevance | Properties ! i
This task will be relevant on the following computers:
All computers
Computers which match the condition belew i
@ Computers which match all of the refevance clauses below §
o — 1
l. varsion of client »= "5.0" ] |l
2. name of sperating aystem doss not Sontaln "Wind® AND name of oparating system ! j ‘L,
= "inME"
LI
3. name of operating system as lowercase starts with "win® | G} |
|
i
N T—areT— [ 1
i 0K | Cancel |

There are several ways to specify a set of computers:

* All computers: The default is to include all the networked IBM Endpoint
Manager Clients for this particular Fixlet, Task, Analysis, or Baseline --
regardless of relevance.

* Computers that match [any/all of] the conditions below: This option lets you
specify a condition that must evaluate to true before the computer triggers the
Fixlet, Task, Analysis, or Baseline.

Name TROUBLESHOOTING: Restart the BES Client Senvice Crestein site: | Master Action Site -

Create in domain: | All Content E

Description | Actions | Felevance Properties
This task will be relevant on the following computers:

All computers .
@ Computers which match | any ¥ | of the conditions below

Computers which match all of the relevance clauses below

|L|:||:ul.||:|n = | |contains vl Ttaby

|Gr0up Membership 'j jl:- member of - | Ewm group

| Concd |

If there is more than one condition, this option includes a pull-down menu
allowing you to select any (ORing the conditions) or all (ANDing the
conditions). Three fields are used to define each condition:

— The retrieved property: select a property from the pull-down list containing
the pre-defined retrieved properties. Note that there are two other options at
the top of this list.

- Select Relevance Expression from the top of the list, select is true or is
false from the relationship pull-down list and then click the Edit Relevance
button to define a custom relevance expression to base your group on.
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- Select Group Membership from the property list, select a membership
option and then select a manual group from the pull-down list to the right.

— The relationship: select from the four available comparison operators:
contains, equals, does not contain, and does not equal. Depending on the
particular retrieved property, there might be other relationships available.

— The value: Enter a value to be compared to the value of the retrieved
property. If the comparison is true, the Baseline becomes relevant on the
specified computer. For example, to create a group that automatically enlists
Windows computers, enter OS contains Win.

There are two buttons used to edit the list of conditions:

— Plus (+): Click this button to add a new condition to the list. When there are
two or more conditions, notice that the radio button above includes a
pull-down menu allowing you to trigger on any or all of the conditions in the
list.

— Minus (-): Click this button to delete the condition associated with it.

* Computers on which the relevance clause below is true: Click this button to
enter a custom Relevance expression to be evaluated on each IBM Endpoint
Manager Client.

Mame: TROUBLESHOOTING: Restart the BES Client Service Creste in site: | pdaster Action Site =

Create in domain: | All Content -

Description | Actions | Relevance | Properties

This task will be relevant on the follows ng computers:
All computers
Cemputers which match | any * | of the conditions below

@ Computers which match all of the relevance clauses below

1. version of client »>= "5.0" s |k
2. name of operating system doss not contain "Win%" AND name of operating aystem ! [=f |
| - M
|
i 3. nams of opearating system as lowsrcass starts with "win” |
L
I
I QK Cancel

If the relevance expression evaluates to true, the Fixlet, Task, or Baseline
becomes relevant to that particular client and the Console reflects that status. In
the case of multiple relevance statements, they must all be TRUE (they are
ANDed together) for the Task or Fixlet to become relevant.

A complete discussion of relevance expressions is beyond the scope of this
documentation. For more information, see the Relevance Language Reference and
the various Inspector Guides. For some instructive examples, make custom
copies of available Support Fixlets and examine their relevance statements.

This dialog is available by clicking the Fixlet, Task, Analysis, or Baseline icon in the
Domain Panel navigation tree. Right-click the item in the resulting List Panel and

select Create Custom Copy from the context menu.

Alternatively, select the Create item from the Tools menu.
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Edit Script Element

The Edit Script Element dialog lets you create a small script to accompany a new

or custom Fixlet, Task, Baseline, or Analysis.

Edit Script Element - D

var isEvansOrlater =
o7
relevance if (exists property "datastore inspectors") then (True) else (False)
f»' == True' ¥ truefalse
try {if (isEvansOrLater)
{document.getElementByld
("relTag25cript8").innerHTM L= Relevance
('if { exists ( fixlet 390 of bes site whose (name of it equals "BES Support"))) then
{ (iformat
ne?
relat {0} {1} relevant computers) -

m

OK ] | Cancel

Enter the text of your action, and click OK. For more information about Action
scripts see the Action Language Reference.

This dialog is available whenever you create a new or custom Fixlet, Task,
Baseline, or Analysis. In the description tag, enter your text, and then from the

toolbar at the top, insert the Script icon . This opens the Edit Script Element

dialog.
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Edit Settings for Computer

The Edit Settings for Computer dialog allows the IBM Endpoint Manager Console
operator to alter the settings for a selected computer. (For more settings, or to
apply settings to multiple computers, see Edit Computer Settings).

Edit Settings for Computer "BIGDOG"

Locked

. Assign Tivoli Endpeint Manager Rela

Primary Tiveli Endpoint | Main Tivoli Endpoint Manager Server hd |
Secondary Tivoli Main Tivali Endpoint Manager Server - |
Custom Settings:
MName : Value Sike Add
_BESClient_LastShutdow... Service manager shutdown request Lacal
_BESClient_RelaySelect F... Local
BESClient_RelaySelect_T... Local
_BESClient_UploadMana... C:A\Program Files (x86)\BigFix Enterprise\BE... Local
_BESClient_UsageManag... 1 Lacal
_BESClient_UsageManag... 1 Lacal
_BESClient_UsageManag.., +:acrobat executicok e Local

BESClient_UsageManag... :masterops;acrobat.exemasteropsoutlock...  Local

More Options... | QK Cancel

There are several ways you can customize the settings of a computer:
* Locked. Check this box to lock the computer.

» Assign Relays Manually. Relays can be automatically assigned. Clear this box to
select automatic discovery (the recommended setting). If you want to manually
specify a particular relay for this IBM Endpoint Manager Client, check this box
and select the relays you want from the pull-down menus below.

— Primary Relay Server: Select the name of the primary Relay from the
pull-down menu. The selected computer now points to this relay for Fixlet
downloads instead of connecting directly to the IBM Endpoint Manager
Server.

— Secondary Relay Server: Select the name of the secondary Relay from the
pull-down menu. If the primary relay is unavailable, then this secondary
relay takes over the job of providing Fixlet downloads.

Custom Settings: This list box contains custom named variables that can be
assigned to each computer. This is a valuable technique for organizing a network
of computers, and can help to identify individual computers as well as groups. The
list of settings in this box can be sorted by clicking the appropriate header:

* Name: This column contains the assigned custom variable names, for example,
"depts."

* Value: This column lists the values of the named variables, for example, "human
resources."

* Site: As applied by the Console Operator, these named variables are a part of
the "local" site. These variables can also be set by other Fixlet sites, in which case
their site name is shown here.
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Note: The values assigned to passwords using the settings _Enterprise
Server_ClientRegister_ProxyPass and, for Linux only,
_BESServer_Database_Password, are encrypted, if the computer is a Windows
system, or obfuscated, if the computer is a Linux system, immediately after you
click the OK button.

There are three buttons to the right of the list:
¢ Add: Click this button to add a new custom variable to the list.
* Delete: Click this button to delete the selected variable from the list.

* Edit: Click this button to edit the selected named variable. This places the cursor
in the value field of the chosen setting for editing.

Finally, there is a More Options button at the bottom of the dialog, which expands
on these functions and opens the Edit Computer Settings dialog.

This dialog is available by selecting the Computers icon in the Domain Panel
navigation tree, right-clicking a single computer from the resulting List Panel, and
selecting Edit Computer Settings from the pop-up menu.

Edit Task

The Edit / Create Task dialog allows you to create a Task from scratch or clone an
existing Task and customize it.

7 Creste Task =8 EoN ==
Name: Adabe Flash Player - BES Consolel Creste in site: |Maﬂa Action Site -

Create in domain: lﬂull Content -

Description :Aqtiong l Relevance | Ptoperties_

Description

It is recommended that computers running the BES Console have the latest version of
Adobe Flash Player installed for Internet Explorer. Adobe Flash Player needs to be
installed for Internet Explorer to use many dashboards and wizards in the BES Console.

Actions |

{Limk 1)

® Click{here to go to the download page for Adobe Flash Player for Intemet Explorer |

{Link2)

® Click] ﬂﬂihor mora information regarding the BES Console and Adobe Flash Player. |

0K [ Cancel

To create an original Task, choose Tools > Create New Task Message. You are
presented with a dialog with some text boxes at the top:

* Name: Enter the name of your custom Task.

* Create in site: From the pull-down menu, select the site you wanr to host this
Task.
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Create in domain: From the pull-down menu, select the Domain you want to
host this Task.

Beneath these data fields, there are four tabs:

Description: Create a user-readable title and description for the Task you want
to deploy. If you are cloning an existing Task, the original title and description is
the default. This is an HTML page, and you can use the toolbar at the top to
alter fonts and formatting.

Actions: Specify the actions for your custom Task to run.

Relevance: Create a relevance clause to target this Task to a subset of computers.
For a cloned Task, the original relevance clause is the default. You can replace or
modify the relevance clause to suit your network needs.

Properties: Specify certain properties for your Task, including Category,
Download Size, Source, Severity, and Date.

To create a new Task from scratch, select the following:

Tools > Create New Task

You can also customize an existing Task by selecting it from any Task list and then
choosing:

Edit > Create Custom Copy

Alternatively, right-click in a Task list and select Create Custom Copy or Create
New Task from the pop-up menu.

Enter Private Key

The Enter Private Key dialog requests a password.

P

Private Key Password I,%,

Private Key Password

QK | | Cancel

Type in the publisher password that you were given by your Site Administrator.
This dialog is displayed whenever an action is deployed, to ensure that only
authorized personnel are allowed to update computers in the network.
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Execution Tab
The Execution tab can be found in various action dialogs. In this tab you can set
the schedule, time interval, and the recovery options that must be satisfied when

deploying the action.

Use the settings in this tab to ease the traffic load in your network.

& Take Action Q@%

Mame: | Install BES Server Plugin Service

Create in domain: | All Content i v

Preset: IDefauIt | % l ["1shaw only personal presets

Constraints ; ) e 7
[ starts on |02 lat | | | dient local ime | v]
Ends on il_D_fD?leB_i_\Lh at 5-21, 53.28 E | dientlocal tme
[] Run between | | and | 55, : dient local ime
[ run enly on Sun = ed || Th z Sat dient local time
[ Run only when

Behavior
[ on failure, retry times
[] reapply this action

bt eapplic:
rea s
[ start client downloads before constraints are satisfied
[ stagger action start times over - minutes to reduce network load

I Ok ] ’ Cancel ]

This tab is available from several different dialogs:

e [“Take action” on page 240
pag

* [“Take multiple actions” on page 242|
+ [“Action Settings” on page 141|

+ [“Edit Computer Settings” on page 197|

In the Constraints section of this dialog you can schedule actions and restrict the

target computers, in particular:

Starts on [date] [time]
Defines a date and time when the action can first be run. You can choose
from Local Client time or Universal time from the pull-down menu. The
choice you make here affects all of the scheduling constraints. Note that
UTC is only available for version 8.0 or later.

Ends on [date] [time]
It defines the action’s expiration date and time.
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Run between [time] [time]
Defines a period of time during which the action can be run.

Note: Pending actions are run even if the time period has expired. For
example a baseline might start according to the specified time limit and all
the actions it contains are run independently from the specified time
period during which the actions can be run.

Run only on [Sun,Mon,Tue,Wed, Thu,Fri,Sat]
Defines specific days of the week to run the action.

Run only when [Property] [Operator] [Value]
It filters clients by their retrieved properties. Select a Property and an
Operator from the pull-down menus, then select a value for comparison.
The value entered must form a valid relevance expression.

In the Behavior section of this dialog you can manage failed actions and recurrent
relevance. The BigFix Client can retry any action that is unsuccessful and reapply
any action that succeeds and then subsequently fails. This capability allows you to
automatically implement continuing policies minimizing the network load and the
operator intervention. You can set the following behaviour:

On failure, retry XX times
It sets the maximum number of retries upon action failure. The default
value is 3 retries. After selecting this checkbox, choose one condition
among the following:

Wait XX between attempts
The Client waits a time interval of XX before retrying the action.
The default time interval is 1 hour.

Wait until computer has rebooted
The Client waits to reboot before rerunning the action.

Reapply this action
It applies again the action if the target is no more compliant to the policy
set by the relevance expression. After selecting this checkbox, choose one
condition among the following;:

Whenever it becomes relevant again
It reapplies the action as soon as the relevance expression evaluates
again to true

While relevant, waiting XX between reapplications
Instead of immediately reapplying the action upon relevance, it
specifies a period of time to wait between attempted
reapplications.

Limit to XX reapplications
It continues to apply the action the given maximum number of
times, while it remains relevant. The default values is 3 times. It
counts the number of attempts after the original, so a limit of 3
actually involves 4 attempts.

Start client downloads before constraints are satisfied
The software downloads starts before the Client has satisfied the execution
constraints. Select this option if you want to ensure that the download is
available for execution as soon as the desired time frame begins.

Stagger action start times over MM minutes to reduce network load
It forces the program to space out the running of actions. This option can
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reduce the load on the network, in the case of bandwidth-intensive actions,
and is useful to help relays in effectively servicing hundreds of attached
Clients.

Find

You can find information in any of the lists (Fixlets, Tasks, Actions, and so on.)
whenever the focus is on that list. To do this, you create a Find Filter. For example,
to find a particular word in the Fixlet list, click anywhere in the Fixlet List Panel
and press Ctrl-F (or select Find from the Edit menu).

Create Filter . &J
MName: <Ad hoc filter>

Visibility: [] Available to all operators

Include lFixlets v] with [all v] of the following properties:

Name v | [contains - B
Visibility +| | equals v | visibe 5

| Create | | cancel ]I

\, = — e = —_— ==y

There are several sections in the Filter dialog:
Name: Provide a name for your Find Filter in the Name box.
Visibility: This box lets you keep the Filter to yourself or share it with other users.

Include: This section lets you define the scope of the Find. Choose from Fixlets,
Actions, Tasks, or any of the other main categories of content. You can choose to
include all (AND the properties) or any (OR the properties) of the following items.

Two properties have been pre-arranged for you, but you can add or delete from
these default choices. As with other property choices using IBM Endpoint Manager,
there is a {field} {operator} {search string} triad to define. Here the defaults allow
you to select a Name containing a value and a Visibility. Because Fixlets, Tasks,
and Analyses can be hidden, the visibility field allows you to search through these
items depending on whether they are Visible, Locally Hidden, or Globally
Hidden.

When you have finished defining your Find Filter, click the Create button. Your
custom filter is placed in the All Content Domain, under the Custom Filters folder.
To make changes, right-click it and select Edit from the context menu.

This dialog is available by selecting one of the main content categories (Fixlet

Messages, Tasks, Actions, and so on.) the icon in the Domain Panel navigation tree
to establish the focus, then pressing Ctrl-F or selecting Find from the Edit menu.
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Fixlet and Task: List and Document

210

A list is created whenever you click Fixlets and Tasks from the Domain Panel

navigation tree.

File Edit View Go Tools Help

4= Back v P Forward + | # Show Hidden Content +" Show Mon-Relevant Content | aRefrﬁh Console

[on, Yo

[ ﬁ Custom Content
E Custom Filters

All Copten 4 Fixlets and Tasks |Search Fixlets and Tasks

4 [} Fixlets and Tasks (75) Mame 2 Applic.. | Ope... Category

. : _ J TROUBLESHOOTING: Run BES Client Diagnostics 6/6 0 Troubleshooti..

& [ Fixlets Only (18) : .

@ Tasks Only (57) TROUBLESHOOTING: Upgrade InstallShield 11 L. 4/6 0 Troubleshooti.. ™

> B
% @ B s ) Version of Dbmslpcn.dll May Cause Handle Lea... 1/6 0 Support »

- Windows Install rvice Is Disabled 1/6 0 Setting '
[ @ Analyses (27)
b @’ Actions (8) Windows Secyfity: MBSA 2.2 - Install (x54) 1/6 0 Configuration
b £ Dashboards Windows fcurity: Microsoft Windows Malicio.. 1/6 0 Deploy
- E Wizards o | L T |

[ @ Computers (6)

i wﬁl

This list incorporates both Fixlets and Tasks, which you can filter by

Fixlet: Version of Dbmslpcn.dll May Cause Handle Leak on BES Client/Server Components
l{}’T Action~ | » EditLiCopy [# Export | Hide Locally Hide Globally | 3¢ Re
"’" “»’w— \""J\ M"v

opening the

icon and clicking any of the child nodes beneath it. The List Panel on the right
now contains all the currently relevant Fixlets and Tasks, narrowed down by the
filters. A Fixlet or Task document is displayed in the Work Area of the Console
when you click any item in the list. It displays a description and typically a set of

links to deploy Actions.

Fixdet: Version of Dbmslpcn.dll May Cause Handle Leak on BES Client/Server Components

o 0

&7 Take Action= | » Edit | Copy ' Export | Hide Locally Hide Globally | 3¢ Remove

Description | Details | Applicable Computers (1) | Actien History (0)

| Description

the BES Chent, FIllDB, and/or GatherDB Services to leak handles.

Important Note: There have been reports of issues caused

in a test environment pror to use in a production envircnment.

i Actions
L Cdisable the "Shared Memory Met-Librany'.

Client Met-Libraries manually.

by disabling the "Shared Memory Met-Library' setting. In particular,
the firewall service may no longer start on computers running ISA
Server 2004. Please take extra caution to qualify this setting change

The listed computers have a version of dbmslpcn.dil that may causs

To

resolve this issua, use the action below to set a registry key value
and disable the 'Shared Memory Net-Library’ for SQL Server client.

m

® Click here for more infarmation fram Microsoft on how to configure SQL Semver
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Fixlet and Tasks have the same basic tools and tabs available because they are
similar objects. The main difference between the two is that a Fixlet is triggered by
a vulnerability, whereas a Task is designed for ongoing maintenance. Both of them
use Relevance clauses to target client computers and both use Action scripts to
accomplish their goals. You can get a separate listing of each by clicking the All
Tasks or All Fixlets node in the navigation tree.

At the top of each document you find the name of the Fixlet or Task. Beneath that
is a toolbar containing the following tools:

Take Action: This tool provides a pull-down menu of Actions. Select an action
from the menu to deploy it to your network.

Edit: Lets you edit the Fixlet or Task. This tool is only available for custom
Fixlets or Tasks.

Copy: Lets you copy or clone the Fixlet or Task to customize what it does.

Export: Allows you to export the Fixlet or Task for editing in an external editor,
or for copying to another Console or deployment.

Hide Locally: Hides the Fixlet or Task on this version of the Console.
Hide Globally: Hides the Fixlet or Task on all networked Consoles.
Remove: Deletes this Fixlet or Task (only available for Custom Fixlets or Tasks).

There are several tabs for this document. They include:

Description: An HTML page describing the Fixlet or Task and a set of Actions
(implemented as links) that address the problem described. You can search any
of the HTML interfaces in the Console by pressing Ctrl-F and then entering your
search string.

Details: An HTML page describing the Properties, Relevance clauses, and Action
scripts associated with the Fixlet or Task. At the bottom of the page is a text box
to enter a comment to be attached to the message.

Applicable Computers: Shows which subset of computers is targeted by the
Action.

Action History: Shows the history of any Actions that were invoked by this
Fixlet or Task.

To display a Fixlet or Task list, click the Fixlets and Tasks icon in the Domain
Panel navigation tree.

A Fixlet or Task document is opened whenever you open an item in the resulting
list.
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Fixlet List and Document

A list is created whenever you click Fixlets and Tasks from the Domain Panel
navigation tree. This list incorporates both Fixlets and Tasks, which you can filter
by opening the Fixlet and Tasks icon and clicking All Fixlet Messages beneath it.

File Edit View Go Tools Help ‘IP
%= Back ~ WP Forward ~ | # Show Hidden Content +") Show Mon-Relevant Content {?'Refrﬁh Conscle
All Content 4 Fixlets Only Search Fixlets O
4 _% Fixlets and Tasks (75) MName Applic...
; , Skype 5.1 Available 1/6 0 Up
iy Fixlets Onl
4 @ ixlets Only (1 oy BES Quick Reference - Evaluation 1/6 0 Supf..
b B By Site Versien of Dbmslgen.dil May Cause Handle Lea... 1/6 0 Sup’
OFFICE: Office Deployment Control -- Init...  4/6 0 Setti
i E5j By Category
» 5 By Source Windows Ingller Service Is Disabled 1/6 ] Setti
b ﬁ By Source Release D Adobe Regder 9.4 Available 1/6 0 Sen{
B @ Tasks Only (57) Apple iTunes 10.0.1.22 Available - Windows XP... 1/6 0 Secir,
B [E Baselines (3] Mozilla Firefox 3.6.12 Available (Superseded) 1/6 0 Sec
b @ Analyses (27) M509-035: Vulnerabilities in Visual Studic Activ.. 1/6 0 Se

The List Panel on the right now contains all the currently relevant Fixlets. A Fixlet
document is displayed in the Work Area of the Console when you click any
message in the list. As well as a description, it includes clickable links called
Actions.

Fisdet: Version of Dbmsipcn.dll May Cause Handle Leak on BES Client/Server Components [ =]

47 Take Action~= | » Edit | Copy ' Export | Hide Locally Hide Globally | 3¢ Femove

Description | Details | Applicable Computers (1) I Action History (0)

| Description

The hsted computers have a version of dbmslpcn.dll that may causs
the BES Client, FillDB, and/or GatherDB Services to leak handles. To
resolve this issue, use the action below to set a registry key value
and disable the 'Shared Memory Net-Library' for SQL Server client,

Important Note: There have been reports of issues caused

by disabling the "Shared Memory Met-Library' setting. In particular, 3
the firewall service may no longer start on computars running ISA
Server 2004. Please take extra caution to qualify this setting change
in a test environment prior to use in a production envircnment.

i Actions

L] Cdisable the "Shared Mamory Met-Librany'

® Click here for more infermation from Microsoft on how to configure SQL Server
Client Met-Libraries manually.
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At the top of the Fixlet document you find the Fixlet name. Beneath that is a
toolbar containing the following tools:

e Take Action: This tool runs the default action of the Fixlet.

* Edit: This option lets you edit the Fixlet. This tool is only available for custom
Fixlets that you created yourself.

* Copy: This option lets you copy or clone the Fixlet to customize what it does.

* Export: This tool allows you to export the Fixlet for editing in an external editor.
* Hide Locally: Hides the Fixlet on this version of the Console.

* Hide Globally: Hides the Fixlet on all Consoles.

* Remove: Deletes this Fixlet (only available for Custom Fixlets).

There are several tabs in a Fixlet document. They include:

* Description: An HTML page describing the Fixlet and a set of Actions
(implemented as links) that address the problem described. You can search any
of the HTML interfaces in the Console by pressing Ctrl-F and then entering your
search string.

* Details: An HTML page describing the Properties, Relevance clauses and Action
scripts associated with the Fixlet. At the bottom of the page is a text box to enter
a comment to be attached to the Fixlet message.

* Applicable Computers: Shows which subset of computers is targeted by the
action.

* Action History: Shows the history of any actions that were invoked by this
Fixlet message.

To display a Fixlet list, click the Fixlets icon under the Fixlets and Tasks icon in
the Domain Panel navigation tree.

A Fixlet document is opened whenever you open an item in a Fixlet list.

Import Content

The Import dialog allows you to import .bes files that you exported or that were
sent to you by another operator.

IBM Endpoint Manager files might contain groups of Fixlet messages, Tasks,
Actions, or Baselines. When you open them, a Create dialog is displayed, together
with the expected features for each content type. For more information, see the
associated creation dialogs for the selected content.

This dialog is available by selecting Import from the File menu.

Launch Web Reports

The Web Reports dialog provides access to network information, which is collected
from the BigFix Servers and aggregated into a set of HTML reports. These include
summaries of the history and status of Fixlet messages and Actions across
extended networks of computers. These reports can be used to track software
deployments and compliance across a global network of independent LANs. To
start, select Tools > Launch Web Reports.

Web Reports is a stand-alone program that is not described in this Guide. For more
information, see the Web Reports Guide.
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This dialog is available by selecting:

Tools > Launch Web Reports.

Main Console Window

214

The Main Console Window has a panel on the left containing buttons and
navigation trees called the Domain Panel. Choose an item from the Domain Panel
to open the related List Panel on the right. From this list, specific items can be
opened in the Work Area below. Here are the main parts:

Domain Panel: This panel provides a high-level view of the IBM Endpoint
Manager content, allowing you to quickly subdivide the information by major IT
functions. Within each domain, this panel presents navigation trees that make it
easy to zoom in on Fixlet Messages, Reports, Analyses, and other content.

Domain Buttons: At the bottom of the Domain Panel, these buttons represent
the set of Domains that are currently available to you. When you subscribe to a
site, it is automatically entered into the correct domain. If a new domain is
required, a button for it is added to this group. At the bottom of the buttons is a
control that allows you to adjust the number of buttons to display.

Console Toolbar: This toolbar allows you to navigate back and forth through the
items you have selected from the Domain navigation tree. In addition, there are
buttons that allow you to display items you might have hidden and items that
are not currently relevant to any of your Clients (this allows you to view all the
available content for research or cloning purposes). There is also a refresh button
that re-evaluates content for the Console display.

List Panel: This is a listing of the items specified by the content filters and the
navigation trees in the Domain Panel. You can sort this list by clicking the
column headers and you can rearrange the headers by dragging them left or
right. In addition, you can right-click the headers to see a pop-up menu
containing a list of all the possible fields. Check those you want to use as
headers.

Context Menu: This is the menu that opens when you right-click any item in a
list. Different lists have different context menus.

Work Area Toolbar: This bar contains context-sensitive buttons that can run
various actions based on the content of the current work area.

Work Area: Below the List Panel and the Work Area Toolbar is the Work Area.
When you double-click an item from the List Panel, the Console opens a
detailed document in this window.

Domain Panel Console Toolbar List Panel Context Menu
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File Edit Go  Tools Help
) Show Hidden Content
| A8
MName = Source Severity i Site Applicable Co...} Open Actio *
a [y A (LITT) o : i
: MS08-026: Vulnerability in RPC Coul.. Important Patches for Win... 1/2 0 @
= By Source Severity] e, = HYE P e
@ N/A (1) MS03-037: Vulnerabilities in Microso... Critical Patches for
A @ <Unspecifieds M503-041: Vulnerability in Workstati.. Moderate Patches for Op=n
P E
i @ N/A (67) |E | M509-044: Vulnerabilities in Remote..  Critical Patches for Copy Text
@ Unspecified (1 IM309-048: Vulnerabilities in Windo...  Critical Patches for Copy Text with Headers
b @ Low (57) M3503-051: Vulnerabilities in Windo...  Critical Patches for Select All
b @ Moderate (156] M508-056: Vulnerabilities in Windo...  Important Patches for
b @ Important (L M503-053: Vulnerability in Local Sec..  Important Patches for Globally Hide
b B Critical B0y [ P e et [ "t | Globaly Unhide
i £ By Site - - - - Locally Hide
Fixlet: M503-037: Vulnerabilities in Microsoft Active Template Library (AT
b [ By Category Locally Unhide
» [ By Source Teke Action~ | .~ Edit | Copy [ Export | Hide Locally Hide Gl
I £ By Source Release Take Default Action...
b @ Fixlets Only (1.884) 3 | Applicable Computers (1) | Action History (U)| el Comment
» [} Tasks Only (93) 5
= N Edit...
......... Descriptio| Remave
s All Content Microsoftjhas released a security upd3Re that resolve Create Customn Copy...
— reported julnerabilities in Microsoft Ac@¥e Template LI et
@ BigFix Management vulnerabfities could allow remote codd execution if a P
crafted cgmponent or control hosted o a malicious w z
.l. Patch Management accountsfare configured to have fewerjuser rights on Add To New Baseline...
less impgeted than users who operatgwith administ Add To Existing Baseline... »
@ Systems Iiccyde After downloading and installing this update, affecte -
r ‘i Create New Fixlet...
" longer bg susceptible to these vulnergpilities.
- Create New Task...
#7? items in list, 1 selected. Connecte'to 'nc926068.ron Create New Baseline...
Domain Buttons | Work Area Toolbar Work Area

Manage Properties

The Manage Properties dialog contains a list of computer properties that are
retrieved on a regular schedule from each BigFix Client.

4 [ All Properties (197) + | Name : Activated Site i Add Mew |
g ﬁ B":_"’F“"‘ | BES Client Download Throttli-, Mot Activated  BES Suppost
E B":" ) BES Client Dynamic Downloa... Not Activated  BES Suppart Delcte
- B" i;;‘"‘" BES Relay Downleod Thratting Not Activated  BES Support | — ey
“r,_ Banchwidth Throttling Status &) BES Reday Dynamic Downloa.. Mot Activated BES Suppart _#hﬂ_cgttﬂm ~0RY |
y " a ay Total QU face ot Actreate ot
j_ BES Client Helper Service (5) BES Relay Total Outbound Dy... Mot & d  BES Supp
L ; BES Client Logging Service Vers BES Relay Total Outbound The., Nuthct?vaud BES Support
' BES Component Versions (5) BES Server Total Outbound D.. Mot Activated BES Support
i [ BES Health Checks Analysiz (8) BES Server Total Outbound T.. Mot Activated BES Support
' BES Management Rights (2)
' BES Relay Cache Infarmation (4
l ' BES Relay Status (5 =
a4 I” pnss I_D - H_. i T 1] LI Pe— I_Il _______ L
Narme: BES Client Download Throttling Caleqony
Relevance: if (exiscs seccing " BESClient D: whase [exiscs -

walue of it} of clisnt) then value saccing
1 nd™ of clisnc &las "not ssac”

Evaluate every Every Report -

0K Cancel

=== = = = = = = A
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This allows the Console operator to monitor specific aspects of all managed clients.
These properties can also form the basis of the client filters (and column headers)
in the Console whenever client computers are listed. In addition, these properties
can be used to target computers for Fixlet messages or actions.

There are several properties listed as defaults in the top panel, but if you are a
Master Operator, you can add to these (and delete others) by using the buttons on
the right:

* Add New: To add a property, click this button, and the bottom part of the dialog
becomes editable. Supply a name (that to be used for filtering and sorting) and
then fill in a Relevance Expression in the text box below.

* Delete: To delete a property, highlight it in the list and then click this button.

* Make Custom Copy: You can clone and customize any property by selecting it
in the list and then clicking this button.

* Export: To export a property as an XML (.bes) file for sharing with other users,
click the button and then specify a filename for export.

Below this panel are two text fields. They display the existing property name and
relevance expression. For reserved properties, these fields are display-only. Many
of the properties, however, are available for editing.

* Name: Displays the existing name of a property, or allows you to enter a name
for a new Property. If you make this name available, it is integrated into the
interface for filtering, sorting, and targeting. This field also allows you to rename
a property.

* Relevance: This text box displays the relevance expression that is evaluated to
produce the retrieved property.

For each of these properties, there is an optional evaluation period:

* Evaluate Every: Choose a time period, from 5 minutes to one month, which
controls how often the Property is evaluated. You might want to set a long
period for time-consuming property evaluations or a short period for more
urgent properties. The default is Every Report, which revaluates the properties
with each report.

NOTE: Some of the properties (such as the IP Address and the relay status) are
essential to the correct functioning of the Console. They are marked as Reserved,

and cannot be renamed or deleted.

This dialog is available by selecting Tools > Manage Properties...
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Manual Computer Groups

This dialog allows you to manually group your computers to target them
simultaneously.

Select Manual Computer Group %J

() Add the selected computers to the manual group selected below:

Group Name : Computers

external group 2

@ Add the selected computers to a new manual group named:

New Groug

i OK | ’ Cancel

To choose the computers you want to group, select them from the Computers List
Panel. Right-click and select Add to Manual Group from the context menu. In the
dialog that opens, you can add these computers to a pre-existing group, or define a
new group. There are two buttons for these choices:

* Add the selected computers to the manual group selected below: Click a group
and click OK.

* Add the selected computers to a new manual group named: Type in a new
group name and click OK.

NOTE: A computer can belong to more than one group. You can also define
groups automatically, by using properties or Relevance statements to indicate their
group status.

This dialog is available by clicking the Computers icon in the Domain Panel
navigation tree, selecting computers from the Computer List Panel, and then
right-clicking and selecting Add to Manual Group from the context menu.

Messages tab

Ordinarily, the system applies actions in the background, without involving any
users. In the Messages tab you can select to alert the user with a specific message,
and to offer certain interactive features on the message display, including the
ability to see more information about the proposed action and to cancel the
proposed action.
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&’ Take Action

Mame: | Install BES Server Plugin Service Create in domain: ;AII Content v-

Preset:

| Target || Execution | Users | Messages j.?ffef_ | Post-Action || Applicability | Success Criteria | Action Script |
Display message before running action
Title: Install BES Server Plugin Service

Description:
[] Ask user to save work

[ Allow user to view action script

[ Allow user to cancel action

Set deadline: ® [1 day v ._ from time action is relevant
At deadline: (%) Run action automatically

O Keep message topmost until user accepts action
[] show confirmation message before running action:

[] bisplay message while running action:

[ OK ] [ Cancel ]

This tab is available from several different dialogs:

* |“Take action” on page 240)|

* [“Take multiple actions” on page 242|

* [“Action Settings” on page 141

+ [“Edit Computer Settings” on page 197|

You can select to display a message to the users before running the action or while
the action runs or both. The default is to show no message. If you click on Display
message before running action, in addition to the title and the text of the message,
you can specify the following behaviors:

Ask user to save work
Includes a prompt asking users to save their work before the action is
invoked.

Allow user to view action script
Allows the user to look over the script before accepting the action.

Note: This option is disabled in the Take Multiple Action dialog.

Allow user to cancel action
Grants the user the right to cancel the action.

Set Deadline
Extends the user a grace period after the action becomes relevant. For
example, this ability could be helpful to allow the user to prepare for an
upgrade. Select:
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time_period from time action is relevant

To grant the user a specified grace period starting when the action
becomes relevant.

date at time client local time
To set the deadline to a specific date and time using the timezone
specified in the Execution tab, which can be either the local client
timezone or the Universal Time Zone.

At deadline
When the deadline arrives you can select to Run action automatically or
to Keep message topmost until user accepts action to keep the message
on top until the user clicks to accept the action.

Show confirmation message before running action

Displays a final confirmation message to the user before running the
action.

Modify Custom Site Subscriptions

The Modify Custom Site Subscriptions dialog lets you subscribe or unsubscribe
any specified group of computers to any of your ad-hoc enabled custom sites.

Modify Custom Site Subscriptions ﬁ

@ Subscribe selected computers to site:

| BigCorp Dev Site - |
Unsubscribe selected computers from site:
i BigCorp Dev Site I
| OK | | Cancel

To prepare a custom site for this type of ad-hoc subscription, you must first open
the custom site, select the Computer Subscriptions tab, and click the button
labeled Computers subscribed via ad-hoc custom site subscription actions. Do
not forget to Save Changes using the toolbar.

Now, when you open Computers in the List Panel, right-click to bring up the
context menu and choose Modify Custom Site Subscriptions. This dialog opens
and those custom sites that have been enabled for ad-hoc subscriptions are
available for subscription from the pull-down menu. If the site is already
subscribed to a custom site, this dialog also lets you unsubscribe it.
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This dialog is available by right-clicking an item from any Computer list and
selecting Modify Custom Site Subscriptions from the context menu. For this
menu choice to be available, you must have first set up a Custom Site with
subscribers.

Offer tab

In the Offer tab you can advertise a list of actions (typically optional patches or
updates) to the BigFix Client user.

"/ Take Action Q@ﬁ“

Mame: | BES Relay/Server Setting: Enable Disable Dynamic Throtting | Create in domain: | All Content [v]

Preset: !Default i ~ I [C1show only personal presets

An action that is made into an 'Offer’ becomes available in the list of offers in the dient UI on applicable machines. Users can browse
through the list of available offers and apply those that they are interested in.  Offers will only be visible to users selected on the
'Users' tab and on machines where the dient Offer Ul is enabled.

[] Make this action an offer

[ ][ [ell& | B ru|is=|EEs s\, = \
BES Relay/Server Setting: Enable/Disable Dynamic
Throttling
Description
® Click here to accept this offer.

[ O ] ’ Cancel ]

This tab is available from several different dialogs:

* |“Take action” on page 240|

* [“Take multiple actions” on page 242|

* |“Action Settings” on page 141

Use the information in this tab to let an operator, which is allowed to manage the
targeted Clients, choose the actions from the offering list. Offers are limited to
version 7.0 Clients or later.

In this tab you see the following options:

Make this action an offer
Check this box to advertise the given action to users.

Notify user of offer availability
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Title Enter a descriptive title for your action. This advertisement is presented to
users who have to decide whether to take advantage of the offer or not so
use a effective and easy to understand description.

Category
Enter a category for this offering. This is a user-defined field for
bookkeeping purposes, and you can use any scheme that makes sense to
your particular deployment. For example, one company might want
offering categories like Installers and Uninstallers; another might want
Applications and Updates.

HTML box
Enter a description of the action in the box provided. The description will
be presented to users. You can change fonts, sizes, styles, numbering, and
formatting to customize the description.

Operator Permissions Tab

The Operator Permissions tab of the Site document lets Master Operators specify
site permissions for other operators.

External Site: Client Manager for Endpoint Protection = O

Save Changes Discard Changes

Gather 3 Remove

| Details | Computer 5ubscriptiu:un5| Operator Permissions |

Operators with read permission will be able to view this site and take actions based on
its content.
[] Grant read permission globally Permission: [ Reader l ’ None
Mame Last Login Time Permission
don 5/6/2010 6:40:56 PM Mone
ken 5/6/2010 6:36:37 PM Reader
rnay 5/6/2010 6:41:40 PM Mone
suE 5/6/2010 6:37:16 PM Reader

This dialog is available to Master Operators and Non-Master Operators who have
Site Ownership permissions.

Not all operators need to know about all sites, and some sites can be most easily
managed by a single operator, such as the Anti-Spyware Czar. This interface lets
you attach a Fixlet site to a single operator or group of operators. You can also
remove operators from this list at any time.

This interface only affects the reader status of Non-Master Operators. For an
external site, there is a check box and two buttons:

* Grant read permission globally: Check this box to allow read access to all
operators.

* Reader: Select an operator from the list and then click this button to grant read
permission to that operator.
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* None: Select an operator from the list and click this button to deny read
permission to the specified operator.

For a custom site, which can be owned and edited, there are two extra permission
buttons.

Custom Site: BigCorp Policy Site o O

5] 5ave Changes Discard Changes | Gather 3€ Remove

| Details | Computer Subscriptions| Operator Permissions |

Customn site owners are allowed to grant other operators read or write permission and modify the site subscription.
Writers are allowed to create new content in the site. Readers are allowed to view and apply content in a custom site.,

["] Grant read permission globally ~ Permission: [ Owner ] l Writer l [ Reader ] l Mone
MName Last Legin Time Permission
don 5/6/2010 6:40:56 PM Writer / Reader
ken 5/6/2010 6:36:37 PM Owner / Writer / Reader
may 5/6/2010 6:41:40 PM Reader
sUE 5/6/2010 6:37:16 PM Mone

As before, you select an operator from the list and then click buttons to grant
permissions. The two extra buttons are:

* Owner: This grants the greatest permission to the operator who can then assign
reader and writer permissions.

* Writer: This button allows an operator to edit the site.

This dialog is available by clicking the Sites icon in the Domain Panel navigation
tree, selecting a Site from the resulting List Panel, and then clicking the Operator
Permissions tab.
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Post-Action tab

In the Post-Action tab you can set to restart or shut down the client computer after
the action has completed

' Take Action =Joks

Mame: | BES Relay/Server Setting: Enable/Disable Dynamic Throttling Create in domain: :AII Content :mv.'J

Preset: [Custom] Default v j [[]5how only personal presets

| Target | Execution | Users | Messages | Offer | Post-Acten | Applicabilty | Success Criteria | Action Seript

) Do nothing after action completes
(%) Restart computer after action completes

() Shutdown computer after action completes

Message
Before restarting, show the following message to active users:

Message Title: Shutdown Mow

Message Text: Your system administrator is requesting that you restart your computer. Please save any unsaved work
and then take this action to restart your computer,

[ Allow user to cancel restart
Set deadline: 1day [ | from time action completes

At deadline: (®) Restart automatically
O Keep user interface topmost until user accepts restart

[ OK l [ Cancel ]

This tab is available from several different dialogs:

* [“Take action” on page 240|

+ [“Take multiple actions” on page 242|

+ |“Action Settings” on page 141

Among the various settings that you can specify in this tab you find:

Allow user to cancel restart
This gives the user a dialog box where they can cancel the proposed
restart.

Set deadline
This gives the user the option to delay the restart/shutdown for the
specified time frame after the action completed. Typically, restarts are
needed to complete an installation, so they should not be postponed for
too long a time.

At deadline
Click one of these buttons to specify what the deadline action is. You can
choose to automatically restart, or to keep a dialog box on the screen until
the user is ready.
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Post-Execution Action Script Tab

In the Pre-Execution Action Script tab of the Take Multiple Actions dialog you
can create an action script that runs after the chosen set of actions is run.

4’ Take Multiple Actions Q@@

Mame: | Multiple Action Group Create in domain: ;AII Content | % i

Preset: [Custom] Default v [C5how only personal presets

Target | Exeaution | Users | Messages | Offer | Post-Action | Pre-Execution Action Saript | Post-Execution Action Swipt | Appicabilty |

() Do not run a custom action script after executing this multiple action group,
() Run the following action script after executing this multiple action group:
Action Secript Type:

Action Script:

1; // Enter your custom post-eXecution action script here

I 0K l ’ Cancel ]

This tab is available from several different dialogs:

* [“Take action” on page 240l when deploying a baseline

* |“Take multiple actions” on page 242|

There are two buttons in this dialog;:

Do not run a custom action script after executing this multiple action group
This is the default for most Fixlet actions, and is the recommended option.

Run the following action script after executing this multiple action group
You can select one of the following options and either modify the existing
script or enter a new script in the text area. Select the type of action script
that you want to use for this script:

BigFix Action Script
This is the IBM Endpoint Manager standard scripting language for
actions. For more information about the action language, see
[[ntroducing the action language]

AppleScript
This is Apple's scripting language for controlling computer
resources.
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sh The action is a shell script to be run by a Linux or a UNIX or a bsd
shell.

Note: By default, actions cannot be undone. Make sure to test your action on a
small scale before you deploy it in your entire network.

Pre-Execution Action Script tab

In the Pre-Execution Action Script tab of the Take Multiple Actions dialog you
can create an action script that runs before the chosen set of actions is run.

-
¢” Take Multiple Actions =03
Mame: | Multiple Action Group Create in domain: ;AII Content -|. W f
Preset: [ [Custom] Default v [ show only personal presets

| Target | Execution | Users | Messages | Offer | Pest-Action | Pre-Sxecution Action Script | post-Execution Acten Script | Applicabiity |
(%) Do not run a custom action script before executing this multiple action aroup,
) Run the fallowing action script before executing this multiple action aroup:
Action Script Type:

Action Script:

1 /S Eneer your custom pre-executlon actlon sScript here

[ Ok ] [ Cancel ]

This tab is available from several different dialogs:

* [“Take action” on page 240/ when deploying a baseline

* [“Take multiple actions” on page 242

There are two buttons in this dialog:

Do not run a custom action script before executing this multiple action group
This is the default for most Fixlet actions, and is the recommended option.

Run the following action script before executing this multiple action group
You can select one of the following options and either modify the existing
script or enter a new script in the text area. Select the type of action script
that you want to use for this script:
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BigFix Action Script
This is the BigFix standard scripting language for actions. For more
information about the action language, see [Introducing the action|
-lanua oe

AppleScript
This is Apple's scripting language for controlling computer
resources.

sh The action is a shell script to be run by a Linux or a UNIX or a bsd
shell.

Note: By default, actions cannot be undone. Make sure to test your action on a
small scale before you deploy it in your entire network.

Preferences

The Preferences dialog lets you adjust certain system-wide parameters.

-,

Preferences ﬁ

Fixlet List Relevance Colorization

R e 15 coerae Modify the colors used to display relevance.

Set Colors
Client Computers [

Console Close

Send heartbeat every 15 minutes
n Prompt for confirmation before dosing the
Mark as offline after 45 minutes console
Language
Console language: (Default) [ e :
Caching

) Always load data from database (best for fast networks and slow disks)

) Keep partial cache on disk (best for fast networks and fast disks)

(%) Keep full cache on disk (best for slow networks and fast disks)
Expiration policy for full cache:

) Aggressive {remove unused data quickly)
(%) Moderate

) Conservative (keep unused data for a long time)
Clear Cache

[ Ok ] [ Cancel ]

There are several sections in the Preferences dialog:

Fixlet List

* Refresh list every XX seconds: Controls how often the Fixlet display is updated.
The default setting causes the BigFix Database to be queried every 15 seconds.
More frequent updates cause more network traffic, but less frequent updates
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increase the response time. As the BigFix Database increases in size, a longer
refresh rate might be desirable. 15 seconds provides a good balance between
latency and bandwidth concerns.

Client Computers

* Send heartbeat every XX minutes: Controls how often the BigFix Client
computers check in with the BigFix Server to update their status. Each time a
BigFix Client sends a heartbeat, it includes any retrieved property values that
have changed. 15 minutes is the default value.

* Mark as offline after XX minutes: Controls how long to wait after the last
heartbeat before a computer is declared to be offline. The default is 50 minutes.

Relevance Colorization

* Modify the colors used to display relevance: Whenever Relevance expressions
are viewed, the text can be colored for easier reading. Click the Set Colors
button to open an interface allowing you to customize your personal color
scheme.

Console Close

* Prompt for confirmation before closing the console: This preference provides a
yes/no prompt every time you exit the Console.

Language
* Console Language: If you want to change the Console language, select the
language and then restart the Console.

Cache options

* Always load data from database: If you do not want to leave information
cached on your Console computer, click this option. This causes all data to be
loaded freshly from the database each time you open the Console.

* Keep partial cache on disk: This option caches everything except retrieved
property results. The Console still caches Fixlet and Action results, which are
then written out upon exiting.

* Keep full cache on disk: With this option, retrieved properties can be stored
locally along with Fixlet and Action results. The more properties you keep in the
cache, the more expensive it is to maintain, so the caching policy determines
how long the Console runs before it clears items out of its cache.

Expiration policy. If you have selected the full caching option above, you must
also set an expiration policy to periodically purge the cache:

» Aggressive: This policy purges unused data rapidly, purging any items that
were not accessed in the previous Console session.

* Moderate: This policy is intermediate between aggressive and conservative.

* Conservative: This policy allows data to remain for a long time between purges,
whether or not is has been recently accessed.

¢ Clear Cache: Click this button to clear the current cache when the Console is
next run.

This dialog is available by selecting:
* File > Preferences
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Recent Comments

This dialog presents a list of comments that have been attached to Fixlet messages,
Tasks, Baselines, Actions, and Computers.

Recent Comments =]
Object Comment Console Operator Time Entered
tically R Refer to new Admin Policy joe 111672011 3:02:48 PM
ES Client Sett Made part of Client package joe 1/16/2011 3:01:56 PM
Run on all Tokyo systems - 1/15/11 joe 111672011 3:00:22 PM

It compiles all the Comments from each of these interfaces for viewing in one
place.

You can view the current comments by selecting Tools > View Recent Comments.

Results Tab

The Results tab of the Analysis document displays a list of targeted computers
and the results of the analysis for each one.

Analysis: BES Relay Status [~ ™|

& Activate %Deactivate | # Edit =% Export | Hide Locally Hide Globally | ¥ Remove

| Description | Details | Results |Applicahle Computers (3]|

|View as list -
4 @ Applicable Computers (3) Cnmpu{er Ma..  BES Relay Installed Status BES Relay S...
> gy zetrleved Properties BIGDOG Mot Installed Manual
4 lf]q}' E:i'-'F’ | o | MOMMA Not Installed Manual
N exdemalgroup @) | Lo Main BES Server Automatic
&% G group (2)
% M group (1)
&= Win group (3)
‘ i t

The format of this display depends on the selected View, either list or summary.
The list view is shown above.

When viewed as a list, each specified retrieved property has a corresponding
header and the value of each property is displayed beneath it. If there is more than
one value for a property, then <multiple results> is displayed. You can sort this list
by the headers or use the folders in the left-hand panel to filter the results. This
allows you to manage large sets of computers by their retrieved properties.
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When viewed as a summary, each property has its own section, with response
counts and percentages for each value of the property.

Analysis: BES Relay Status e O

QY Activate Qg Deactivate | & Edit x-:) Export | Hide Locally Hide Globally | ¥ Remove

| Description | Details | Results |Applicable Computers (3j|

l‘u"iew as summary vl
F] @ Applicable Computers (3] o~

I» i By Retrieved Properties BES Relay Installed ... Top10 ~ ||
4 [} By Group Status

ﬁ external group (2) Count | Percentage | Result L

% G group (2] 1 33.33% Main BES Server 3

% M group (1) 2 66.67% Mot Installed

% Win group (3}

BES Relay Selection .. Top10 ~

Method
Count | Percentage |Re5ult L |
1 3333% Automatic
2 6667% Manual

This dialog is available whenever you select an activated Analysis from an
appropriate list.

Role Computer Assignments Tab

The Computer Assignments tab of the Roles window allows you to add a set of
computers to a role.

'Role Unix Admin =20
H"1 JE '-||.-|r:|_.|r-- Dizcard "._'1r||1|.—5- x Remowve

e

5 All Computers This rofe has management rights on all computers that
have the retrieved property values shown on the left.
This role does MOT have management rights on any
computers that do NOT have the retnieved property
values shown on the left.

This role will automatically be granted management
nights on {or will have management nghts removed
on} any computers that change to match {or to not
miatch) the retrieved property values shown on the left.

Click the Add button to include computers, defined by properties or groups, as a
part of this role's definition. Make sure to click Save Changes before you dismiss
this window.
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This dialog is presented when you select a role from the Roles list or when you
create a role from scratch with Tools > Create Role.

Role Details Tab

230

Roles can be created and defined through the Console. You can create a role by

selecting Tools > Create Role. You can modify an existing role by clicking on an
item in a Roles List, which is available when you select Roles from the Domain
panel.

Fine: HMOHDIED

R e ¥ Remove

Dieta

Desails | Computer Assgrments | Operatoes 13) | LOWS Geoups (11| Sites 10)
Detaile

HKORck1

MO = Mg - Custom Content = Yes - Show Other = Yes - Urmanaged = Show Nane

Piminsan

Mo [w]
s [v]
es[v|
i v
Wias )
Vs v
Show Hane  [»]

Al Risstart and Shuldaen [»
Aderw Restart and Shuidown [v]
Intnilsce Legin Frivileges

s ]

Vs w

The Roles Detail tab lets you describe the role and set permissions. In particular,
you can give this role Master Operator permissions with the appropriate
pull-down menu. If you want this role to be able to create and edit custom sites,
use the Custom Content pull-down. If you want this role to be able to follow the
actions of other operators, select Yes from Show Other Operator's Actions.

To run actions on computers set Can Create Actions to Yes. If you set to No, you
can still view computers and create Fixlets or analyses.

To lock computers set Can Lock to Yes.

If you want to allow this role to view Unmanaged Assets, select that option from
the appropriate pull-down.

To influence the ability of the operator to trigger restart and shutdown as
Post-Action, assign a value to Post Action Behavior.

To influence the ability of the operator to include restart and shutdown in actions
with type BigFix Action Scripts, assign a value to Action Scripts Commands.

You can also set permissions to access the BigFix Console and REST APL

This dialog is presented when you select a role from any list of roles.
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Role LDAP Groups Tab

The LDAP Group tab of the Roles window allows you to associate an LDAP
Group to the Role definition.

Role: ﬁnance;ﬁmup =

E@SE'{E Changes Discard Changes 3§ Remove

[ | Details I Computer Assignmentsl [}perators| LDAP fEéUUFS Sites

Assign LDAP Group Remove LDAP Group
Name Distinguished MName LDAP Server
‘& n | ¢

Click Assign LDAP Group to bring up a dialog with your currently unassigned
LDAP Groups listed for selection. You can also delete groups by selecting their
name and clicking Remove LDAP Group.

Make sure to click Save Changes before you dismiss this window.

This dialog is presented when you select a role from the Roles list or when you
create a role from scratch with Tools > Create Role.
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Role Operators Tab

The Operators tab of the Roles window allows you to associate specific local or
LDAP-defined users with the given role.

Role: Unix Admin =0
H"-..'.— Changes  Discard Changes ¥ Remove
| Detais | Computer Assignments OFgators | LDAP Groups | Sites

Assign User |
EEhbeenic. b i) |

Mame Last Login Time Oper
Joe Blough 10/3/2011 1214400 PM Local
Jill Doe 10/3/2011 12:05:11 PM Lecal
Fred Dingle 10/3,/2011 12:08:19 PM Local
o (L1} ¥

Click the Assign User button to bring up the list of currently unassigned users.
You can delete users from this role by selecting their names and clicking Remove
User.

Make sure to click Save Changes before you dismiss this window.

This dialog is presented when you select a role from the Roles list or when you
create a role from scratch with Tools > Create Role.

Role Sites Tab

The Sites tab of the Roles window allows you to associate content sites with a
given role.

Role: Unix Admin S|
H"-..'.— Changes  Discard Changes ¥ Remove

Detaiks | Computer Assignments | Operators | LDAR Grnups. Sites

Assign Site .

MName Type Creator Domain

Patches for Solans External

Patches for RHEL 5 External

Linux RP h-tgatchlng External

o i ¥
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You can add various sites by clicking the Assign Site button. Then, for a custom
site, you can assign owners and writers to this role.

Make sure to click Save Changes before you dismiss this window.

This dialog is presented when you select a role from the Roles list or when you
create a role from scratch with Tools > Create Role.

Security Warning

The Security Warning dialog alerts you about scripting or relevance statements
embedded in text.

Security Warning . -

This message contains scripting and/or relevance.
Do you want to enable this dynamic content?

Title: Fixlet: Fixlet with Wizard

Source: BES Operator "bigfix" (signature verified).

| Enable || Disable |

Whenever the Console detects that an embedded Relevance clause or a script is
about to be displayed, this warning pops up. Unlike Action scripts, which require
a password before they can be run, embedded scripts are run automatically and
thus require scrutiny. In general, if you created these scripts from a custom site,
you can click the checkbox to allow dynamic scripting to always be enabled.

If you are uncertain about the source of the embedded script, click Disable.

This dialog is displayed whenever content containing a Relevance statement or a
script is about to be displayed.
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Settings Tab

234

The Settings tab of the Edit Computer Settings dialog allows the administrator to
apply certain settings to multiple targeted computers, including locking, relays,
and custom variables.

Edit Computer Settings ==l

Settings | Target | Execution | Users | Messages

Change the following settings:
Locking Status

Tiwoli Endpoint Manager Relay 5

Primary Tivoli Endpoint Manag:

Secondary Tiveli Endpoint Man

Custom Setting

Custom 5ite Membership

I. oK Cancel

It includes the following controls:

Locking Status. Check this box to either lock or unlock the targeted computers.
You might want to lock a computer because it is currently being used in
program development, it is in the middle of a lengthy process, or because it is
running specialized software. While a computer is locked, no actions are run on
it.

— Locked. Click this button to lock the computer.
— Unlocked. Unlock the targeted computers.
Relay Selection Method. Choose an automatic or manual Relay method.

— Automatically Locate Best Relay. Select this button to automate the process
of selecting a Relay. This is the recommended setting.

— Set Relays Manually. Force a manual selection of the BigFix Relays.

Primary Relay. Select a primary Relay. Check the box and select a computer
from the pull-down menu. Any attached Clients then gather Fixlet downloads
from this relay rather than directly from the IBM Endpoint Manager Server.

Secondary Relay. Select a secondary Relay. Check the box and select a computer
from the pull-down menu. Any attached Clients then gather Fixlet downloads
from this relay if the primary relay is unavailable.

Custom Setting. This feature allows the BigFix Master Operator to create named
variables that can be associated with the targeted computers.

— Name. Type the name of a variable to be associated with all targeted
computers, for example, "department.”
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— Value. Enter the value of the above-named variable, for example, "payroll."

When multiple computers are selected, this dialog is available by right-clicking and
selecting Edit Computer Settings from the context menu.

Site Details Tab

The Details tab of the Site document provides you with information about the site
and the subscription criteria.

External Sitez Client Manager for Endpoint Protection o B
H"e.a— Changes Discard Changes | Gather Add Files... 3 Remove

Details .Cﬂmputer Subscriptions l Operator Permissions

* Details
Type External Content Site
Cument Version 1,908
Gather URL http:/fsyne._bighix com/cgi-bin'bfgather/aveliant
Publisher BigFix, Inc

» Subscription

All clients that satisfy the extarnally defined criteria are subscnbed to this site.
External Subscription Constraints
*=

Masthead Relevance evaluation of client licenss =

True

The Details group provides information about the version, publisher, and URL of
the site.

The Subscription group provides information about how the criteria are used to
select clients for subscription to the site.

This dialog is available by clicking the Site icon in the Domain Panel navigation

tree, selecting a Site from the resulting List Panel, and clicking the Details tab from
the document in the Work Area below.
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Site List and Document

236

A list of Sites is displayed when you click Sites, or any of its child nodes, from the
Domain Panel navigation tree.

File Edit View Go Tools Help
<l Back + ﬂ‘% Forward = | 9 Show Hidden Content " Show Mon-Relevant Content

L P 2P

All Content « Sites |SEarch Sites
[ [ Operators (3] = iName . Type Damain
= Ei'tes (14} | 05 Deployment External
N __l EEet! (2) | Patches for Windows (English) External
i3y Eeimal (1) | SCM Checklist for DISA
4 a Wizards

on AL.. External
o Ex'l:ergal | e

A Site document is displayed in the Work Area of the Console when you click any
item from this list. If you open the Sites icon, you can filter the sites to either
Custom or External types. Click an external site from the list to open it in the Work
Area below.

. : 'Q‘r'rvﬁ‘@tl E |SC§F{1icklingtDISA 5T

External Sitez Client Manager for Endpoint Protection o B

H"?.ﬂ. ve Changes Discard Changes | Gather Add Files... 3 Remove

Details Computer Subscriptions | Operator Pﬂmi:sinnsi

* Details
Type Extemnal Content Site
Cument Version 1,908
Gather URL hittp:/fsync._biglix com/cgi-bin/bfgather/aveliant
Publisher BigFix, Inc

m

» Subscription

All clients that satisfy the externally defined critenia are subscribed to this site.
External Subscription Constraints
=

Masthead Relevance evaluation of client licenss =

True

At the top is a toolbar with four buttons:
* Save Changes: This button is grayed out for an external site.
* Discard Changes: This button is grayed out for an external site.
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* Gather: This button gathers the contents of the site.
* Remove: This button allows you to remove the site from the Console.

Beneath the toolbar are three tabs:

* Details: This read-only tab displays the version, URL, and publisher of the site.

Computer Subscriptions: This tab lets you specify which Clients are subscribed
to this site.

Operator Permissions: This tab lets you attach Operators to the site as owners,
writers, or readers.

You can also create and edit your own Custom sites. If you have any custom sites,
click one from the list to view or edit it.

Custom Site: BigCorp Policy Site [
[) 5ave Changes Discard Changes | Gather Add Files... 3¢ Remove

Details  Computer Subscriptions | Operator Permissions

* Details

Type Custom Site

Creator Joe

Created 118/2011 6:03:48 PM
Thiz Policy site iz a collection of
Fixlecs and Taska to escablish

Diescription variona corporate palices acrosa the s
r.-:‘:.w::h.'.l

Damain All Cantent -

+* Subscription

Mo clients are subscribad to this site, but Tivali Endpoint Manager will continue
ta maintain an up-to-date version of the site in the database.

The document for a Custom Site is similar to that for an External site, with added
abilities to edit the site. The toolbar has the same four buttons:

Save Changes: After making edits to your Custom Site, click this button to
record your changes.

Discard Changes: This button clears all the changes you made.

Gather: Because the contents of a custom site are typically stored locally, this
tool might be grayed-out.

Remove: This button allows you to entirely remove the site from the Console.

Beneath the toolbar are the same three tabs:

Details: This tab allows you to view or edit the description of your custom site
and to select the Domain you want to host the site.
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* Computer Subscriptions: This tab lets you specify which Clients are subscribed
to this site.

* Operator Permissions: This tab lets you attach Operators to the site as owners,
writers, or readers.

To view the Site list, click the Sites Icon (or any of its child nodes) in the Domain
Panel navigation tree. Open the icon to narrow down the list to either Custom or
External sites.

To view a Site Document, click any item in a site list.

To create a custom site, select Tools > Create Custom Site.

Site Properties

238

The Site Properties dialog displays information about the selected Fixlet site,
including the name of the Site publisher and the URL from which the content is
gathered.

External Site: Client Manager for Endpoint Protection e B
H'—‘..r'-h‘.'J.—'- Disear !"-':-Il_i"' | Gather Add Files, KHH'I"IENE

Detail: | Computer Subscriptions I Operator Permissions

* Details
Type External Content Site
Current Version 1,908
Gather URL hittp.fisyne._bigfix_com/cgi-bin/bfgather/avcliant
Publisher BigFix, Inc

v Subscription

All clients that satisfy the externally defined criteria are subscribed to this site.
External Subscription Constraints
+=

Masthead Relevance evaluation of client license =

True

The tabs in this dialog include:

* Details: This tab displays the Site type (internal, external), the version, and
information about the publisher and subscriptions.

* Computer Subscriptions: This dialog allows you to narrow down the list of
computers that subscribe to the chosen site. By eliminating superfluous or
irrelevant Fixlet subscriptions, you can reduce the disk-storage requirements of
your client computers.
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* Operator Permissions: This is a list of the operators and their permission levels.
For an external site, you can typically only grant read access, but for a custom
site you can grant ownership, write or read permission.

This dialog is available by clicking the Sites icon in the Domain Panel navigation
tree and then clicking an item from the resulting List Panel. The Site information
opens in the Work Area below.

Success Criteria tab

In the Success Criteria tab you can define the conditions under which the action is
considered to be successful.

¢* Take Action Q@@ﬂ

Mame: | BES Relay/Server Setting: Enable /Disable Dynamic Throtting Create in domain: ;AII Content |1 ‘

Preset: [Custom] Default [w] CIshow only personal presets

Target | Execution | Users || Messages | Offer | Post-Action || Applicability | Success Criteria | Action Script |

Consider this action successful when. ..
() ...the applicability relevance evaluates to false.
@) ...all lines of the action script have completed successfully,

() .. .the following relevance dause evaluates to false:

[ Ok ] ’ Cancel ]

This dialog is available by selecting a Fixlet message or task from any list, then
clicking an action button. From the [“Take action” on page 240| dialog, select the
Success Criteria tab.

Select one of the following options:

The applicability relevance evaluates to false
This is the default success criteria, requiring that the Relevance statement
that made the action applicable is no longer TRUE. Because the Relevance
statement notices a problem and the action fixes it, this is generally
sufficient to establish success.

All lines of the action script have completed successfully
You can make success dependent on completing all steps of the action
script.
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The following relevance clause evaluates to false
You can use a special Relevance clause to ensure that the action has
accomplished it goals. In this case a text box below becomes editable and
you can create or revise an existing Relevance clause.

Take action

Use the Take Action dialog to run deploy a Fixlet, a task or a baseline.

The Take Action dialog is similar to the Take Multiple Actions dialog, but issues
only a single action.

You can access this dialog in one of these ways:

* Right-click a relevant Fixlet message or a task and choose Take Default Action
from the pop-up menu.

* Click a relevant Fixlet message or task and select Take Default Action in the
Work Area toolbar.

* Click a relevant Fixlet message or task and select the Description tab. Scroll
down to see the suggested actions. Click the link related to the action that you
want to run.

& Take Action Q@@‘

Mame: | Install BES Server Plugin Service Create in domain: 'AII Content [ 2 |

Preset: iDefauIt v .Ii [[1show only personal presets

| Target | Exeaution || Users | Messages | Offer | Post-Action | Appiicabilty | Success Criteria | Action Seript
Target:

(®) Select devices
(O Dynamically target by property
() Enter device names

® 3 Applicable Computers (1) | Compu... 0s CPU 5
%HCQEEDZS.F... Linux Red Ha... 1900 MHz Xe... 0Y

(£ T 2]

[ 0K ] ’ Cancel ]

Using the input fields and tabs contained in the dialog you can specify exactly
how the selected action is to be deployed to the computers in your network. These
are the fields and the tabs contained in the dialog;:

Name Is the name of the action.
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Create in domain
Represents the domain where you want to store your custom action. All
Content is the top-level domain, and it includes objects from all domains.

Preset Specifies a preset customized action. There are two built-in presets
available, Default and Policy. Select Policy if you want to set no expiration
date for the action. You can also save your current input as a preset,
private or public, for later use.

Target tab
Contains the list of targets for the action. You can select the targets of the
action from the provided list, or use properties to filter a list or specify a
list of target computers. If you click Select devices you must select the
specific targets in the list. For more information about this tab, see
[Target” on page 145/

Execution tab
Contains the time constraints and retry behavior for the action run and
failure. For more information about this tab, see [“Execution Tab” on page]
207.

Users tab
Contains the settings to run the action based on which and if specific users
are logged on the computer. For more information about this tab, see
[“Users Tab” on page 246

Messages tab
Contains messages to display before or while the action runs. For more
information about this tab, see ["Messages tab” on page 217

Offer tab
Specifies whether or not to advertise the existence of programs or patches
that your networked Clients can choose to use. This grants extra control to
your users to customize their setup. For more information about this tab,
see [“Offer tab” on page 220,

Post-action tab
Lists the activities that must be done to complete the action, including
restart or shutdown. For more information about this tab, see [“Post-Actio

[tab” on page 223

Applicability tab
Contains the relevance clause that determines the applicability of the
action. For more information about the Relevance language, see
[[ntroducing the Relevance language| For more information about this tab,
see |“Applicability tab” on page 151.

Success criteria tab
Specifies what is intended as successful outcome for the action. This tab
lets you use different criteria to determine when a problem has been fixed.
For more information about this tab, see [“Success Criteria tab” on page]

Action script tab

Contains a script describing the action to run. The script is written using
the action language. An operator needs Custom Authoring permissions to
edit the action script. For more information about the action language, see
Introducing the action languagel For more information about this tab, see
“Action Script Tab” on page 139
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When you decide to run the action, click OK and enter your password. A progress
dialog is displayed to keep you informed about the deployment of the action. You
can also monitor how the action is being processed following the instructions
provided in [“Monitoring an action taken” on page 28

Take multiple actions

In the Take multiple actions dialog you specify the settings for deploying a set of
Fixlets or tasks in a single grouping.

As a requirement, each Fixlet or task involved in the group must have associated a
default action.

These is how you can accomplish this task:

1.

Right-click a selected group of tasks or Fixlets containing default actions.

2. Select Take Default Action. The Take Multiple Actions dialog opens.

3.

& Take Multiple Actions g@%

MName: | Multiple Action Group Create in domain: | All Content | i s

Preset: ! [Custom] Default v []show enly personal presets

Target 'Execution_ Users | Messages || Offer | Post-Action || Pre-Execution Action Script | Post-Execution Action Script | Applicability

Target:
(%) Select devices
) Dynamically target by property
) Enter device names

J Selected Computers (1) ;A Compu... 0s CPU

L|
=[5 By Retrieved Properties | | Fnco26028.r... Linux Red Ha... 1900 MHz Xe... 0Of
w-f2) By Computer Name
=1 By 0S
ili Linux Red Hat Enterprise Servel
By CPU
By Last Report Time
By Locked
By BES Relay Selection Method
By Relay
By User Name
By RAM
[ 3840 MB (1)
By Free Space on System Drive
By Total Size of System Drive
1 By Subnet Address :.V.i

E

oOODDDD

o ®

E

ayafa)

=)

[ Ok ] [ Cancel ]

In this dialog, specify how the selected actions must be deployed to the
computers in your network. The input fields contained in the dialog are the
same as those contained in the [‘Take action” on page 240| display with the
exception of the following additional fields:

Run all members actions of action group regardless of errors
This field belongs to the Execution tab and specifies whether the action
run should stop if an error occurs for one or more object of the group
or not.

Pre-Execution Action Script tab

Lets you specify an Action Script to run before the group of Actions is
deployed.
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Post-Execution Action Script
Lets you specify an Action Script to run after the group of Actions is
deployed.
4. When you finish editing, click OK to deploy the action.
5. Enter your authentication password and click OK. A progress dialog opens to
keep you informed about the stage of the deployment.

Target Tab

The Target tab can be found in various Action dialogs.

Target | Execution | Users | Messages | Offer | Post-Action | Pre-Execution Action Script | Pest-Execution Action Script | Applicability

Target:
@ Spectfic computers selected inthe list below
All computers with the property values selected in the tree below

The computers specified in the list of names below (one per ling)

# |59 Selected Computers (3] Computer M. 05 CPU Last Report Ti..  Locked BES Relay Sele...
5 By Retrieved Properties rperys WinT61.76.. 1000 MHzAM.. SO/20103:2%. Mo Automatic
4 5] By Group T 0 bl Bmr -
~ st o A WindP Med. ; 10:31 Y
b Esii g ¥ | mGDoG WinVista6... 3000 MHz Cor...  5/5/2000 3:1%.. No Manual
&> G group (2)
'-b M group (1)
I-'é Win group (3)

4 m R | [T [

When an Action becomes relevant, the Console operator can target a subset of
users to receive the action.

There are three radio buttons at the top of this dialog:

* Specific Computers selected in the list below. When you select this button,
only those Clients highlighted in the computer list receive the actions. This is the
default behavior. Note that you can filter this computer list by selecting items
from the tree view in the left panel. When you click OK, the selection of
computers in this list is frozen, the retrieved values are not reevaluated before
the action is deployed. Thus, if a computer is affected by this problem in the
future, it is not covered by this option. It trigger sthe same Fixlet, but requires
you to target it again.

* All Computers with the Retrieved Properties values selected in the tree below.
This button causes continued evaluation of IBM Endpoint Manager Client
computers for relevance if they match the selected properties. Unlike the
scenario described above, if a new computer is affected by this problem in the
future, it is automatically updated. You can also filter this set of relevant
computers using the retrieved property panel on the left. Because of the
open-ended nature of this function, you might want to use the Execution tab to
define an expiration date.

* The computers specified in the list of names below. This button allows you to
enter (or paste) a list of specific computers. Format the list with computer names
(as displayed in the Console), separated by newlines.

These options grant you great power over the deployment of Fixlet actions. Think
carefully about your choices here. The first button is the safest, because it describes
a static set of computers that you want to target. The second choice is more
powerful, because it continues to evaluate and automatically deploy relevant

Chapter 18. The Dialogs 243



actions, but it could also have long-term consequences that you should consider.
The third choice allows you to deploy to a specific list of computers, for fine-grain
control over your deployment.

This tab is available from several different dialogs:

Take Action, Take Multiple Actions and Edit Computer Settings.

Task List and Document

244

A list is created whenever you click Fixlets and Tasks from the Domain Panel
navigation tree. This list incorporates both Fixlets and Tasks, which you can filter
by opening the Fixlet and Tasks icon and clicking All Tasks beneath it.

File Edit WView Go Tools Help s
w Back = Forward = | @ Show Hidden Content v Show Mon-Relevant Content [::1' Refresh Console
All Content 4 Tasks Only Search Tasks'.
« B Ei’dEtS and Tasks (75) Marme . Applic.. Ope... Categn‘
g L_é' A_” 3 BES Client Setting: Client Ul Tray Mode Selection 6/6 0 BESE{
o {BES Client Setting: Communication Method 6/6 0 BES G
5 BES Client Setti PU Usage 6/6 0 BES Clii
: @ Aa|y5e5 @n BES Client #ftting: Download Throttling 6/6 0 BES Ch"
: [E' Actions (9) BES Client Setting: Enable Auto Relay Selection 6/6 0 BES Cli
. [5) Dashboards BES Client Setting: Enable Command Polling 6/6 0 BES Cli
» B5 Wizards BES Client Setting: Enable Debug Legging 6/6 0 BES Cli
» £5] Custom Content BES Client Setting: Enable/Disable Dynamic Thr.. 6/6 0 BES CI
0

o Custem Filters BES Client Setting: EnableWakeOnLanForwarding 6/6

BES Clj
A Lampuige 6 gt 055 el g g g b LG - g

The List Panel on the right now contains all the currently relevant Tasks. The Task
document is displayed in the Work Area of the Console when you click any item
in the list.
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Task: BES Client Setting: Communication Method = B
&7 Take Action = | »# Fdit | Copy =5 Export | Hide Locally Hide Globally | 3 Remove

Description :I}etails | Applicable Computers (§) | Action History (0)

Description

The BES Client has two methods of communication over the network. The first method
uses the Windows URL Monikers APL, which is a higher-level network interface that
uses the Internet connection settings for the local computer, such as proxy settings
secunty sethings, etc

The second method uses the winsock API, which is a lower-level direct socket access
layer that does not use the local Intermet connection settings. The BES Client uses the
URL Monikers method by default to connect to the Intemet. Using winsock will allow
BES Gather to connect to the Interet without using the Internet connection settings

m

Note: Do not set the "Reapply” behavior whan taking this action or you may cause the
BES Client to constantly reset this setting

Actions

® Click hare to have the listaed BES Clients use the winsock API

® Click here to have the listed BES Clients use URL Monikers

At the top of the Task document is the name. Beneath that is a toolbar with the
following tools:

* Take Action: This tool runs the default action of the Fixlet.

* Edit: This option lets you edit the Fixlet. This tool is only available for custom
Fixlets that you created yourself.

* Copy: This option lets you copy or clone the Fixlet to customize what it does.

* Export: This tool allows you to export the Fixlet for editing in an external editor.
* Hide Locally: Hides the Fixlet on this version of the Console.

* Hide Globally: Hides the Fixlet on all Consoles.

* Remove: Deletes this Fixlet (only available for Custom Fixlets).

There are several tabs in a Task document. They include:

* Description: A text version of the Task, describing the problem and offering one
or more Action buttons or links to resolve the issue. You can search any of the
HTML interfaces in the Console by pressing Ctrl-F and then entering your
search string.

* Details: A list of the properties, Relevance statements, and Actions that
constitute the Task.

* Applicable Computers: Lists the subset of computers that are targeted by the
Task.

* Action History: Shows the history of the Action deployment. This list is empty
unless the Action associated with the Task has already been triggered.

To display a Task list, click the Tasks icon under the Fixlets and Tasks icon in the
Domain Panel navigation tree.

A Task document is opened whenever you open an item in a Task list.
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Users Tab

The Users tab can be found in various action dialogs. In this tab you can fine tune
the delivery of actions based on the presence of users.

For example, you can target long installations to just those computers where the
users have logged off, ensuring that no downtime is incurred by the installation.

¢’ Take Action Q@@

Mame: | Install BES Server Plugin Service Create in domain: E-AII Content -:"v-;

Preset: Default v| [[]shaw only personal presets

:_Targ_et' Execution _5 Users '_Messgg_es | offer | Post-Action | a_pplicabiliq_ | Success Criteria | Action Script |
() Run only when there is no user logged on
() Run independently of user presence, and display the user interface to the selected users

) Run when at least one of the selected users is logged on, and only display the user interface to those users

Selected Users
(® all users

() Local users

(D) Users in the following groups:

I OK l ’ Cancel ]

This tab is available from several different dialogs:

+ [“Take action” on page 240|

* [“Take multiple actions” on page 242|

* |“Action Settings” on page 141

+ [“Edit Computer Settings” on page 197|

You can select one of the following options:

Run only when there is no user logged on
Choose this option for long installations that might happen overnight, but
only on logged-off clients.

Run independently of user presence, and display the user interface to the
specified users
This can be useful for critical patches or small, silent updates. You can
specify a set of users that are allowed to view the IBM Endpoint Manager
Client interface.
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Run when at least one of the specified users is logged on, and only display the
user interface to those users
Choose this option when the action requires feedback or intervention from
specific groups of users.

You can also select users and user’s group to interact with the user interface. Select
one of the following values:

All users
Click this button to select all users.

Local users
Select only local NT-Vista users .

Users in the following groups
Select users from the group below:

Add Domain Group
Add an Windows NT Domain group of users.

Add Local Group
Add a local Windows NT or Vista group to the set of users.

Add All Win9x Users Group
Add users who are logged in to Windows 9x Clients.

Add All WinNT Users Group
Add users who are logged in as Windows NT users.

Remove
Remove the selected user group from the list.

View action info

This dialog is available from any open Action document. Select the Computers tab
in the Work Area, right-click any computer in the list, and either select Show
Action Info from the context menu or select Show Action Info from the Edit
menu.

The View Action Info dialog displays information about a specific action for a
given computer.
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TROUBLESHOOTING: Run BES Client Diagnostics {LinuxiUNIXMac)

* Summary

Siatias
Btar Tima
End Tine

Exit Code

Thee:-action executed successhly
This acticn has been applied 1 time and will not be apphied again

Compisted
DBAOT/2093 13 11.3
QBM7I2012 13114
0

Completed

Completed

Completed

Completed

= Action Scripl Execution Detail

A4 Femove previous rons clisnt disgnostics if found

deliece "ipreceding cext of last "/" of {client folder of
current site as atringhl & "/ClientDiagnostics " &
computer name: & ".tar.gz"i"

delete " ipreceding text of last "/BESCIient" of {client
folder of current site as stringl) & "/ClientDiagnostics ™
& Computer name & ".car.gz"in

delete "iipreceding text of last /" of {client folder of
cUITent site as stzinghl &

"f o GlobalfAzchive/Last/client O ClientDisgnostics " §
computes name & ".tar.oz"i"

e

Title Shows the title of the Fixlet or task that initiated the action.

Summary

A summation of the action deployment for this computer. It includes the
current Status, the Start and End Time for the run of the action, and any
Exit Code that might be returned by the action.

Action Script Execution Detail
The result of each step included in the triggered action.
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Visualization Parameters: Colorization

The Colorization tab of the Visualization Parameters dialog lets you customize the
colors for a graphical representation of your network.

Vizualization Parameters Dq.hg 5 g

- o

Preset: |[CustumJDquH =l Shaw only personal presets { Save Preset...
General | Colonzation | Computers

Celarize Computers By:

Frlet Mef.sag; Relevance -
4 [y Relevant Messages [7) Mame Source Severity | Site
i"_j B‘:(ﬁnur:e SMrll':f = =
= By S Admanistratrve Login Meeded Important BES Support
'—‘ & E'“: i Wersion of Dbmslpon.dll May Cause Handle Le...  Important BES Support
_'—] 35: E::r} Windows Firewall is Blocking BES Traffic - Win... Important BES Support
I_,_,J Wi Restart Meeded Moderate BES Support
(= | E\l( Source Release Date
Restart Meeded - Mot Triggered by a BES Action  Moderate BES Support
BES Quick Reference - Production Low BES Support
Fdet with Wizard Master Action §
‘ e ¥
ok |l cancel

This tab offers four different ways to color the data, available from the main
pull-down menu:

No colorization: Select this option to have every computer displayed as white.

Fixlet Message Relevance: Color each computer based on the Relevance
(applicable or non-applicable) of specific Fixlet messages. Specify the Fixlet
message in the filter/list box below.

Baseline Relevance: Color each computer based on the Relevance (applicable or
non-applicable) of specific Baseline groups. Specify the Baselines in the filter/list
box below.

Retrieved Property: Select the colors of the BigFix Client computers based on
the specified retrieved property.

Action Status: Base the colors of the computers on the current status (completed,
open, expired) of a specified action. Specify the Action in the filter/list box
below.

Relevance Clause: Color each computer based on a Relevance Clause, as
specified in the text box below.

This dialog is available by selecting Tools > Launch Visualization Tool >
Colorization.
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Visualization Parameters: Computers

The Computers tab of the Visualization Parameters dialog lets you limit the
number of computers to be graphed.

Visualizetion Parameters Dralog - — - M
Preset: Ilﬁustun'I] Default = | [T Shew only personal presets Save Preset... Delete Preset
General | Colonzation | Computers

Shaw all computers in visualization
@ Show only selected computers in visualization

a4 (58 AN Computers [3) Computer M... OS cpu Last Repert Ti..
i W Rcxrieve Pavpotie: TESTING Win7 6.0.76... 1000 MHz AM...  5/10/2010 3:34,
4 5 By Group MOMBAA WinkP Med... 3400 MHz Pen...  5/9/2010 10:16)
et i (2 1
W, edems group &) BIGDOG WinWista 6... 3000 MHz Cor..  5/10/2010 3:28)

% 5] gnoup LZ)

% M group (1)

& Win group (3)
‘ m ¥
|| e e
QK Cancel |

This tab has two buttons to make your selection easy.

* Show all computers in visualization: This is the default option, allowing all
Clients to be displayed

* Show only selected computers in visualization: This option opens a computer
filter/list allowing you to specify any subset of computers in your network by
retrieved properties or groupings.

This dialog is available by selecting Tools > Launch Visualization Tool >
Computers.
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Visualization Parameters: General

The General tab of the Visualization Parameters dialog helps you to customize a
graphical representation of your network.

Visualization Pararneters Dialog @
Preset: | Default b4 Show only personal presets

General | Colorization | Computers

@ Use Trvoli Endpoint Manager Relay structure

Use Active Directory Structure

Use IP Address Structure

Use Retrieved Property Path Structure
Path Retrieved Property:
Path Separator String:

everse Path Hierarch

Show labels on leaf nodes

OK | | Cancel

There are several ways to represent the data:

* Use Relay structure: Display the network tree from the BigFix Relay point of
view. This is the default view.

* Use Active Directory Structure: Use the Active Directory to map out the
network tree for visualization.

* Use IP Address Structure: Use the IP architecture to map out the network tree.

* Use Retrieved Property Path Structure: Use standard or custom properties of
the client computers to map out a custom network tree. If you select this option,
you must specify the path-style property that you want from the section below:

Path Retrieved Property: This pull-down menu lists the available BigFix
Client properties. Select one of these to define the network graph. A
path-style property has a separator string to delimit the parts of the path. For
example, if you use an IP address as a path, you would select a period as a
separator. Another example is an actual directory path, where the delimiter is
a backslash. You can also create your own custom paths by concatenating
fields with your own chosen separator.

Path Separator String: Enter the delimiter you want to use to parse the path
specified above. For example, to create a hierarchy from a directory path, use
"\" as a separator string.

Reverse Path Hierarchy: Check this box if your chosen path-style property
has the most significant part on the right instead of the left.

Use first result if the computer has more than one result for this retrieved
property: Many properties return a list, rather than a single item. These
values can be ignored, or you can check this box to have the first element in
the list used for the network map.
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— Group computers with the same retrieved property value: This option
creates easy-to-visualize groups from computers sharing the same property.

* Show labels on leaf nodes: Check this box if you want to display labels next to
the computers at the leaf nodes of the network tree.

This dialog is available by selecting Tools > Launch Visualization Tool...

Visualization Tool
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The Visualization tool allows administrators to view and manipulate data from
their network. To start this tool, Select Launch Visualization Tool from the Tools
menu. A dialog opens allowing you to set certain parameters:

Visualization Parameters Dialog

Preset: [ Default A Show only personal presets
General Colorization | Computers
@ Use Trvoli Endpoint Manager Relay structure
Use Active Directory Structure
Use IP Address Structure
Use Retrieved Property Path Structure
Path Retrieved Property:

Path Separator String:

Reverse Path Hierarch

Show labels on leaf nodes

| oK | | Cancel |

This dialog allows you to load and save your preset preferences to customize
individual views of your network. The presets are managed with a simple
interface:

* Preset: Select a named set of options from this pull-down menu of
previously-defined preferences.

* Show only personal presets: Check this box to filter down the list of presets to
just those you personally created.

* Save Preset: Click this button to save the current set of preferences as a named
preset.
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r 5
Save Visualization Preset s dk e

Mew Preset Mame:

Show Propagating Acticns

.....

QK | | Cancel

L% =

You can choose to make your presets private, or you can share them with other
Operators. Later, if you want to change the parameters of this preset, open it,
make the changes, and save it with the same name. You are asked to confirm the
update.

* Delete Preset: Deletes the currently selected preset.

Below the Preset interface, there are three tabbed areas:

* General: Describe the network hierarchy according to the specified structure.
* Colorization: Set up a coloring scheme for the display.

* Computers: Select all computers or a specified subset.

Before running the tool, your options are checked for completeness. If they pass,
the Visualization tool runs with these values.

B BES Metwork Visualization = =] S

File Wiew Navigation

Controls

Descendants:
e , .
“ ity 14 [ icer

ILDREN: & . [hire]
n

With this panel, you can display network locations, relay hierarchies, Active
Directory domains, and other administrator-defined hierarchies. The tool is
3-dimensional and you can rotate the graph to better visualize the network.
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The tool makes it possible to view a real-time graphical network map showing
Fixlet message status, Action status, Retrieved Property information, and much
more. For example, you could view all computers that are currently unpatched for
a specific Fixlet across your enterprise, and watch the clients change from red to
green as the patch is propagated.

This dialog is available by selecting Tools > Launch Visualization Tool. You must
enable hardware acceleration and OWC, if you have not done so already.
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Appendix. Support

For more information about this product, see the following resources:
+ [IBM Knowledge Center|

+ [IBM Endpoint Manager Support site|

+ [[BM Endpoint Manager wikil

+ [Knowledge Base]

+ [Forums and Communities|
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http://www-01.ibm.com/support/knowledgecenter/SS63NW_9.2.0/com.ibm.tivoli.tem.doc_9.2/welcome/IEM92_landing.html
http://www.ibm.com/support/entry/portal/Overview/Software/Tivoli/Tivoli_Endpoint_Manager
https://www.ibm.com/developerworks/mydeveloperworks/wikis/home?lang=en#/wiki/Tivoli%20Endpoint%20Manager/page/Home
http://www-01.ibm.com/support/docview.wss?uid=swg21584549
http://www.ibm.com/developerworks/forums/category.jspa?categoryID=506
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Notices

This information was developed for products and services that are offered in the
USA.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive, MD-NC119
Armonk, NY 10504-1785
United States of America

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing

Legal and Intellectual Property Law
IBM Japan Ltd.

19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM websites are provided for
convenience only and do not in any manner serve as an endorsement of those
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websites. The materials at those websites are not part of the materials for this IBM
product and use of those websites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
274A/101

11400 Burnet Road
Austin, TX 78758 U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.

This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:
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This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

Portions of this code are derived from IBM Corp. Sample Programs.

© Copyright IBM Corp. _enter the year or years_. All rights reserved.

Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the web at [www.ibm.com /legal /|
[copytrade.shtml|

Adobe, Acrobat, PostScript and all Adobe-based trademarks are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States,
other countries, or both.

IT Infrastructure Library is a registered trademark of the Central Computer and
Telecommunications Agency which is now part of the Office of Government
Commerce.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

Linux is a trademark of Linus Torvalds in the United States, other countries, or
both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

ITIL is a registered trademark, and a registered community trademark of The
Minister for the Cabinet Office, and is registered in the U.S. Patent and Trademark
Office.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java™ and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.
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Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the
United States, other countries, or both and is used under license therefrom.

Linear Tape-Open, LTO, the LTO Logo, Ultrium, and the Ultrium logo are
trademarks of HP, IBM® Corp. and Quantum in the U.S. and other countries.
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Permissions for the use of these publications are granted subject to the following
terms and conditions.

Applicability

These terms and conditions are in addition to any terms of use for the IBM
website.

Personal use

You may reproduce these publications for your personal, noncommercial use
provided that all proprietary notices are preserved. You may not distribute, display
or make derivative work of these publications, or any portion thereof, without the
express consent of IBM.

Commercial use

You may reproduce, distribute and display these publications solely within your
enterprise provided that all proprietary notices are preserved. You may not make
derivative works of these publications, or reproduce, distribute or display these
publications or any portion thereof outside your enterprise, without the express
consent of IBM.

Rights

Except as expressly granted in this permission, no other permissions, licenses or
rights are granted, either express or implied, to the publications or any
information, data, software or other intellectual property contained therein.

IBM reserves the right to withdraw the permissions granted herein whenever, in its
discretion, the use of the publications is detrimental to its interest or, as
determined by IBM, the above instructions are not being properly followed.

You may not download, export or re-export this information except in full
compliance with all applicable laws and regulations, including all United States
export laws and regulations.

IBM MAKES NO GUARANTEE ABOUT THE CONTENT OF THESE
PUBLICATIONS. THE PUBLICATIONS ARE PROVIDED "AS-IS" AND WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING
BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY,
NON-INFRINGEMENT, AND FITNESS FOR A PARTICULAR PURPOSE.
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